Windows 8 and 8.1 Forums


Ethernet port not detected in device manager

  1. #1


    Posts : 53
    Windows 8.1 Pro

    Ethernet port not detected in device manager


    Hi Guys,

    Using windows 8.1 and ubuntu in dual boot on my laptop.

    When i thether my iphone in ubuntu and connect to internet using USB,the Ethernet connection works.

    Now strangely in my windows setup,i cant find my Atheros Ethernet in device manager nor even in Network and Sharing center.

    When i use iphone as personal hotspot in wifi,the connection drops intermittently and i have to re connect always.

    I did reinstall my ethernet drivers but the problem persists.

    Any help will be appreciated

      My System SpecsSystem Spec

  2. #2


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Not seeing the LAN adapter in Device Manager is strange. How about in Hidden Devices? I would start by running sfc /scannow.

    If you run in Safe Mode with networking what happens?
      My System SpecsSystem Spec

  3. #3


    Posts : 53
    Windows 8.1 Pro


    Thanks Popeye.

    Where can i find this "hidden devices" settings??

    I did run sfc /scannow and rebooted but problem persists.Rebooting to safe mode didn't make a difference either.

    I thought maybe its a hardware issue of my LAN adaptor but the same is working flawlessly in Ubuntu.In fact right now i am typing on Ubuntu using wired connection.
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    When you click View at the top of Device Manager there should be an option to show hidden devices.

    What model of atheros adapter is it? Are your PCI/cipset drivers in System devices up to date also? I would re-install all chipset and network drivers listed on the Dell site for your laptop.
      My System SpecsSystem Spec

  5. #5


    Posts : 53
    Windows 8.1 Pro


    Hi Popeye,

    I did find the Atheros AR8152 PCI-E Fast Ethernet Controller in hidden devices.i uninstalled the device and rebooted my system.
    Downloaded the latest drivers from Dell site.Installing the driver gives me the error "Installer cant find the Atheros controller on your system".

    obviously i still cant fine the adaptor in device manager.

    What is the next step??
      My System SpecsSystem Spec

  6. #6


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Honestly a bit stumped since you say it is recognized in Ubuntu. Windows repair install maybe, perhaps someone else has some ideas.
      My System SpecsSystem Spec

  7. #7


    Posts : 53
    Windows 8.1 Pro


    Thanks for your help Popeye.I am stumped too as the ethernet controller is working perfectly fine in ubuntu.In fact i am typing this post on ubuntu with my iphone connected through the USB wire.
      My System SpecsSystem Spec

Ethernet port not detected in device manager
Related Threads
If you have ever wanted to change that boring "HID-compliant Mouse" title to something more descriptive, this tutorial is for you. The name of any device can be modified with this method and can help you organize your devices better in Device Manager. First, open Device Manager by opening a run...
Well, I just ordered a new laptop - the Dell Inspiron 15 7000 (7548) ... i7 5500u , 8gb ddr3, intel ac 7260 dual band. I use an Acronis WinPE USB drive to deploy/create images on my computer, and normally I have an ethernet cable connected which allows me to save/get the images on my 1TB drive...
BSOD then no GPU detected in device manager in BSOD Crashes and Debugging
Hi, im having problem with my MSI 620DX notebook wich have integrated intel family 3000 graphic card as well as GT555M.. problem is that BSOD randomly occurs when im browsing the web and then after restart my GT555M is not detected in device manager and then on another day it is back there until...
The cable works on a different computer, the computer gets wireless fine (typing to you from it) but will not read an ethernet cable. The motherboard manual (built the PC myself from components) says an LED should light-up if an ethernet cable is connected, no such LED appears when I connect the...
Ethernet port not working in Network & Sharing
just noticed my Vaio ethernet port isn't working. it says the adaptor is working normally, but when I plug in an ethernet cable is says the cable is not plugged in. I tried it with two different cables that work elsewhere. I wonder if the laptop ethernet card is faulty? Wireless is working...
Hi All, I'm having a rather annoying issue on Windows 8 with my ASUS Laptop. When moving from Wi-Fi to Ethernet (disable Wi-Fi, plug-in Ethernet cable then enable Ethernet port) my computer fails to recognize the Ethernet connection. I have to restart my computer to solve the problem. Is...
Hi All, Getting a strange error with Hyper-V on Windows 8 Pro x64. When I try and add a virtual switch I get: Error Applying Virtual Switch Properties Changes Failed while adding virtual Ethernet switch connections. Ethernet port '{a bunch of stuff}' bind failed: The data is invalid....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook