Windows 8 and 8.1 Forums


Unable to enable Ethernet connection after fresh install

  1. #1


    Posts : 3
    Windows 8.1

    Unable to enable Ethernet connection after fresh install


    Hey guys,

    I just installed Windows 8.1 from disc. I am using an ASUS P8Z77VLX Motherboard for this.

    I just installed all of the drivers for my motherboard but the Ethernet connection was not detected. I went into network settings to find there were now two Ethernet connections, one enabled, the other disabled. The disabled one apparently was added by my motherboard drivers. I attempt to enable it, it says its enabling, and then nothing happens. The windows says its enabled, and it isn't. It doesn't ever appear to actually change.

    I ran an sfc /scannow and got no errors.

    So, at that, I'm out of ideas. Any help would be greatly appreciated.

    Note: I do not have a Wifi adapter on this desktop, only Motherboard Ethernet available.

      My System SpecsSystem Spec

  2. #2


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Welcome to the forum!

    Did you try uninstalling the adapter(s) in Device Manager then reboot and let re-install?
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8.1


    Yes.

    Also, here is some technical data I found.
    Device PCI\VEN_8086&DEV_1E3A&SUBSYS_84CA1043&REV_04\3&11583659&0&B0 was configured.
    Driver Name: null Class Guid: {00000000-0000-0000-0000-000000000000} Driver Date: Driver Version: Driver Provider: Driver Section: Driver Rank: 0x0 Matching Device Id: Outranked Drivers: Device Updated: false
    Path: PCI\VEN_8086&DEV_1E3A&SUBSYS_84CA1043&REV_04\3&11583659&0&B0
    Hardware IDs: PCI\VEN_8086&DEV_1E3A&SUBSYS_84CA1043&REV_04 PCI\VEN_8086&DEV_1E3A&SUBSYS_84CA1043 PCI\VEN_8086&DEV_1E3A&CC_078000 PCI\VEN_8086&DEV_1E3A&CC_0780

    The PCI Simple Communications Controller not having a proper driver appeared to be the issue, but I installed Intel Management Engine, resolving the PCI Simple Communications issue, but the ethernet connection still does not detect a cable.
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    You're sure cable is good?

    A search did reveal others having same problem with your motherboard.
      My System SpecsSystem Spec

  5. #5


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Which Ethernet chip do you have? The Asus site shows either Intel or Realtek drivers.

    Click image for larger version
      My System SpecsSystem Spec

  6. #6


    Posts : 3
    Windows 8.1


    I'm not sure.

    I don't know how, but the issue somehow resolved itself.
      My System SpecsSystem Spec

  7. #7


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Well, that's good. If it happens again it could be your cable.
      My System SpecsSystem Spec

Unable to enable Ethernet connection after fresh install
Related Threads
Ethernet connection in Network & Sharing
Hi,I have an Acer Aspire E1-572 laptop. Went to connect it to my router via an Ethernet cable but failed to have connection,It works okay on wifi but not on the Ethernet the square box don't show next to the clock.I have looked in device manager for any yellow exlamation marks and none to be seen....
Hello, I'm in a twist and I'm not exactly sure what the problem is. I bought a new laptop with Win8 pre-installed (and immediately updated it to 8.1). I decided after a week to buy an SSD and installed Win8. I now find there is no product key to be found, and can't seem to activate Windows....
Hey guys, I had a hard drive crash the other week and I got a new one and went on and upgraded to windows 8.1 64bit. Well I had a hard time getting it to work correctly but now it seems to start up fine with no BSOD. My problem I'm having now, is that my internet will not work on it, unless I...
I'm sorry but I'm new at this but I'm at a loss at what I'm suppose to do. Just got in the mail 2 ssd's and the HD7870 video card along with a copy of windows 8.1 complete (retail). My boot ssd (one I'm trying to install on) is a 60gb Mushkin and the other is the one I was going to put games on...
Hello, I have been having issues with sharing my internet connection via an ethernet cable. I read online that there is the ability to 'share' your internet connection. I have learned how to do this, but it doesnt work for me. I tried connecting my laptop. I went through everything and I was able...
Hello everyone, I am facing a problem recently. I hope anyone of you can help me to solve it. Recently I have been installed Windows Eight Pro 64-bit in two of my desktop computers. One pc having motherboard Intel DG41 and the other one is Asus Sabertooth P55i. I have two external Realtek NIC...
Hi All, I'm having a rather annoying issue on Windows 8 with my ASUS Laptop. When moving from Wi-Fi to Ethernet (disable Wi-Fi, plug-in Ethernet cable then enable Ethernet port) my computer fails to recognize the Ethernet connection. I have to restart my computer to solve the problem. Is...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook