Windows 8 and 8.1 Forums


Win 8.1 limited wi-fi again, no usual solution is working

  1. #1


    Posts : 3
    Win8

    Win 8.1 limited wi-fi again, no usual solution is working


    Hi everyone!
    I am strugguling with this for abou half year. Its this usal thing ****ed up differently.

    After i connect to any network, it says limited intead of connected. I can see the name of the network and etc. But no valid IP is assigned.

    I have tried the usual solutions and they arent working (shut down device for PS mode, etc.).

    And here comes the fun: Eventhough DHCP is always on in the network adapter menu, after going to cmd's ipconfig /all it keeps saying "DHCP enabled: No".

    Do you have any ideas how to reinstall only DHCP or any other solution?

    I have Lenovo G700 and some Atheros Wifi adapter.

    thank you

      My System SpecsSystem Spec

  2. #2


    Are you able to log into the router from your pc ?
    Make sure the routers dhcp mode is enabled.

    Make sure the subnet mask is the same on your pc's adapter settings as the router.
    Try putting your settings to automatic in the adapter settings on your pc.
      My System SpecsSystem Spec

  3. #3


    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10


    Hi there

    This can sometimes be caused by OTHER devices (Phones for instance) grabbing an IP address (Media servers / NAS drives, network printers etc.

    SWITCH OFF every network device you have INCLUDING PHONES. Restart the router and then start the COMPUTER BEFORE TURNING ON YOUR PHONE. If you have any Smart TV's also turn them OFF --Power off completely -- not on STANBY. Also if you have a wifi extender turn that off too.

    I know that's hard for anybody under about 35 these days but Phones do actually have an OFF switch.

    Cheers
    jimbo
      My System SpecsSystem Spec

  4. #4


    Posts : 3
    Win8


    Hi,
    i may seem dumb as rabbit, but im not. I have the same trouble even connecting through ethernet cable. I tried reseting the router's settings but that doesnt work. The troubles continue, even though i connect to any network (home, work, school, random airport, coffe shop, whatever).

    I am trying to figure out any other way then to reinstall windows, which would cause big trouble.

    Cheers,
      My System SpecsSystem Spec

  5. #5


    On your PC, hold your mouse over the internet picture in the bottom right task bar, what does it say there ?
      My System SpecsSystem Spec

  6. #6


    Posts : 3
    Win8


    Quote Originally Posted by dannyk90 View Post
    On your PC, hold your mouse over the internet picture in the bottom right task bar, what does it say there ?
    It only says limited with yellow varning sign on it. It does the same thing on cable connection icon.
      My System SpecsSystem Spec

  7. #7


    Posts : 74
    s: XP, Win7, Win8, Ubuntu


    I had an odd situation last week. My Toshiba WiFi for Win7 would not work at my friend's house (works fine at mine). Being that the laptop is multiboot, I rebooted under Win8.0, in which the WiFi worked fine. So even though Win7 worked great at home, I was forced to go to the Toshiba support site and download the latest WiFi driver. After reinstallation, it worked fine. It was strange.

      My System SpecsSystem Spec

  8. #8


    Quote Originally Posted by kejklir View Post
    Hi,
    i may seem dumb as rabbit, but im not. I have the same trouble even connecting through ethernet cable. I tried reseting the router's settings but that doesnt work. The troubles continue, even though i connect to any network (home, work, school, random airport, coffe shop, whatever).

    I am trying to figure out any other way then to reinstall windows, which would cause big trouble.

    Cheers,
    Check whether "DHCP Client" service started in Services.
      My System SpecsSystem Spec

Win 8.1 limited wi-fi again, no usual solution is working
Related Threads
Hello! I've recently run into a problem with a Hotmail or an Outlook account. Before, it used to work without problem, but I'm not sure if something has changed by the site itself. I used to open a Hotmail account using Chrome. and the Mail App that comes with Windows 8. just a week or so it asks...
Right, i've been having this problem since I THINK starting to use a HDMI wire. But now, i cannot get any audio from the audio jacks, they are detected, but no sound is produced and I just cannot figure it out. I've disabled the HDMI, installed, un-installed, re-installed audio drivers and pretty...
Hi everyone, Lately my computer has been distorting sounds and been going slower than it used to. When I restart the computer, the amount of distortions/small sizzling sounds is at a minimum, but it increases as I continue to use the computer. I googled how to fix this and one of the suggestions...
Hi All, First off, everything is working OK once it is finally connected. I have two wifi inputs to my laptop. The internal Intel wifi-adapter is tethered to my cell phone at 2.4GHz. The other, an N600 TP-Link adapter is connected via the access point of my router which is locked to using the...
Hi I just installed W8.1 on my Laptop, I formatted the hard drive and did a clean install, when I opened Internet Explorer it went to my usual home page?? How is that possible? I have not set up a home page since installing W8.1. Very curious. Cheers
Eight Forums Android App Eight Forums IOS App Follow us on Facebook