Windows 8 and 8.1 Forums


Would Downgrading to Windows 8.0 Solve My Connection Bugs?

  1. #11


    Posts : 299
    Windows 8 Pro


    Yes see if it still has a problem when it is charging.

      My System SpecsSystem Spec

  2. #12


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Quote Originally Posted by Plushieluver101 View Post
    Quote Originally Posted by adamf View Post
    You've not filled in the model number. Googling the motherboard ZBWAA and the processor N2840 indicates it could be a satellite model C50-B or C55-B. If that looks right (you can check your model by looking on the sticker on the back - FAQ: Where is my model and serial number on my Toshiba laptop) you can get drivers from Satellite C55-B5200 Support | Toshiba

    I have. It says C50-B something. Probably filled the wrong box. Sorry!
    Quote Originally Posted by Vincenzo View Post
    This fix from Dell supposed to help on other brands too.
    How to Fix Limited Wi-Fi Connectivity Issue in Windows 8.1 | Dell India

    Also does the problem only happen when you run on battery power? there is a different fix for that.

    And did you tell the computer not to sleep the wifi adapter?

    I'll try that Battery power? I think it's always on battery power, as it's on a laptop, no? Unless you mean the difference between charging and not, then I don't know. I'll have to check that theory out.


    I have no idea how to do that, so I guess not? Do I need to do something with it?
    Quote Originally Posted by Vincenzo View Post
    Yes see if it still has a problem when it is charging.
    Good point! I do have my laptop plugged in 99.9% of the time. Only unplug it every so often to drain the battery to keep it healthy.
      My System SpecsSystem Spec

  3. #13


    Posts : 25
    Microsoft Windows 8.1 64-bit


    Quote Originally Posted by Vincenzo View Post
    Yes see if it still has a problem when it is charging.
    Quote Originally Posted by popeye View Post
    Quote Originally Posted by Plushieluver101 View Post
    Quote Originally Posted by adamf View Post
    You've not filled in the model number. Googling the motherboard ZBWAA and the processor N2840 indicates it could be a satellite model C50-B or C55-B. If that looks right (you can check your model by looking on the sticker on the back - FAQ: Where is my model and serial number on my Toshiba laptop) you can get drivers from Satellite C55-B5200 Support | Toshiba

    I have. It says C50-B something. Probably filled the wrong box. Sorry!



    I'll try that Battery power? I think it's always on battery power, as it's on a laptop, no? Unless you mean the difference between charging and not, then I don't know. I'll have to check that theory out.


    I have no idea how to do that, so I guess not? Do I need to do something with it?
    Quote Originally Posted by Vincenzo View Post
    Yes see if it still has a problem when it is charging.
    Good point! I do have my laptop plugged in 99.9% of the time. Only unplug it every so often to drain the battery to keep it healthy.

    How come charging would make a difference to the Wi-Fi?
      My System SpecsSystem Spec

  4. #14


    Posts : 299
    Windows 8 Pro


    When you are operating on battery only the computer can go into a mode designed to save power, and some older routers cannot handle that mode. You can find documentation in various places on the web, here is one:
    http://www.thewindowsclub.com/poor-w...rmance-windows
      My System SpecsSystem Spec

  5. #15


    Posts : 299
    Windows 8 Pro


    Here's how to tell the computer not to sleep the wifi adapter:
    http://www.thewindowsclub.com/wifi-g...ed-after-sleep

    Did you check the driver as per the Dell page posted earlier?
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
Would Downgrading to Windows 8.0 Solve My Connection Bugs?
Related Threads
Hello everyone :D this is my first post im making on this site. :) I've noticed some bugs on Windows 8.1 (+Update 1) that havent been fixed by microsoft yet. 1)Shortcut arrow Bug:Ever since i upgraded to 8.1 Some arrows on my shortcuts wont load(For sometime),others will,others will load then...
Hey all! I encountered 2 very annoying problems with YouTube on Internet Explorer 11 after installing Windows 8.1 and I hope someone might have a fix for this. Problem no 1.: For some reason, I'm not able anymore to click on the videoscreen instead of the tiny Pause button to pause the video...
whenever i restart my laptop it freezes before lock screen (nothing shows up except black screen)and only solution is by putting my computer to sleep and than wake him up.. :p other bug is this... happens some times... http://imageshack.us/a/img713/9420/dowy.th.png and 1 other bug is even my...
Downgrading to Windows 7 in Installation & Setup
So my laptop came with Windows 8 preinstalled and I'm going to downgrade to Windows 7, but if ever I want to go back to Win 8 in a future, I'll need an OEM installation media as my license is OEM, discs were not supplied, however there's a recovery partition on my drive. My question is: are...
Windows 8 bugs in General Support
I am new to the forum, i just installed windows 8 pro and updated, and i found some bugs and i want to share also want to know if someone has it too. Sometimes IE 10 metro and desktop version couse (display driver stopped responding and has recovered) i have sapphire 6850 1GB and 12.10 latest...
This is a thread for everybody to share what bugs that they have found in Windows 8. My first bug is that if you shutdown with the fast startup enabled, then the system thinks it's in hibernate. This is a bug that really needs to be resolved.
Post your Windows CP bugs here in General Support
Hi, I haven't seen a CP bug thread yet so here goes: "Non-existent" window: 4308 This sometimes shows with the Windows Explorer icon same "preview". Metro start menu search with more than about 150 results causes the computer to freeze for about five seconds if you click "Files".
Eight Forums Android App Eight Forums IOS App Follow us on Facebook