Windows 8 and 8.1 Forums

LAN doesn't work on Acer Aspire V5 573G

  1. #1

    Posts : 5
    Windows 8.1

    LAN doesn't work on Acer Aspire V5 573G EDIT! New problem


    I just bought Acer Aspire V5-573G laptop

    I can access the internet with wifi, no problem, but I can't access with cable.
    I upgraded to SSD today so it has been reinstalled and still doesnt work.
    It seems to notice the cable but it shows a "!" and says Limited.
    I'm running on Windows 8.1 64bit
    I really want to try everything before sending it to repairs.

    Any ideas?

    Last edited by SnowStorm; 29 Jan 2015 at 07:14.

      My System SpecsSystem Spec

  2. #2

    Posts : 2,690
    Windows 3.1 > Windows 10

    check the LAN plug there are two small LED's both lit when LAN cable plugged in..

    Also verify that the driver you installed from OEM is for windows 8.1 x64

    another option is to go into device manager and remove the driver and see if MS Update has a driver for it
      My System SpecsSystem Spec

  3. #3

    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit

    Have to ask.....tried different cable? Also try Safe Mode with networking and see if it works.
      My System SpecsSystem Spec

  4. #4

    Also, go to the ACER site and get the latest driver for the NIC, and make sure to get the one for 64 bit or 32 bit depending on your OS.
      My System SpecsSystem Spec

  5. #5

    Posts : 5
    Windows 8.1

    Thanks for the replies. It just started working so we won't complain.

    New problem!!

    The wifi this time.
    On cable I get 92-94mbps in speed tests, and I have always got the same with wifi.
    Now, I only get 20-40mbps.
    There are 3 drivers from Acer that I can download, but no where it says who is the manufacturer of this card.
    I must have the wrong driver?
    Any ideas?
      My System SpecsSystem Spec

  6. #6

    See if ACER has a utility to look at your ACER and to install the correct drivers.
      My System SpecsSystem Spec

LAN doesn't work on Acer Aspire V5 573G
Related Threads
Hey So basically when I plug in an Ethernet cable my wireless adapters and wireless autoconfig services automatically disable, and when I enable them, they disable immediately. I want to use my laptop as a hotspot for my phone but it keeps saying wireless auto config service is not running! ...
Acer Aspire Switch 11 in Drivers & Hardware
I might be buying(in the future) the Acer Aspire Switch 11(with I5 Core) to replace my Windows 8 tablet Acer Iconia W700(I5 Core) because it is lighter, thinner, and has a keyboad dock(with trackpad) and it has a extra/built in battery inside the keyboard dock as well. :) So When is Acer...
Acer aspire v5 low fps when unplugged in Performance & Maintenance
hi i have an acer aspire v5-473pg with windows 8 installe i5 and with nvidia geforce 740m my problem is as up some updates ( i really dont know if windows update or nvidia) changed my laptop performance. my laptop can play dota 2 around 50-60 fps plugged or unplugged. Its like saving power when...
acer aspire one D270 in Drivers & Hardware
my acer aspire one D270 has some driver does not work after l instal eight os .:)
So many problems with this comuter it is even difficult to write this post. Anyone having problems with this laptop? Win8 works much better on my Samsung Ativ.
Solved Acer laptop fn key doesn't work in Drivers & Hardware
For some reason my brand new Acer laptop doesn't have a functioning fn key. Everything else is perfect though, as it should be coming right from the box. I can't quickly mute, change screen brightness or put my computer to sleep. This is very annoying. Do I need to install a driver even though the...
acer aspire resolution in Graphic Cards
here's a reg tweak to get resolution needed for win 8 on acer aspire. I do not know anymore than what is in the article. Windows 8 on Acer Aspire One Netbook - Screen Resolution etc... - Http Client Protocol Issues - Site Home - MSDN Blogs
Eight Forums Android App Eight Forums IOS App Follow us on Facebook