Windows 8 and 8.1 Forums


Dell Inspiron 5547 won't detect wireless network adapter

  1. #1

    Dell Inspiron 5547 won't detect wireless network adapter


    My Dell Inspiron won't connect to the internet via WI-Fi. But all other devices connect to it just fine.
    I can only get access to the internet using an Ethernet cable.

    I had this problem before, but it just magically solved itself after about 20 minutes of not doing anything. But it's been a whole day now, and nothing seems to work.

    When I go on device manager, under Network adapter, it only lists one:
    Realtek PCIe FE Family Controller
    And there's no exclamation mark or anything beside it.

    I've tried:
    -Restarting the computer
    -System restore
    -Restarting router
    -System BIOS boot (A Dell representative walked me through the process)
    -Download and installed wireless network driver adapters from Dell support page
    -In device manager, tried to 'Scan for hardware changes'

    Any help would be greatly appreciated in solving this mystery!

    edit: Airplane mode is off
    Last edited by Vanille; 12 Jan 2015 at 11:52.

      My System SpecsSystem Spec

  2. #2


    Posts : 47
    Windows 8.1


    Did you turn Airplane Mode on?
      My System SpecsSystem Spec

  3. #3


    No, Airplan mode is off xD
    I should have mentioned that earlier
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Well, can't rule out a bad card. They are fairly cheap and easy to replace in most cases, just be sure to get a Dell compatible one. There are also USB options.

    Check to make sure the adapter is seated securely in the slot.

    Maybe take it somewhere to see if it will connect to a hot spot. I doubt it though if the adapter doesn't appear in Device Manager.
      My System SpecsSystem Spec

  5. #5


    Posts : 5
    Windows 8.1


    I'm also experiencing this. Any solution?
    does my wireless card is broken?
    do i have to open and reposition or replace the card?
      My System SpecsSystem Spec

  6. #6


    • Boot your computer and create a new Environment variable called devmgr_show_nonpresent_devices and set it's value to 1 as follows:
      • Right click on Computer and select Properties
      • Click on Advanced System Settings in left pane.
      • Click on the Environmental Variables button
      • Click the New button under the User variables for xxxxx" area.
      • Set the Variable name as: devmgr_show_nonpresent_devices
      • Set the Variable value to: 1
      • Click OK as needed to close all the windows you opened.

    • Open Device Manager (Control Panel, System, Hardware tab, Device Manager)
    • Click on View then Show hidden devices.


    See what, if any, yellow marks show.
      My System SpecsSystem Spec

  7. #7


    Posts : 5
    Windows 8.1


    Quote Originally Posted by Ztruker View Post
    • Boot your computer and create a new Environment variable called devmgr_show_nonpresent_devices and set it's value to 1 as follows:
      • Right click on Computer and select Properties
      • Click on Advanced System Settings in left pane.
      • Click on the Environmental Variables button
      • Click the New button under the User variables for xxxxx" area.
      • Set the Variable name as: devmgr_show_nonpresent_devices
      • Set the Variable value to: 1
      • Click OK as needed to close all the windows you opened.

    • Open Device Manager (Control Panel, System, Hardware tab, Device Manager)
    • Click on View then Show hidden devices.


    See what, if any, yellow marks show.
    I'ma give it a try, after i finish windows update. will update after. thanks!
      My System SpecsSystem Spec

  8. #8


    Posts : 5
    Windows 8.1


    Quote Originally Posted by Ztruker View Post
    • Boot your computer and create a new Environment variable called devmgr_show_nonpresent_devices and set it's value to 1 as follows:
      • Right click on Computer and select Properties
      • Click on Advanced System Settings in left pane.
      • Click on the Environmental Variables button
      • Click the New button under the User variables for xxxxx" area.
      • Set the Variable name as: devmgr_show_nonpresent_devices
      • Set the Variable value to: 1
      • Click OK as needed to close all the windows you opened.

    • Open Device Manager (Control Panel, System, Hardware tab, Device Manager)
    • Click on View then Show hidden devices.


    See what, if any, yellow marks show.
    hi there, i tried the one u suggested. and i saw my intel(r) dual band wireless-ac130 now on the device manager. though its not on yellow mark, but it says that "Currently, this hardware device is not connected to the computer. (Code 45)" Why is it saying that way?
    I haven't opened my laptop how come my wireless card is not connected.
      My System SpecsSystem Spec

  9. #9


    Posts : 5
    Windows 8.1


    I opened my laptop and remove the card and put it back after a minute, still it cant be recognized. is it my card is broken? but i haven't drop my laptop and also took care of it. how did this happen? disappointed with dell.

    I also checked the bios, and i haven't found the wireless connection, to check if its enabled or disabled.
      My System SpecsSystem Spec

  10. #10


    Does the laptop have a switch to turn the wireless on and off or a Fn key to do so? Maybe it's simply turned off.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Dell Inspiron 5547 won't detect wireless network adapter
Related Threads
I upgraded to 8.1 and now my wireless connectivity is lost. I have installed the latest driver model for my device but still it is not working 28610
As you can see I have a dell 5547 and whenever I moved it it shuts off. takes a while to turn it back on. its probably something messed up in the wiring. Thanks
Hi. My USB wifi adapter is not recognized by my desktop PC. I already tried some troubleshooting methods like reinstalling the latest driver, restarting the system, installed to other OS like Windows 7 / 8 / 8.1 32 and 64 bit but problem still exists. I tried installing it to my friend's laptop...
50834Hello,I am having issues with my Dell 5547 laptop. There is a roughly 1cm border all around the screen which wasn't there before and I noticed it now as my taskbar is adjusted 1cm up but when I put google chrome in full screen it sort of chops the top bar down a bit. I noticed through google...
Hi i got usb adapter WDL-U700 dual band 802.11n wireless USB adapter it doesnt seem detect 5ghz wifi i already checked/change configuration to multimedia/gamig enviroment, channel mode etc
Hi everyone, I have a Linksys AE6000 Wireless USB adapter in my Laptop and it is 5Ghz enabled. When I first got my laptop it had Windows 8 on it, but before I did anything I reformatted it to Windows 7. Under Windows 7, this wireless adapter connected to my 5Ghz SSID on my router (the 2.4 and 5Ghz...
I am using a Netgear WNDA4100 wireless adapter on my new Windows 8 desktop computer. I had previously been using the WNDA3100 and it worked flawlessly; however I found a refurbished WNDA4100 online for half the price. Up until today, the WNDA4100 had not let me down. Every website I would type...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook