Hi guys. So when I turned on my desktop today, I got the limited network sign. I am using Powerline, so it showed as Ethernet, just as usual. I had the powerline adaptors unplugged, since I moved my PC to another room for a day, and then back again in the old place where it used to work perfectly. Technically, the only thing I've done with the Powerline adaptors is unplugging them for around 24 hours, and then put them back in the exact same sockets. They are not in any kind of power strip, just plugged directly into the wall.
So here is what I have tried to do so far:

  • Restarting and replugging everything.
  • Used Wi-Fi on the same, as well as another computer, to test if it worked (it did on both devices)
  • Using an Ethernet cable directly from the modem/router to a laptop (worked)
  • Re-pairing the two powerline adaptors several times (showed on the indicator lights that both were connected, just not transfering any data

Do you guys have any suggestions to what I can do to solve my problem?
My powerline kit is the PA-TL6010
When I try to troubleshoot the Ethernet connection, it says the following: "Ethernet doesn't have a valid IP configuration". Could that make it so it's easier to solve the problem?