Hi, names gareth first time poster

I am running an acer all in 1 PC with win 8.1 propack recently upgraded. and am trying to get a remote desktop working for the office PC to work form home.

we have tried several different types of software including the basic win version, remote assistance. inc gotomypc, DNS2GO, Teamviewer and we never seem to successful get it working.

Gotomypc - will connect and load, but cannot see any moment on screen (can click and move things and see them on the computer we are accessing, just not from the computer doing the accessing)
Teamviewer v9 - software says connected, but only a black screen is viewable
remote assistance - connects on accessing computer, but host the screen stops responding
DNStoGO - software advises the domain is online but no other computer can access it.

we have tried fixing any corrupt system files, changing the resolution settings, checked memory and it is fine. and yes we have done everything to set this up correctly, ports set in router, tcpip v4 set as permanent IP(also used for the ports on the router), exceptions made in firewall, regedit set to correct port (i forget the directory we changed), remote access allowed in control panel.

we have done a few other things which skip my mind at this stage, however we are officially out of ideas. any help or ideas would be appreciated.