Windows 8 and 8.1 Forums

Windows 8.1 network shares not accessible to Androids

  1. #1

    Posts : 7
    Windows 8.1

    Windows 8.1 network shares not accessible to Androids

    Hi all.

    I am having an issue, specifically between my Android devices, and my new Win 8.1 PC.

    I have an older Acer 6930 laptop running Windows 7 Professional, and my mentioned new Windows 8.1 ASUS M11 tower.

    I use an app called ES File Explorer on my Android devices, an LG G3 (phone) and a Samsung Tab 3 8.0 (tablet) to access Windows shares on those PC's. Has always worked for last two plus years for me with all previous Androids I have owned.

    For some reason, I specifically cannot access the 4 external HDD's attached to the new Windows 8.1 machine from my Android devices.


    ---The internal HDD partition (D drive) on my Windows 8.1 machine is accessible from my Androids, the external HDD's are NOT.

    ---The internal partition (D drive) on my Windows 7 Pro machine and the external HDD (F drive) are both accessible on my Androids

    ---All the drives/shares are accessible from one Windows machine to the other. IE I have full access to my Win 8.1 shares from the laptop, and I have full access to my Win 7 shares from my tower.

    Attempted so far......

    --- made sure to add Everyone under Advanced Sharing to have Read Access
    --- made sure to add Everyone under Securtity to have Read Access, List Contents and Read/Execute
    --- Administrator/Administrators and my user account name set with full access in both sharing and security
    --- same user account name across both PC, and same password
    --- verified both PC's are in same WORKGROUP (WORKGROUP)
    --- adding new firewall rules to allow my Androids thru based on their IP (all devices static in my network)
    --- tried both enabling and disabling password protected sharing on both PC's
    --- tried using ES File Explorer's Anonymous login option and of course logging in with proper user names and password
    --- verified ownership of all HDD's all set to my common user account name

    The error seen on the Android devices in ES File Explorer says a few things to check to possibly solve the accessibility issue and looks like this:

    Login Fails:

    This may be caused by:
    -WLAN is off
    -SMB server is out of network scope
    -The IP is invalid
    -Blocked by the firewall
    -SMB service is off

    WLAN can't be off I can access D drive on both PC's from both Androids.
    SMB service can't be off or out of scope, again can access D drive on both PC's from Androids.
    Firewall shouldn't be an issue as I have allowed both Androids access thru the firewall based on their IP's.....on both PC's
    And the IP's must be valid if I can see all the shares.....I just can't access the externals of the Win 8.1 machine.

    I tried going into GPEDIT and SecPol.msc but both apparently are missing off my new tower, even though it is in fact Windows 8.1 so I am a little miffed about that. According to what I have read, 8.1 is supposed to include SecPol.msc and GPEdit but apparently not for me.

    I don't know what to do from here on. Ive pretty much tried everything I know, and I cannot figure this out. Going to contact the devs of ES File Explorer but I expect that I won't hear from them for a year or two so I thought I could ask here and hope someone has solved something like this before.

    At wit's end . Please tell me I missed something glaringly obvious.

      My System SpecsSystem Spec

  2. #2

    Just as a test, I would try disabiling the firewall on the Win 8 machine just long enough to test. If that works, you know there's an issue with your rule. I also am assuming you're attempting this via wifi and not the cellular network.
      My System SpecsSystem Spec

  3. #3

    Posts : 7
    Windows 8.1

    Weird. I replied a few hours ago, but now my comment is gone.

    Anyways, I tried disabling firewall as suggested, but it didn't help. I actually forgot to add that to the list of things of tried previously, as I tried that a while back and it made no changes
      My System SpecsSystem Spec

  4. #4

    Posts : 7
    Windows 8.1

    I found a 3/4 solution. By that I mean now I can access three out of four of the HDD's.

    Following this link (not sure how my searches never stumbled on it)

    I was able to edit the registry as suggested and now three out of four of the external HDD's are accessible. I may just have to play with values to get the last HDD to 'open up', or possibly have not replicated all shares and security rules like the others that work.

    I will keep on this but for the most part I would consider this solved. I saw something like this a while back but the guide did these changes thru SecPol.msc, which for unknown reasons was and still is missing from my Win 8.1 tower PC. Still baffled to why that is, but that hopefully another battle for another day.
      My System SpecsSystem Spec

  5. #5

    Posts : 7
    Windows 8.1

    Did a final tweak to the IRPStackSize (Decimal value 33) and the last HDD is accessible.
      My System SpecsSystem Spec

Windows 8.1 network shares not accessible to Androids
Related Threads
Hopefully some of the networking experts on here can help me with what's probably a simple, straightforward problem, but it's starting to really annoy me now as I've spent three evenings searching for and trying numerous solutions but still have the problem… I have a Windows 7 desktop pc and a...
I am trying to share a folder over a local network so I can access it from my Android device. I am using ES filebrowser to access the computer. I have included my user creds when connecting but the only share available is the Public folder on C:, while I have other shares on a different (external...
I have a Linux Centos server with Samba configured. On the other workstations (XP and Windows 7), the server is shown under Network (centos5); not with my Windows 8 workstations. If I map the network drive (e.g. \\centos5\www\), I have full access. What might I be missing? Todd
Just upgraded 2 computers, a laptop and a desktop to windows 8, clean install. I shared my files on the desktop and mapped it to my laptop as a network drive. i am able to access it through explorer and programs like chrome but some programs can't even see the drive. Tried using UNC paths but...
The host is W8 Pro RTM. If attempt is made to access the guest XP(SP3) from the host, "The user name or password is incorrect" is returned. If I try to access the XP from another PC on the network the user ID in the dialog box is grayed. The grayed user ID shows xxxx\Guest, xxx being the computer...
Yesterday I installed Ubuntu beta 12.04 LTS. I want to access my other machines' Windows hard drives which are already configured to share in the workgroup fashion. All Homegroup and IPv6 stuff are disabled across the board on all machines. (And yes, I know Homegroup is only for 7 and 8.) I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook