Windows 8 and 8.1 Forums

RAS Async Adapter & WAN Miniports Showing error (45)

  1. #1

    RAS Async Adapter & WAN Miniports Showing error (45)

    I am having a strange issue with my RAS adapter and WAN miniports removing themselves from Device Manger list. Shown below is the present status of the devices.

    Click image for larger version

    I have been trying to solve this problem for a little while and have tried different methods. One method that did work for a short time was not running 2 virus programs at the same time. I stopped Windows Defender, and kept Malwarebytes running. I also have Spybot S&D for updating the malware sites list in my browsers and host file.
    This surprisingly fix this almost immediately except for the RAS Async Adapter which I uninstalled and rebooted for it to re-install correctly.
    I have check quite a few sites concerning the RAS and WAN problem to see what might fix my particular problem. Not too long ago, this same thing happened and I seem to remember locating a site that mentioned a fix in the registry to have the system install the drivers (which I have forgotten about since). This did fix it, but it has returned again as you can see.
    The day I realized that the ports were causing problems again was a day I had to do a restore. So, I probably reinstated the problem with the restore.

    I have ran virus programs several times and I also keep a close eye on these kind of attacks. I have run SFC/ Scannow, chkdsk fix and repair, also have tried a work around to remove these items by updating drivers to legacy drivers, Bluetooth adapter so they can be removed for a reinstallation of the port drivers. The system normally will not allow removal of these items, so installing the wrong driver allows for deletion which was the only method for some reason.

    I don't have any idea what device is giving the error (45) because I haven't installed anything new except for a joystick. The ports also do not seem to be effecting any type of operations on my system and if I didn't check my device manager regularly, I would of never noticed the ports had this problem again. I would like to fix this stuff and maybe find out what I may of changed to cause this driver installation problem. Somehow the system isn't installing them I guess and my best guess is that there is information in the registry that got corrupted.

    Anyway, I will check back here regular as I also do a relaxed search online for the original fix that was located before the restore.

    Thanks for your time.

      My System SpecsSystem Spec

  2. #2

    Wow, this must be a tough one. I usually get someone who has had this problem and can fix it. I'll check back
      My System SpecsSystem Spec

RAS Async Adapter & WAN Miniports Showing error (45)
Related Threads
I found in my WIN 8.1, there are so many WAN miniports in my device manager. And i can't delete any of them, Is it normal? What are they?
51153 this screen appears on every boot followed by long error number that i could never got the time to read or even capture it some times this screen stays for very long time and cancel button just doesn't work
c++ 2008 showing error 1935 in Software and Apps
i am getting this error 1935 while installing c++2008? help me pls49625
I tried everything I know but can't seem to get back my wifi card to work. Please help.
I bought an external USB WiFi adapter (Alfa AWUS036NHA) a few months ago, for the purpose of using it for penetration testing, studying networking and Internet security, fooling around with WiFi hacking, and just generally being able to get much stronger signals and throughput, etc. It's supposed...
Hello all, I have been running Windows 8 since the beta release and up until this point haven't had use for adapter bridging or "internet connection sharing". I have a cellular modem hooked up via USB and am trying to bridge the USB modem adapter with my LAN port on my tower to output to a...
Hi guys, I am trying to install windows 8 on my computer. First I wanted to do a clean install by booting directly from DVD, which resulted in 0x00000005D error. I tried several times and I got this error consistently. Later I tried Windows 8 upgrade assistant which showed that my...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook