Windows 8 and 8.1 Forums


Very slow internet in Windows 8.1, frequent dropouts

  1. #1


    Posts : 3
    Windows 8.1

    Very slow internet in Windows 8.1, frequent dropouts


    My internet can be very slow on my Windows 8.1 PC. All my other devices on speedtest.net show about 35 Mbps, this PC occasionally gets there but will very quickly drop to under 5 Mbps, and every 20-30 minutes the internet will drop altogether for about 20 seconds. I also have a Ubuntu partition on this same PC, and with this same hardware it maintains 35 Mbps.


    This behaviour happens with my default ethernet (via powerline) connection, and also a wifi usb adapter.


    I have the very latest driver (Realtek PCI-E Ethernet Driver) from my motherboards website.


    I also tried the Windows 7 driver from here. I've no idea if it's the correct driver, all I did was google "Realtek PCI-E Ethernet Driver" and it took me there. When I installed it my speed was up to 35 Mbps for a while, then later it slowed to a crawl again. But this also happens when I do a fresh install of the up-to-date driver from the MSI website.


    Why is this happening? Is there anything I can do?

    Windows 8.1 64 bit
    AMD A8 5600k processor
    MSI FM2-A55M-E33 motherboard
    8gb ram

      My System SpecsSystem Spec

  2. #2


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    Without a posted Speedtest or Shaper Probe result, we are going to be running blind here. It also helps to know who your ISP is, and what mfg & model of Gateway or Router you are using.
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8.1


    Ah sorry, will get to work on the speedtest/shaper probe result.

    My ISP is BT (in the UK) and my router is the BT Home Hub 5.
      My System SpecsSystem Spec

  4. #4


    Posts : 3
    Windows 8.1


    Unfortunately (fortunately?) my speeds are perfect right now, probably because I just uninstalled and reinstalled my drivers today. I'll just have to wait for the slowdown to happen
      My System SpecsSystem Spec

  5. #5


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    See Network issues with BT HomeHub V3 - up and down - DNS? The OP is also a BT customer. From history with working with BT customers on forums. This seems to be a common issue. Usually doing the fix as pointed in the link I posted, can usually resolve connection issues.

    It is common for European and Asian ISP's to throttle or slow down customers. But also common for faulty equipment to be the culprit.
      My System SpecsSystem Spec

Very slow internet in Windows 8.1, frequent dropouts
Related Threads
Greetings folks! Very glad I stumbled across this website. I'm having issues with my new desktop computer that I bought from IBUYPOWER. The issue is slow/intermittent internet. Seems like a lot of 8.1 people are having internet problems. Computer specs are as follows: -AMD 6300 Six Core...
Hiii have 512 kbps Internet plan, so maximum i get 60 kbps downloading Speed . I am running windows 8 pro and want to upgarde to windows 8.1 but would i able to download 3 gb + data ? Suppose i shut down my pc and when again i open my pc, then downloading will stat from beginning or it will resume...
Ok, this is my first post, hope this is the right place to post this. I have noticed that my internet speed is very slow in Windows 8, other people have somewhat the same problem, however mine is noticeably slower. In Windows 7 I got 330Kb/s Download and 40Kb/s Upload, which is my max, but in...
Purchased Windows 8 Pro with a new computer system, an HP Envy, last week for work. Have a dedicated 20 down and 20 up connection that is functioning at speed. Loading internet pages with Windows 8 is incredibly slow. Had the very same connection with a 7 year old HP using Windows XP and the...
I have noticed on one of my Windows 8 Pro computers that it has longer response time when accessing Internet. It has worked flawlessly for a month. The other PCs are not affected so it has nothing to do with my Router (DIR655) It seems like it takes time to do a DNS-lookup and I have tried...
After upgrading to Windows 8, im facing a very slow download speed. My router and the NIC is working fine because on the same PC I also have Linux. In Linux, everything works fine. When checking through the task manager, it shows that the system use the full bandwidth 1Mbps even without a...
I just recently upgraded to Windows 8 on my HP dv6z-3000 laptop. It is roughly 2 years old and has 6 gb of ram and ran windows 7 without a hitch. Everything on Windows 8 is running smoothly as well except for one issue that I have been searching for a solution for the past few days. Whenever I open...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook