Windows 8 and 8.1 Forums


Desktop computer won't connect to the internet.

  1. #1


    Puerto Rico
    Posts : 10
    Windows 8.1 Pro

    Desktop computer won't connect to the internet.


    Two days ago my ISP replaced my modem-router for a new one. Ever since the replacement, my main desktop computer won't connect to the internet "immediately". I checked the connection via ethernet and WiFi with my other computers (even tested every single one of my ethernet cables) and they work perfectly fine, except for my main desktop computer.

    What my desktop does:

    When I turn it on I have to wait for around an hour before it connects to the internet. During that hour, it attempts to identify something (I guess the IP? - the yellow warning icon gets displayed) and after 3 seconds of attempting, the connection drops and it goes back to saying "No connection". The connection is being made via Ethernet cable and I tried the troubleshoot but it continues to say that I need to plug-in a ethernet cable to my computer, thing is it is already plugged in and like I stated above, the cable worked fine with all my other computers. My desktop used to work perfectly fine with my old modem-router.

    I attempted to do do some troubleshooting refreshing my ip using the cmd with admin privileges but nothing worked as it said every time that there was no media connection. My desktop just randomly connects to the internet by itself after an hour of attempting to connect and disconnecting and once it gets connected it works perfectly fine until I restart my computer or turn it off and then the next day it'll be the same thing over again.

    This has gotten extremely annoying, what can I do to fix this and further prevent it from happening? - I updated all my drivers and it's still the same. It'll just connect to the internet whenever it wants to.

    Please help!!

      My System SpecsSystem Spec

  2. #2


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Is this what you've already tried:

    Click Start > All Programs > Accessories, right-click on Command Prompt and choose Run as administrator. Windows 8 users press [Windows Key] + [X] and select Command Prompt (Admin).
    At the command prompt type: netsh winsock reset catalog and press [Enter].
    Next type: netsh int ip reset reset.log and press [Enter].
    Restart your PC for the changes to take effect.
      My System SpecsSystem Spec

  3. #3


    Puerto Rico
    Posts : 10
    Windows 8.1 Pro


    Quote Originally Posted by popeye View Post
    Is this what you've already tried:

    Click Start > All Programs > Accessories, right-click on Command Prompt and choose Run as administrator. Windows 8 users press [Windows Key] + [X] and select Command Prompt (Admin).
    At the command prompt type: netsh winsock reset catalog and press [Enter].
    Next type: netsh int ip reset reset.log and press [Enter].
    Restart your PC for the changes to take effect.
    Hi thanks for the fast reply! - I don't recall having done that exactly, if I remember correctly it was a command that has to do with refresh/reset ip, however I followed your steps and got this:

    The netsh winsock catalog got reset successfully but for the netsh ip reset reset.log:

    Resetting Global, OK!
    Resetting Interface, OK!
    Resetting Unicast Address, OK!
    Resetting Neighbor, OK!
    Resetting Path, OK!
    Resetting Route, OK!
    Resetting, failed.
    Access is denied.


    Resetting, OK!

    I closed cmd prompt and restarted my pc and now I'm waiting to see if it'll connect to the internet. I'll post back in 5 minutes.
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Really would be nice to get feedback if something worked or not. Oh well.
      My System SpecsSystem Spec

  5. #5


    Puerto Rico
    Posts : 10
    Windows 8.1 Pro


    Quote Originally Posted by popeye View Post
    Really would be nice to get feedback if something worked or not. Oh well.
    Popeye, I apologize for my late response. I didn't work - I got on the phone with a Microsoft technician and he guided me through some of those steps you posted. I've even set up my IP manually and still nothing. I flushed my IP and reset the logs, still nothing.

    What else is there to do?
      My System SpecsSystem Spec

  6. #6


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    I would talk to your ISP since they changed your equipment.
      My System SpecsSystem Spec

  7. #7


    Puerto Rico
    Posts : 10
    Windows 8.1 Pro


    Quote Originally Posted by popeye View Post
    I would talk to your ISP since they changed your equipment.
    I called them and they checked my connections and since my Internet worked via Ethernet and Wireless on all my other computers they said they couldn't do anything else because the problem was on my end and it is me who has to fix my computer in order for their service to work. I guess I'll buy a router and maybe re-install windows or something... I don't really know what else to do.

    I do appreciate you following up on the thread and trying to help, so thank you a lot for that!!
      My System SpecsSystem Spec

  8. #8


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Only thing I have left is delete your network card in Device Manager then reboot.

    EDIT: Would also help to know some specifics like network card, computer......
      My System SpecsSystem Spec

  9. #9


    Puerto Rico
    Posts : 10
    Windows 8.1 Pro


    Quote Originally Posted by popeye View Post
    Only thing I have left is delete your network card in Device Manager then reboot.

    EDIT: Would also help to know some specifics like network card, computer......
    Network Card:
    Killer e2200 Gigabit Ethernet Controller (NDIS 6.30) 1.1.38.1281

    Computer:
    MOBO: MSI G45 Gaming
    i7-4770k quad @ stock clocks
    16GB RAM
    256SSD Samsung EVO
    1TB HDD Hitachi

    I'll delete, reboot and post back in a sec.
      My System SpecsSystem Spec

  10. #10


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Have you downloaded latest drivers? Driver Downloads | Qualcomm Atheros, Inc.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Desktop computer won't connect to the internet.
Related Threads
My computer hard rive recently crashed and was sent off to manufacturer to be supposedly fixed. Once I got it back my internet connection was spotty. Internet explorer would often stop working. It got to a point that I could not connect tonetworks, I tried multiple networks. This occurred a week...
On my windows 8 laptop I haven't had any problems for months but now my apps on the start screen won't connect to the internet, but I can still connect to the internet when I'm in desktop. I have scoured the internet but I can't find a solution, please help!
I need some help in connecting my mac book pro/ windows laptop to My main computer and everything on it. I've never had 2 computers in the same house before. I use my Windows 8.1 for everything, but there are times when I'm somewhere else in the house where I'd like to access anything/everything on...
I'm having a devil of a time with connecting my desktop computer. The computer connects to the network fine, and other computer s in the house are connected to the internet, so it's not the modem or the connection. I spent nearly an hour on the phone with Internode Support, even though this...
I've spent ages scouring Google and trying different things but with no joy and so would appreciate any help! I upgraded my Windows 7 laptop to Windows 8 and none of the apps work and they all show offline. When I open the desktop I can use the internet with no problem. In the network and...
Yep, on the desktopUI all my software can connect fine to the internets, browsers, emaiclients, games etc etc. On the MetroUI nothing connects to the internet. for example with the windows app store i get the message (roughly translated from Dutch) "Windows store didn't connect to server or timed...
Whenever I boot up my computer, I always have to go and connect to the internet. It doesn't automatically connect to the internet. I don't want to do this anymore. I tried clicking "Connect Automatically," but that didn't solve the problem. I also tried troubleshooting. It found some problems, and...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook