Windows 8 and 8.1 Forums


Lenovo y50 Network Problem

  1. #1


    Posts : 4
    Windows 8

    Lenovo y50 Network Problem


    Excuse my typing, on my phone ATM.

    I recently performed a downgrade on my Lenovo y50 laptop, and everything worked well in the end and Win7 Home Premium is up and running. I installed all the drivers for the laptop on Lenovo's website, but my WiFi remains unusable (tried direct line from router, still no luck).

    When I view my System Information > Network > Adapter it says Name: [00000000] WAN Miniport (SSTP)
    Adapter Type: Not Available

    It reads pretty much the same for IKEv2, L2TP, PPTP, PPOE, IPv6, and the Network Monitor, and everything else.

    Only exception is bluetooth appears to be working.

    In Device Manager, under Network Adapters there is only my Bluetooth, and under "Other devices" it lists (3D Video Controller, Ethernet Controller, Network Controller, PCI Device, Universal Serial Bus (USB) Controller, and Unknown device all with yellow triangles with exclamation points next to them.)

    I'm considerately adept with technology, but this is beyond me and I don't want to screw something up. My biggest guesses ATM are Lenovo saying there is a Realtek LAN Driver for the y50 that I can download:
    http://support.lenovo.com/us/en/downloads/ds100500

    But I can't really tell what my WiFi card is, where I bought the laptop on NewEgg says my Laptop's WLAN controller is an Intel Dual Band Wireless-AC 7260. I can download the driver for that here: Intel Dual Band Wireless-AC 7260 Driver for Windows 7 (32-bit, 64-bit) - ThinkPAd Edge E440, Edge E540 - Lenovo Support (US)

    I dont want to install anything without getting the go-ahead with more understanding in this matter.

    This caught my attention, but it's in Win8, it sounds similar but I can't tell. https://forums.lenovo.com/t5/Windows...r/td-p/1051981

    Any help is appreciated.

      My System SpecsSystem Spec

  2. #2


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    You need to install the drivers & Pro-Set software from intel.com's website. Only way you are going to get that 7260 mini-card working, is by installing the correct drivers.

    Not installing any drivers, you are going to just have a piece of plastic that does nothing, sitting there on the machine.
      My System SpecsSystem Spec

Lenovo y50 Network Problem
Related Threads
lenovo easy camera driver problem in Drivers & Hardware
Hi friends I bought a new lenovo G500 note book, i5, 4GB ram with windows 8 but today when I click to camera tile it says this camera is not compatible wit this version of windows. I have tried driver update and some other settings but failed. please help me.
For the past few months, my Lenovo G505 computer (running windows 8.1) has been telling me that its wifi connection is "limited". It used to work well on the wifi (same router) and I have restarted the router several times, but to no prevail. The wifi problem is only for my two private wifi...
Lenovo G510 Mic problem in Sound & Audio
I'm using Windows 8.1.The problem is my mic doesn't work i change it to speakers from listen but in recording it's still show defaut device.I was wondering why my mic is so low and finally find the problem but now this is another problem how to fix this.
Solved Lenovo G580 audio problem in Sound & Audio
Hello. I have a Lenovo G580 with Windows 8. I have a weird problem with audio. If the default audio is set as internal speakers and I plug in my headphones the sound just keeps coming from the internal speakers. But if I set the headphones as default, I can switch between the speakers and...
Network problem in Network & Sharing
Hi everybody! I just installed OS 8 and I have a network problem...I don't see the LAN connection.I know you must install a driver,I installed it and LAN doesn't appear.If you don't know what I mean,I'' put some screenshots in Attachaments.Thank you! PS:I'm at a friend's home right now and sorry...
Hi all, This is my first post to the forum so please bear with me as I am not an IT pro by any means, probably more of a fairly capable user once directions are given. I have the Lenovo Thinkpad Tablet 2 running Windows 8 and generally find it a device well suited to my application. One...
Hi all. My Lenovo Twist (Ultrabook s230u) has ran into problems - and tries to run AutoRepair but gets hung up each time. Lenovo has instructions for creating a bootable USB to run UEFI diagnostics: Lenovo UEFI Diagnostics - Bootable USB (Create it on Windows OS) - Desktops / Notebooks /...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook