Windows 8 and 8.1 Forums

Connection drops when connecting to remote server

  1. #1

    Posts : 14
    Win 8 Pro ITA

    Connection drops when connecting to remote server

    Windows 8.1 ITA 64bit

    When I connect to a specific remote server (hosted on Amazon) my connection drops after about 60 seconds. That is:
    - Putty: after 60 seconds (idle / non idle) connection drops (PuTTy window status: inactive, PuTTy popup error: "Network error: Software caused connection abort")
    - RockMongo: if I connect using RockMongo, after 60 seconds connection is lost
    - Jmeter: about every minute I have "Non HTTP response code:,Non HTTP response message: Socket closed"

    I have not this problem when connecting to other servers BUT my friends, connecting from the same office using their Linux OS, don't have this problem.

    I have the same problem with wired (Atheros AR81xx) and wireless (Atheros AR956x) connection. Wired and Wi-Fi drivers are up-to-date.

    No antivirus or firewall installed. I tried turning windows firewall on and off, nothing change. I also tried to set MTU to the best value for my connection (1472) but this didn't change the game. I can't say if the problem existed in the past, I noticed it only few days ago when I started to work with that server.

    I also tried to dump tcp packets using netsh, I got some errors (Winsock - event id 1032 ad 1003) and I got these errors also closing all opened programs.

    Any help?

      My System SpecsSystem Spec

  2. #2

    Central IL
    Posts : 3,468
    Linux Mint 17.2

    Have you talked to Amazon S3 group, or looked in the discussion forum at to see if others may also be having the same problem, or had it and found a solution.

    Instead of using PuTTY, try WinSCP. It incorporates Putty, a SSH & FTP Client all in one. You can download it from WinSCP :: Free SFTP and FTP client for Windows The only thing that I can think of, is that the S3 server is dropping your connection on their end. WinSCP also allows for logging, so that you are able to better troubleshoot what is going on. More on the logging feature. Logging :: WinSCP
      My System SpecsSystem Spec

  3. #3

    Posts : 14
    Win 8 Pro ITA

    I'll talk to Amazon s3 group too, thank you.

    This is WinSCP log:

    . 2014-09-19 10:31:53.696 Startup conversation with host finished.
    . 2014-09-19 10:32:42.007 Changing directory to "mydir".
    > 2014-09-19 10:32:42.083 cd "mydir" ; echo "WinSCP: this is end-of-file:$?"
    . 2014-09-19 10:32:57.084 Waiting for data timed out, asking user what to do.
    . 2014-09-19 10:32:57.250 Asking user:
    . 2014-09-19 10:32:57.250 **Host is not communicating for 15 seconds.
    . 2014-09-19 10:32:57.250
    . 2014-09-19 10:32:57.250 Wait for another 15 seconds?** ()
    . 2014-09-19 10:33:14.253 Data has arrived, closing query to user.
    . 2014-09-19 10:33:14.527 Network error: Software caused connection abort
    * 2014-09-19 10:33:14.586 (ESshFatal) Network error: Software caused connection abort
    * 2014-09-19 10:33:14.586 Error changing directory to 'mydir'.

    I have the same problems also with jmeter and rockmongo and they use http connection. Consider I have no problem using Linux from the same office with same url & account, so it "seems" a OS related problem.

    Other ideas?
      My System SpecsSystem Spec

  4. #4

    Posts : 14
    Win 8 Pro ITA

    The problem exists only versus Amazon VPC; no problem using Amazon EC2. Maybe it's a routing problem. Our company use a VPN to access to Amazon VPC, this is the trace route:

    1 2 ms 2 ms 1 ms
    2 2 ms 3 ms 2 ms vpn-1.vm.***.net []
    3 62 ms 61 ms 61 ms
    4 71 ms 62 ms 61 ms project-vpc-1.vm.***.net [10.50.***.***]

    I tried to lower the MTU to 1400 (1472 should be the best value for me) but nothing changed.

    Update: I used ping -f -l xxxx to find the perfect MTU for my VPC destination. MTU perfect value is 1372. I set this value but I still have connection drops, I haven't fix this yet

    Useful link (not so useful for me):

    Update 2: partially solved, adding a permanent root (my sysadmin trick). I still have no idea why linux os works without adding that route and I have to add it, maybe the vpcvpn configuration could be involved [ ]
    Last edited by johnwook; 22 Sep 2014 at 11:13.
      My System SpecsSystem Spec

Connection drops when connecting to remote server
Related Threads
I've read several posts here and elsewhere and still can't seem to get this problem resolved. I have two computers running Windows 8.1 on my network, one is my main PC and the other is a HTPC in the living room. On the HTPC I am logged into a local account named Bob and I have a few programs...
I have just yesterday downloaded Windows 8.1 to my machine. Since then my computer loses its network connection often, and I have to reconnect via "Connect to a Network." This is quite annoying. Any help would be greatly appreciated. Thanks so much.
Well, my first real problem with 8.1, my bluetooth mouse drops connection about every 15-20 minutes. Turn it off and back on it reconnects. A search of the web shows other people with same problem. I've tried everything I know of, power settings for bluetooth the mouse and usb ports, drivers,...
What settings/services need to be changed/stopped to keep other computers from accessing my system through an unwanted remote connection ?
Hello everyone, i'm getting this problem in some days ago, tried alot of things to solve but without sucess :cry: Well, i use a usb Wireless adapter to acess the internet, and my signal is always good. The connection works fine too. But in some sites (more specifically in a flash video player...
Hello, I have a new windows 8 laptop and every couple of minutes the internet connection goes to "limited" and if I simply disconnect and reconnect from the network it starts working again, but then disconnects again in about 5-10 minutes. This is extremely annoying and none of our Windows 7...
Remote Desktop App Not connecting in Network & Sharing
I connect to a secure environment using Cisco VPN and can use the old mstsc fine to connect to my PC, but the new remote desktop app in windows 8 just tells me to check the computer is turned on and connected to the network. Any ideas on why this would be? Guess I should also ask (hoping I can...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook