Windows 8 and 8.1 Forums


Network Connection Problems

  1. #1


    Greece
    Posts : 341
    Win8.1 64bit, Windows 10 TP on VMWare Player

    Network Connection Problems


    A couple of days ago when I opened IE I got an error message saying I was not connected to a network. I was, with internet access, and I knew this was okay as my partner was sitting 3 feet away using the internet on his machine. I eventually resolved the issue by doing a System Restore but the same thing happened again today, which gave me a chance to collect some evidence to try and get it properly sorted.

    When it happened today I went through the network diagnostics, which suggested a possible problem with the network adapter and the driver for the ethernet adapter, which I chose to 'fix as administrator' and then got this:

    Click image for larger version

    Click image for larger version

    [When I switched off last night some updates were installed and today the installation completed on these. I checked these and found that KB2975719 had been successful but KB2989647 had failed. I also noticed that KB2975719 had first installed just before the first network connection problem (then been uninstalled by the system restore).]
    I decided to do another system restore, but before I did I checked what programs would be affected. Here is the list:

    Click image for larger version
    The system restore was successful, but I still had the network connection problem as before.

    So I decided to restore to an earlier point, about 6 hours before on the same day. This time, no programs were affected, the system restore was successful and I got my network connection back.

    After this I installed Windows updates in the following order: KB2975719, KB2989647 and KB2984006. Each install was done separately with a reboot in between and I checked internet access after each one. Everything went okay.

    Later today, further updates have been installed: KB2994897, KB2977174, KB2995004 and KB2979582. The last two of these were on the System Restore affected programs list so they seem to have sorted themselves out.

    So my idea that the problem was somehow associated with KB2975719 seems to be wrong as this has successfully installed.

    But maybe one or more of those other drivers in the list could be the problem? I really don't want to find this happening again if they get updated again so any suggestions would be appreciated.

    EDIT: Last night just before I closed the machine I was playing Microsoft Solitaire, using my internet connection to access daily challenges ( IE was closed). Everything was loading slowly. Just now (10.45pm) I went to play Solitaire and Microsoft Mahjong, but Solitaire has an X on the app icon, and both say they can't open. Both updated sometime yesterday. I also have Microsoft Sudoku and that has opened okay, although it is slow to load. A connected problem or a new one entirely????

    Thank you
    Last edited by SaggyMaggyPoo; 17 Sep 2014 at 14:54. Reason: New information

      My System SpecsSystem Spec

  2. #2


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    The big questions are, were you playing the games from the Metro screen, or in the desktop. Any third party Internet security software installed.
      My System SpecsSystem Spec

  3. #3


    Greece
    Posts : 341
    Win8.1 64bit, Windows 10 TP on VMWare Player


    I play the games from the Metro screen.

    I have Emsisoft antimalware which I have used for several years without any problems.
      My System SpecsSystem Spec

  4. #4


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    Try using IE from the desktop. I bet the problem will go away. A lot of people are having issues with the metro apps not connecting to the internet. No one has been able to pin down the exact cause as to why this is only happening in Metro. Even running the metro apps in something like Metromix from Stardock Software, does not even resolve the issue.
      My System SpecsSystem Spec

  5. #5


    Greece
    Posts : 341
    Win8.1 64bit, Windows 10 TP on VMWare Player


    I di use IE from the desktop, but today the apps seem to have sorted themselves out again.

    But the original issue of the network connection problem and my query whether it could be something to do with the list of driver updates I put in the first post is still outstanding if anyone is able to look at this...
      My System SpecsSystem Spec

Network Connection Problems
Related Threads
Internet Connection Problems in Network & Sharing
I'm having this persistent problem with my Wifi. I'm using a 802.11n USB Wirless LAN Card aka Panda Wireless USB to connect to my router in my home. The connection will drop every 1 minute. The USB will stop flashing or completely turn off. I can unplug it and replug it back in, but this is a never...
Slow over network connection in Network & Sharing
Hello guys, I have a Desktop connected via ethernet to my Apple Airport Extreme, which supports ac wifi. The hard drives I'm sharing through my desktop are connected via USB 3 cables. So the local speed is pretty good. However, network speed is not as fast. I get about 12 mbps while transferring...
Internet connection problems in Network & Sharing
Hello. I've been having troubles with my internet connection for about 3 weeks. It all started like the 4th day after they installed the service. First couple of times it would only happens once or twice a day, but lately is been happening about 10 to 20 times a day. Pretty annoying since I am an...
Solved Network connection one way only in Network & Sharing
I just bought and set up a new Dell computer with windows 8. I set sharing and permissions. From the new computer I can access on my network another Windows XP computer and transfer files appropriately. From the XP computer however I can not find the Windows 8 computer. Any suggestions?
Solved Browser Connection Problems in Browsers & Mail
Hi guys, I have just upgraded from Windows 7 Home Premium to Windows 8 Pro and am extremely frustrated with my browser connection. I say browser rather than internet as that seems to be running fine with feeds on the start screen and uploads/downloads continuing in the background with no issues...
Internet connection problems in Network & Sharing
Hello, Firstly I'm no computer expert atall so I might be showing my ignorance here. I've just got a Sony Vaio with windows 8 which initially worked ok, but now won't connect to the internet atall, either with the ethernet cable or on wi-fi. Windows diagnosis does nothing. It was working...
Just upgraded to Windows 8 Professional from Windows 7, and I love everything except the networking. Nothing works except wifi. I can't see any other computers on my network or any of the hard drives connected to my router. My other laptops in the house can see them (one runs Windows 7 and one...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook