Windows 8 and 8.1 Forums

Why is 8.1 bridging wired to wifi hotspoti so difficult?

  1. #1

    Why is 8.1 bridging wired to wifi hotspoti so difficult?

    There are now many wifi only android devices that do not have mobile wireless. Yes, almost everyone has a wireless modem at home for their broadband connection. there are free or guest wifi connections in many places. But sometimes only wired connections are available, such as at my office that I do not have a wifi one that I want to use. I do have wired internet connection and two wifi adapters.

    At home my wifi only devices (Google Nexus 7) easily connects to my wifi router. I have a rooted S3 with a working native wifi hotspot to which my Nexus connects

    It seems easier to share a wifi internet connection with another wifi device, but not so easy to share an ethernet connection by bridging to a wifi hotspot.

    I do not understand why Win 8.1 does not have a GUI for setting up hostednetwork. Running command prompts is a PITA.

    Does anyone know of a program that will easily bridge and share an ethernet connection to a wifi device and set up a hotspot for the wifi device?

      My System SpecsSystem Spec

  2. #2

    N. Calif
    Posts : 2,592
    W10 Pro (desktop), W10 (laptop), W10 Pro (tablet), W10 (laptop)
      My System SpecsSystem Spec

  3. #3

    I had tried Virtual Router before, and in fact that is why I bought a wireless dongle as the help file said if the software solution did not work, then get a dongle.

    It says it works with Win 8 (and does not specifically state it works with 8.1) Separately i have been trying to buy a wireless card or dongle for my desktop and many specifically state they do not work with 8.1 and customer comments on those that are silent say there are no drivers for 8.1 (apparently many use RealTek chipsets and apparently they are 8.1 challenged) and there they are inconsistent/unreliable and /or have weak signals.

    My Nexus says its connected but it will not go to a website, nor download email. I think it is not getting access to a DNS server. I have not yet figured out the combinations of IP and gateway and DNS server addresses to plug into the nexus wifi settings that will allow me to actually connect - I keep getting and ERR - address unknown.
      My System SpecsSystem Spec

  4. #4

    N. Calif
    Posts : 2,592
    W10 Pro (desktop), W10 (laptop), W10 Pro (tablet), W10 (laptop)

    I use PDANet on my netbook to tether my phone via USB. PDANet has built-in Hotspot capability which works for me. I have also used VirtualRouter to create Hotspot. PDANet and VirtualRouter both work for me on my netbook (Win 7) and laptop (Win 8.1) using the built-in wifi adapter.

    The only device I have that I can't get to create a wifi hotspot using either PDANet or VirtualRouter is my Surface Pro 3 tablet. Apparently the built-in wifi adapter on it doesn't support hosted networking.
      My System SpecsSystem Spec

  5. #5

    I too was a early user of PDANet but have since switched to EasyTether. This worked well to connect my laptop to my phone to get it to the internet using the phone's mobile wireless connection. Now that I have a custom Android ROM/kernel I can also do this wirelessly with wifi. That's what most people want to do.* I changed from doing this as while I had unlimited data with both Verizon's FTC's bid mandated free to all devices LTE and Sprint's 4G and neither ever complained as I only did minimal surfing and it worked well. I got a switch to share the broadband connection on my corporate network which works even better.

    *I want to do the opposite. I want to connect my phone with mobile wireless turned off or a tablet which doesn't have mobile wireless to connect to a PC using wifi and sharing the PC's wired ethernet internet connection.

    I may have my laptop's LAN and WAN devices and drivers screwed up at this point so I plan to do a drive image backup tonight and then remove/uninstall them all and let them re-install/update hopefully with default settings and start over.

    I am getting so frustrated I may jest get a wired microUSB to RJ45 ethernet adapter (like BobjGear's or an eBay lookalike) and connect directly to my Zyzel switch rather than fooling around with my laptop anymore.

    Anyway back to Virtual Router Plus: Assuming I get all me devices, drivers, and settings back to Win 8.1 default, when I start up Virtual Router Plus there are two options for shared connections; one is local area connection and the other is ethernet. Which do I pick? Do I still need to run these command prompts:

    netsh wlan set hostednetwork mode=allow ssid=myssid key=12345

    netsh wlan set hostednetwork mode=allow

    netsh wlan start hostednetwork

    Do I still need to set the LAN wired ethernet adapter to allow others to share my connection? Do I need to bridge the LAN wired ethernet adapter to the Wifi one?

    In the Nexus, do I modify the connection setting to change from default HDCP to static and if so how do I find the Nexus' IP address (as there is no router client table to which to refer) What gateway do I use, my company's, laptop wired adapter, my laptop's wifi adapter, or what?

    The TP-Link dongle came with a utility for a soft AP but it is useless also as it assumes the laptop's wifi is connected to the interent (it's not) and that what I want to do is share that with another wifi device rather than to share the wired LAN ethernet adpater with a wifi device connected to the laptop thru a wifi adapter/dongle.
      My System SpecsSystem Spec

  6. #6

    N. Calif
    Posts : 2,592
    W10 Pro (desktop), W10 (laptop), W10 Pro (tablet), W10 (laptop)

    You do not need to run the netsh commands if using Virtual Router, those commands are being issues by VR using the info you enter into it's GUI.
      My System SpecsSystem Spec

  7. #7

    Got my Nexus 2 wifi connect 2 internet thru lappie wired

    I am not sure how I did it. Hopefully it will stay "done." I used Connectify-me and
    I think I first had already bridged the ethernet and wifi adapters first, or maybe
    the program did (or redid) it. Who knows? Only the Shadow knows.

    I did image my 500GB SSD first just in case. It took about 18 hours on a USB 3.0
    port and drive. Then I uninstalled all the network adapters and rebooted.

    I tried a number of things first including Connectify, and then some manual ones
    like ICS sharing the ethernet adapter and bridging it to my wifi one. The Nexus
    would connect, save the secured WPA but then try to authenticate and gave an
    authentication error. I am sure the password was correct as I kept it simple
    (and unsafe for now) (12345678). I tried disabling my Bitdefender firewall and anti-virus.

    I finally uninstalled an additional TP-Link TL-N725N wireless N dongle (that
    I purchased as Virtual Router had suggested adding another)and its drivers and
    utility program, rebooted and let that wifi adapter find non-TP-Link/RealTek
    drivers (aka (shock shock) Microsoft drivers as there are many posts about how
    crappy the Realtek ones are).

    But I didn't use the TP-Link wifi dongle, nor virtual Router. I stayed with
    the Lenovo x220 built in half mini card. I decided to try Connectify-me again and
    selected the Microsoft Network Adapter Multiplexor Driver as the adapter to use
    to internet share (after trying some adapters that didn't work).

    Just call me Thomas Edison. I tried many things that failed and persevered until
    something worked. Let there be wifi.

    I was about ready to buy a zyxel pocket router as the tablet connects flawlessly
    to my two Asus routers at home and at my summer place.

    I hope this helps someone else - at least a little.
      My System SpecsSystem Spec

Why is 8.1 bridging wired to wifi hotspoti so difficult?
Related Threads
My motherboard has a built in wifi card, but ofcourse I use wired. I use wifi for troubleshooting connections sometimes. When I am done with wifi, I disable wifi - about to enable ethernet. But the wifi does not disable I click disable a few more times but nothing. And I can not enable...
Hi, I'm alright with technology but I've come across a problem I cannot solve. About two weeks ago I turned my laptop on and everything went blank, it couldn't read my drives, no data, nothing. After rebooting it a few times (with a lot of swearing and threatening to chuck it out of the...
I have a new computer with inbuilt Wifi on the motherboard :) For months I used the Wifi option and found it was okay for accessing the net but VERY SLOW accessing my NAS. So I went into the UEFI BIOS and disabled Wifi and plugged in the network cable. Everything is peachy, my write speed...
So just this past weekend I re-installed Windows 8.1 on my dad's ASUS Notebook (K55N), but now its WiFi internet speed is a good ~25% slower vs wired directly to the router (Linksys E4200), that was definitely not the case prior to the fresh install. I did run Windows Update just after the install...
I've been having trouble with my internet connection for the past few days. It seems to be a battle between my router and modem, but my question is about the sidebar on windows 8. When I click on the internet connection icon (?) in the lower right hand corner, the sidebar appears, showing the...
why some of the netframe is missing in windows 8 like net frame 3.0 etc. shortcoming of win 8in 8 had included? I think it is. what if w is there any method to fix it? like ,,,,download offline??
Verify your email, how can it be this difficult? in User Accounts and Family Safety
Hi All, Just trying to verify my email, which isn't my hotmail account. However, I click the url within the email and it then wants me to login to my account. I attempt to login to my usual Hotmail account and it then tell me incorrect email. Should I only be signing up with my hotmail...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook