Windows 8 and 8.1 Forums


WiFi is VERY unreliable

  1. #11


    Posts : 328
    Windows 8.1 (x64)


    Shot in the dark here, but have you tried using your laptop right next to your router (same room, no obstacles between) ??

    This might be a wi-fi channel problem, with your neighbors' wi-fi signals getting stronger than your router on the same channel or creating too much noise for your adapter. Try to do check what I asked first and if there's a definite improvement then change your router's wi-fi channel to something else, the recommended channels to use to avoid overlapping are 1, 6 and 11. If you want more precise information you could also use an utility like inSSIDer by MetaGeek or even via commandline (type : netsh wlan show networks mode=bssid). Both show the signal strength of wifi networks around you and can help choose the right one.

      My System SpecsSystem Spec

  2. #12


    Beloit, Wisconsin
    Posts : 125
    Microsoft Windows 10 Pro 64-bit


    Agreed I forgot to mention that part. Don't know what I was thinking.
      My System SpecsSystem Spec

  3. #13


    Posts : 14
    Windows 8.1


    My drivers are up to date. I first tried to have windows look for updates, which notified me I was using the latest drivers.
    I then manually downloaded the latest drivers from realtek because they were indeed more recent. Still did not solve the problem.

    The laptop came pre-installed with windows 8. One of the things I tried to solve my connectivity issues was to upgrade to 8.1. Again, did not solve the problem.
      My System SpecsSystem Spec

  4. #14


    Posts : 14
    Windows 8.1


    Quote Originally Posted by oneeyed View Post
    Shot in the dark here, but have you tried using your laptop right next to your router (same room, no obstacles between) ??
    Well, pretty much anything I'm doing right now is a shot in the dark, so...
    Anyway, the main location is 2 floors below the location of the router. But as I've had this problem for 2 weeks now (and actually much longer, considering I've had this problem before I started using an external adapter) obviously I've tried standing right next to the router. Again, did not help with the problem.

    The router is using channel 11. As for nearby routers: they're all using channel 1 (except one is using channel 6, but its signal strength is very low anyway). I'm the only one on 11.

    In a nutshell, here's the weird thing I'm experiencing:

    • I get 5/5 signal strength, even when I'm 2 floors away (other devices I have show 3/5)
    • The connection works just fine for 5 minutes, with internet speeds up to 30mbps when next to the router and half of that in my normal location.
    • After some random interval (usually less than 10 minutes), it just stops. Windows does not tell me I have "limited connectivity" or "no internet access" or anything else. Windows problem solver does not detect anything wrong and still tells me I'm connected to my router.
    • I can turn off wifi and back on, and with some luck I'll be able to connect again for the next 5 minutes. Sometimes even that doesn't work.
    • Firefox keeps spinning indefinitely. Under normal circumstances, firefox would just go to a local page telling me I have no internet connection. In my case, it just keeps spinning indefinitely when trying to load a page.
    • Clearly I'm not connected, despite what windows indicates. I can't surf the internet, I cannot connect to other devices on the local network. It's not that it's slow, there's just nothing there.
      My System SpecsSystem Spec

  5. #15


    Trnava
    Posts : 683
    Win 8.1.1 Pro x64


    OK, one more thing, make sure, that you have IP and DNS set manually as before.
    Type to run: services.msc - find the service - Network Store Interface Service.
    Select startup type - set it to - Disabled - then - Stop it. Test the internet.
    It will say, that it will stop a bunch services, that is OK for testing purposes.
    When you finish testing, do the same, but set it to Automatic and Start it.
      My System SpecsSystem Spec

  6. #16


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Eleandor, what router model and does it have the latest firmware?
      My System SpecsSystem Spec

  7. #17


    Posts : 14
    Windows 8.1


    @TairikuOkami
    Will try this when I have time tonight. Just to be clear: when you say "test the internet", I just need to surf the web and see if I get disconnected again?

    @popeye
    I've already said this twice, once in my original post...
    B-box 3 - Belgacom
    Firmware updates are automatically pushed by Belgacom (my ISP). Beyond "simple" things like DHCP or WiFi settings, I'm pretty much locked out.
    I can't switch to a different router because only Belgacom modems are certified for digital TV.

    Well, actually, I guess I could technically add a second router? Don't know how I would actually configure it to share internet though...
      My System SpecsSystem Spec

  8. #18


    Trnava
    Posts : 683
    Win 8.1.1 Pro x64


    Quote Originally Posted by Eleandor View Post
    @TairikuOkami
    Will try this when I have time tonight. Just to be clear: when you say "test the internet", I just need to surf the web and see if I get disconnected again?
    Right, if it still fails afterwards, then you can pretty much exclude Windows as a cause.
      My System SpecsSystem Spec

  9. #19


    Beloit, Wisconsin
    Posts : 125
    Microsoft Windows 10 Pro 64-bit


    I wonder if you have any Windows event warning about your network card?
      My System SpecsSystem Spec

  10. #20


    Beloit, Wisconsin
    Posts : 125
    Microsoft Windows 10 Pro 64-bit


    Click image for larger version

    Something like this.. It should tell you if your having any adapter issues or anything in that sort..
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
WiFi is VERY unreliable
Related Threads
Hi there, I have a new problem that has just cropped up today. I am no longer able to connect to public wifi or my phone's wireless hotspot. My laptop either will not connect or connect with limited access. It has connected without issue in the past and as soon as I returned home it connected to...
Kingston SSD suddenly unreliable in Drivers & Hardware
I've been using a Kingston Hyper-X 240GB SSD for nearly 8 months now but starting the end of last year, started experiencing filesystem corruption. I was getting forced CHKDSKs on nearly a daily basis. So, I download an ISO of Win8.1 64-bit (from MS), created a USB stick from it, and used it to...
Hi All, Win8: I have two wifi APs in the home and I have it all set up so that one is the Internet by cell phone tether and the other is the cabled network via the router wifi. Works just fine - except. On wifi 1, Internet I have it set for "Connect automatically" which at boot up it...
So, I've just installed Windows 8.1 on my pc, and most of the time when I open the file explorer that comes with windows it comes up with a green loading bar at the top, which usually takes around 10 minutes just to view the files, then, other times when I open the file explorer, it loads...
Hi, I have a Gateway NV52L15 notebook and I am having problems with my WiFi access. I have Windows 8. My wireless networks are not showing up. When I troubleshoot the network adapter, I get a messAge that reads that my wireless capability is turned off. When I go to the Gateway Device fast lane, my...
Title says it all. When I troubleshoot, it says Default Gateway not Available. I'm getting the 169.x.x.x IP address... I have 2 computers operating, one that isn't. Wireless works perfectly. One is Windows Server 2012, does not work. One is Windows 8, does not work. And another Windows 8...
unreliable server2008 connection in Network & Sharing
i'm hoping someone here can throw some light upon my problem... We have numerous pc's, in a workgroup, all connected to a router, which acts as the DHCP server and the gateway to the internet. We had an occasional server2003 added to the LAN for web developers to test, and browse, local...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook