Windows 8 and 8.1 Forums


"Ethernet" doesn't have a valid IP configuration

  1. #1


    Posts : 3
    Windows 8.1 Enterprise

    "Ethernet" doesn't have a valid IP configuration


    You have probably heard this problem a lot of times and it have bin talked about in a lot of forums.
    But after searching and trying almost every posable fix I could find, nothing would fix the problem ""Ethernet" doesn't have a valid IP configuration".
    After playing a match in "League of Legends" with my desktop I noticed my ping went up and I disconnected right after, I looked at my network icon in the taskbar and saw an yellow error mark. I clicked on the network icon and it said "Unidentified Network" and "Limited". I tried to troubeshoot the problem and the problem found was: "Ethernet" doesn't have a valid IP configuration. I ran ipconfig with the cmd tool and I noticed Ipv4 Adress was 169.254.171.146 (As ive heard that means windows is using a default ip by itself).
    I have a lot of devices in my house like laptops and smart-phones that work perfectly good.
    One thing that did work was sharing 3G internet from my iPhone to my desktop via usb.

    Solutions tried: Resetting router, disabled the "allow computer to turn of this device to save power" in ethernet options, tried different cables, restarting pc and updated drivers (installing the driver to a usb from my laptop).

    I hope someone will try to help me with my problem. Thank you!

      My System SpecsSystem Spec

  2. #2


    Posts : 216
    Windows 8.1 Pro with Media Center


    That IP address is usually the result of the system not obtaining one from your router. Are you hardwired to the router and have you checked for loose cables? If the cable isn't clicked into one of the ends, it could loose your connection. Also, if you have an extra empty one, try a different router port.
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8.1 Enterprise


    There is no loose cables and I have tried different ports in the router
    Thanks for reply
      My System SpecsSystem Spec

  4. #4


    Posts : 3
    Windows 8.1 Enterprise


    wait, delete the whole post. I solved it by plugging in and out all cables from my router. And the internet just worked. I will mark this as solved ty
      My System SpecsSystem Spec

  5. #5


    Posts : 1
    windom 8.1


    I have same problem connecting to Wlan here is what its says when I tried to use IP from Cmd
    Microsoft Windows [Version 6.3.9600]
    (c) 2013 Microsoft Corporation. All rights reserved.
    C:\Windows\system32>ipconfig
    Windows IP Configuration

    Wireless LAN adapter Local Area Connection* 3:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Wireless LAN adapter WiFi:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Ethernet adapter Bluetooth Network Connection:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Ethernet adapter Ethernet:
    Connection-specific DNS Suffix . :
    Link-local IPv6 Address . . . . . : fe80::e519:f486:cd88:2938%3
    Autoconfiguration IPv4 Address. . : 169.254.41.56
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :
    Tunnel adapter isatap.{3295BF9E-4B58-4DAF-93D4-9EB464C8175F}:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    C:\Windows\system32>

    Pls can anyone help with this? It is really give me sleepless night.
    Thanks
      My System SpecsSystem Spec

"Ethernet" doesn't have a valid IP configuration
Related Threads
Hi guys. So when I turned on my desktop today, I got the limited network sign. I am using Powerline, so it showed as Ethernet, just as usual. I had the powerline adaptors unplugged, since I moved my PC to another room for a day, and then back again in the old place where it used to work perfectly....
I have no idea what the problem is with my network. I know I have the password right and I am definitely in range. Other devices work on the network also. I have the network diagnostics report and a screenshot of my IP configuration included. Please help! PrintWindows Network Diagnostics...
I've had my modem connected straight to my computer via ethernet cable and never really had any problems. I recently downloaded itunes to listen music on my ipod and i know this probably isn't the problem but weeks later i was prompted to download an update for itunes and of course I clicked...
Hey guys i'm stumped on what is going on with my network connection. I have tried updating the drivers, refreshing my computer, installing all updates. Type of computer: HP Pavilion 20-b010Windows IP Configuration Host Name . . . . . . . . . . . . : Desktop Primary Dns Suffix . . . ....
Hi Everyone, I bought a a Lenovo IdeaPad P400 Touch laptop last week, with Windows 8 64-bit OS. I went through the general setup and had the computer working in no time; wireless and Ethernet connections worked fine for a few days and then I began getting "Limited" connectivity errors on both...
Hi all, I recently got windows 8 and have found it to be rather volatile. I use WiFi in my house on my desktop Intel PC and my computer strangely sometimes works to get to the internet and sometimes it doesn't coming up with connection limited and after troubleshooting it "doesn't have a valid ip...
Hi, I'm using an ethernet cord to connect to my internet and it has been working well until Thursday morning when I turned on my laptop (Windows 8) to see a yellow triangle sign in the bottom right hand corner, in front of the ethernet connected symbol. Since then I haven't been able been able...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook