Windows 8 and 8.1 Forums


browser download speed suddenly reduced,browsing is normal

  1. #1


    Posts : 23
    Win 8.1 Pro x64

    browser download speed suddenly reduced,browsing is normal


    hello people, i need help quickly!
    jst few a days ago, everything was okay about my internet
    i have a 600Kbits per sc connection, cable modem
    so my downlaoding speed is around 60-70 kbytes/s
    same in utorrent and in browser downlaods,
    i use windows 8.1 pro, 64 bits, recently my google chrome was turning slow and firefox too, i dunno if my pc was infected by viruses. i scanned wit havast and bitdefender free versions and found nothing.
    and yesterday when i tried to download a pdf file, i dunno why nut downlaod spee dwas horrible, started with 24 and then it was like 3-4 kbytes/s and it even failed later.
    i thought it was a connection problem so i restrted my connection, browing was fine everything except downloading seemed okay.
    i tried doing the same things with different browsers like firefox or internet explorer but the problem was same.
    shockingly when i tried utorrent, it was perfectly normal, it gave the ususal downlaod speed of 60-70 kbytes/s
    so it seems the problem was onl in downloading with broswers and no problem with browsing and utorrent.
    i hard resetted my pc and reinstalled fresh copy of win 8.1
    but again twas the same.
    did it 3 times already but no change.
    i dunno if it is a virus or something but i am exhaousted, plzz help soon
    ( before formattin my pc , i backed up my files in an external hdd so it may be possible taht if tehre is a virus involved then it may have came back due to my external hdd)

    P.S: i checked Speedtest.net by Ookla - The Global Broadband Speed Test and there too, showed 0.56 mbps , so it was normal there too
    Last edited by Shawn Blazer; 31 Jul 2014 at 15:34.

      My System SpecsSystem Spec

  2. #2


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    After you run the Speedtest, you need to copy the URL it gives you for the badge, so we can see what you got. Post your ISP, make & model of Gateway you have, Computer spec's, specifically if you are using wireless or ethernet for connecting to the gateway.

    Make sure you are using the proper driver for the network adapters, not the ones that come from Microsoft/Windows update.
      My System SpecsSystem Spec

  3. #3


    Posts : 23
    Win 8.1 Pro x64


    Click image for larger version


    ------------------
    System Information
    ------------------
    Time of this report: 7/31/2014, 16:38:13
    Machine name: SHUBHAM
    Operating System: Windows 8.1 Pro 64-bit (6.3, Build 9600) (9600.winblue_gdr.140221-1952)
    Language: English (Regional Setting: English)
    System Manufacturer: INTEL_
    System Model: DG41RQ__
    BIOS: BIOS Date: 02/08/08 17:50:03 Ver: 08.00.10
    Processor: Pentium(R) Dual-Core CPU E5400 @ 2.70GHz (2 CPUs), ~2.7GHz
    Memory: 3072MB RAM
    Available OS Memory: 3034MB RAM
    Page File: 1549MB used, 2763MB available
    Windows Dir: C:\Windows
    DirectX Version: DirectX 11
    DX Setup Parameters: Not found
    User DPI Setting: Using System DPI
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    DxDiag Version: 6.03.9600.16384 64bit Unicode
      My System SpecsSystem Spec

  4. #4


    Posts : 23
    Win 8.1 Pro x64


    and how do i check if my drivers are not proper??
    plzz help
      My System SpecsSystem Spec

  5. #5


    Quote Originally Posted by Shawn Blazer View Post
    and how do i check if my drivers are not proper??
    plzz help
    Go to Device Manager, expand "Network Adapters", right click the adapter, select properties and find the version in Driver tab.
    You could also contact your ISP and ask for a faster Profile.
    Click image for larger version
      My System SpecsSystem Spec

  6. #6


    Posts : 23
    Win 8.1 Pro x64


    Click image for larger version


    Tried clicking update driver and it says it up to date.
    Yesterday night, all of a sudden, my downloads were okay, but everything came back to the same problem today morning.
    I randomly tried downloading some .exe files but no luck. Then i tried downloading some Dell driver from Dell's Website and it was downloading with perfectly normal speed! That time, quickly i tried downlaoding a video file from my chrome browser using an add-on that i have (i usually downlaod videos by addons that detect and capture them) installed, and it give normal speed! I thought the problem must have resolved somehow but then again when i tried to do for another video file, same problem, it stuck with 5-10 kbps. But this time something was different, although it didnt give normal speed for other downlaods, that dell driver file, when i resumed it was downloading normally.

    I dont understand whats happening with my pc. Of course if it would have been only happened with my videos then it would be okay but it happens with every browser and .pdf , .exe ( even when i tried to download mozzila firefox steup from filehippo.com, there was the same issue )

    :'(
      My System SpecsSystem Spec

  7. #7


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    What is the driver it shows for the adapter? It will always say up to date. You need to possibly roll it back to the OEM driver, or download the Realtek driver from Realtek Open up the Properties for the adapter and look in the Device Details tab, to find out what chipset the network adapter is, so you can download the proper driver from Realtek.
      My System SpecsSystem Spec

  8. #8


    Posts : 23
    Win 8.1 Pro x64


    I tried opening properties of my network adapter driver i.e; Realtek PCIe GBE Family Controller but couldnt find any chipset name there but i think what u mentioned maybe : "Intel(R) G41 Express Chipset (Microsoft Corporation - WDDM 1.1)" ( i saw that one in dxdiag )

    so what do i do? at least i need to know what kind of absurd problem is this, is this releated to installing windows 8.1 , cuz i never had this kind of problem anytime. and i dont think any kind of viruses can affect it, and as my browsing and other downlaod operations i.e; utorrent is working fine so i can eliminate any lose connection of the cables. right? so the problem comes down to drivers or something in the system?? help me out bbro

    thnks in advance
    Last edited by Shawn Blazer; 01 Aug 2014 at 12:04.
      My System SpecsSystem Spec

  9. #9


    Posts : 23
    Win 8.1 Pro x64


    Click image for larger versionits not even moving an inch..
    i tried getting PCIe GME driver from here Realtek
      My System SpecsSystem Spec

  10. #10


    Posts : 23
    Win 8.1 Pro x64


    today, I downloaded and installed 3 realtek lan drivers ( PCIe GME ) from which one of them was from the original realtek website...
    and as expected, I had no luck :'(
    GUYS I am reverting back to XP , plz guys if u have any ideas left then help me out!!
      My System SpecsSystem Spec

Page 1 of 4 123 ... LastLast
browser download speed suddenly reduced,browsing is normal
Related Threads
For once I am posting a solution instead of a problem. I had complained to my ISP about a hesitation and speed issue. They agreed to upgrade my service from 15 to 25 Mbps. However when the guy was here to check the system he got that increased speed on my old Win 7 laptop, but could not get it as...
Browser comparison: How the five leaders stack up in speed, ease of use and more Source A Guy
Hi Guys, Recently my laptop has started automatically opening my Google Chrome browser when I turn on the laptop and sign into my account... Quite annoying having pages automatically open when I haven't pressed them... Could anyone tell me how to stop this from happening? I'm running Windows 8.
Hello. I have Windows 8.1 Enterprise x64, with Update 1. I want to ask you, where can be problem. CPU --> Intel(R) Core i5 3230M 2,6 - 3,2 ghz GPU --> Intel HD 4000 and nVidia GeForce GT740M 2GB (it switches how it needs) RAM --> 4 GB DDR3 and 1 600 MHz (1,6 GHz) HDD --> 750 gb with 5400 rpm...
so i ran a speed test with several different website and they all said my download speed is between 5 Mbps and 8 Mbps : 34005 however when i actually download something my download speed stay at 1 Mbps or when i watch videos ( youtube ) :cry: i dnt have this problem with my phone ! thank u
Hi I have recently upgraded 4 computers on my Network from windows 8 to 8.1. Since performing this upgrade we now have intermittent browsing and download issues. If I run speedtest.net, I appear to be only able to download and not upload. Our set-up is as follows, we have a domain with a local...
Anyone else having trouble downloading and internet browsing my computer has gone up in computing and isnt prossing it, also everything i download takes 3day to download when it says 3hours! you cant do more then one thing at a time. also i cant reformat my computer i have done mult. things...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook