Windows 8 and 8.1 Forums

Wireless Adapter Reduced Speeds

  1. #1

    Posts : 1
    Windows 8.1 64 bit

    Wireless Adapter Reduced Speeds

    Laptop - Acer Aspire V5-552G-X414
    Router - Asus RT-N56U
    Modem - Arris DG860
    Wifi Adapter - Atheros AR5BWB222

    ISP - Time Warner Cable, 20/2 Mbps
    Devices Connected - 2 Iphones, 1 Kindle Fire, 1 PS4, 1 Desktop, 1 Laptop
    No Error Messages

    Problem: Laptop won't connect at full speed UNLESS I uninstall driver and reinstall. Then it will connect at 20Mbps until I close the lid or restart the computer (I think, not sure on when it slows back down). It slows down to what looks to be 3-4Mbps every single time. It shows no error message and no reason as to why it slows down that I can tell. Device manager shows no problems. Desktop is also ran on wireless through a different adapter and never loses speed, so I'm fairly certain its an adapter or windows problem with the laptop. I've tried original driver and updated to most recent driver and still does this. I've turned off automatic update of driver in Win8.1 also.

    Any help would be appreciated.


      My System SpecsSystem Spec

  2. #2

    There is a long list of firmware updates that relate specifically to Windows 8 for your Asus RT-N56U router. I would suggest you update the firmware.

    ASUSTeK Computer Inc. -Support- Drivers and Download RT-N56U

    It also doesn't help when the modem is a gateway or a modem/router but the only requirement there would be to turn off DHCP on the N56U, although I don't see how this could create the problem you are describing.
    Last edited by chev65; 24 May 2014 at 14:20.
      My System SpecsSystem Spec

  3. #3

    Central IL
    Posts : 3,468
    Linux Mint 17.2

    You are Double-Natting with that other router behind the Gateway. That is half of your problem. The other half is that you need a true Wireless A/P or set the Asus router up with DHCP disabled, and connect the Ethernet cable from the Gateway to the Asus Router from LAN port to LAN port.
      My System SpecsSystem Spec

Wireless Adapter Reduced Speeds
Related Threads
5ghz wireless adapter in Network & Sharing
I need to upgrade my laptop from its 2.4ghz only wireless adapter to a dual 2.4ghz & 5ghz wireless adapter. A quick search on ebay and i found a usb wireless adapter. can i get your opinions on this adapter is any good. Mini 300Mbps Dual Band 2.4/5GHz 802.11a/b/g/n Wi-Fi Wireless USB Dongle...
8.1 - Wireless Adapter shuts off in Network & Sharing
Hi, After a while when i'm browsing the web etc, my wireless connection goes to Limited and there are no other wireless networks available (when there should be 10+ networks). When i disconnect that limited connection, there are suddenly no networks found and my wireless adapter disables...
wireless adapter in Network & Sharing
which wireless adapter is cheap and compatible to use on a windows 8 desktop? i have recently purchased a new windows 8 desktop but as i don't know much about desktops i thought they had built in wireless like a laptop, my computer is in my bedroom and my modem is downstairs, this is why i need...
wireless adapter in Network & Sharing
Anyone having problems connecting wireless? I have a Netgear WNA 1100 wireless adapter and when I use the push n play feature to link my router & computer it crashes my machine with a irq error.
This is my first day with my new PC. I just got it for Christmas and since the first boot up I noticed a tremendous drop in WiFi connection. After about an hour of messing with Windows 8 (First time using Win8) I had installed Steam and decided to download a game. I was maxing out at only 317...
My Wireless Adapter Is Not Working in Drivers & Hardware
I just recently purchased a new Windows 8 PC that does not have a built in wi-fi adapter. I have a Zyxel G-220v3 wireless adapter that does not seem to want to work in my new PC (I know it is at least 4 years old.) When I plug it into the USB port in the front of the PC, nothing happens. When I...
Do you have a wireless adapter that works with the Win 8 pro RTM? I've tried ASUS USB N13 and Rosewill RNX-N150 with no success. :cry:
Eight Forums Android App Eight Forums IOS App Follow us on Facebook