Windows 8 and 8.1 Forums


Setting PPPOE connection to autodial on startup

  1. #11


    Posts : 24
    WINDOWS


    thanks for your help,I'm still looking for a solution in my case

      My System SpecsSystem Spec

  2. #12


    Posts : 24
    WINDOWS


    Solved using rasdial.exe "connectionname" username password

    to hide the command windows:
    1) I've downloaded and install AUTOIT ,put next script into a .au3 file:
    Code:
    $file=@ScriptDir&"\pass.ini"
    $section="REGISTER"

    $conn=IniRead($file$section"connectionname""")
    $username=IniRead($file$section"username""")
    $password=IniRead($file$section"password""")

       
    RunWait("rasdial.exe "&$conn&" "&$username&" "&$password, @WorkingDir, @SW_HIDE
    right click and chose compile,and I got the exe (in my case i got internet.exe,in task I've created in step 3 you'll see the path to it : <Command>E:\settings\internet\internet.exe</Command>)

    2) in the same folder as exe I've created pass.ini file :
    Code:
    [REGISTER]
    connectionname="internet"
    username="youruser"
    password="yourpassword" 
    when need to change username or password,just edit .ini file

    3) create task schedule as there
    Last edited by mrapi; 13 Apr 2015 at 02:34.
      My System SpecsSystem Spec

  3. #13


    Posts : 1
    Windows 8.1 Pro 64


    Would you tell me, what is the exactly settings, in the Task Scheduler?
      My System SpecsSystem Spec

  4. #14


    Posts : 24
    WINDOWS


    This is exported task as xml,if you need additional info please let me know

    Trigger: at log on
    Action :start a program


    Code:
    <?xml version="1.0" encoding="UTF-16"?><Task version="1.2" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
      <RegistrationInfo>
        <Date>2014-05-14T17:23:54.8568073</Date>
        <Author>user\john</Author>
      </RegistrationInfo>
      <Triggers>
        <LogonTrigger>
          <Enabled>true</Enabled>
          <UserId>user\john</UserId>
        </LogonTrigger>
      </Triggers>
      <Principals>
        <Principal id="Author">
          <UserId>user\john</UserId>
          <LogonType>InteractiveToken</LogonType>
          <RunLevel>LeastPrivilege</RunLevel>
        </Principal>
      </Principals>
      <Settings>
        <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
        <DisallowStartIfOnBatteries>true</DisallowStartIfOnBatteries>
        <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
        <AllowHardTerminate>true</AllowHardTerminate>
        <StartWhenAvailable>false</StartWhenAvailable>
        <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
        <IdleSettings>
          <StopOnIdleEnd>true</StopOnIdleEnd>
          <RestartOnIdle>false</RestartOnIdle>
        </IdleSettings>
        <AllowStartOnDemand>true</AllowStartOnDemand>
        <Enabled>true</Enabled>
        <Hidden>false</Hidden>
        <RunOnlyIfIdle>false</RunOnlyIfIdle>
        <WakeToRun>false</WakeToRun>
        <ExecutionTimeLimit>P3D</ExecutionTimeLimit>
        <Priority>7</Priority>
      </Settings>
      <Actions Context="Author">
        <Exec>
          <Command>E:\settings\internet\internet.exe</Command>
        </Exec>
      </Actions>
    </Task>
      My System SpecsSystem Spec

  5. #15


    Thanks, though i'm not sure how you did this
    to hide the command windows I've compiled into a exe next AUTOIT script:

    Code:

    $file
    =@ScriptDir&"\pass.ini"
    $section="REGISTER"

    $conn=IniRead($file, $section, "connectionname", "")
    $username=IniRead($file, $section, "username", "")
    $password=IniRead($file, $section, "password", "")

    RunWait("rasdial.exe "&$conn&" "&$username&" "&$password, @WorkingDir, @SW_HIDE)


    also create in the same folder pass.ini file :
    Code:
    [REGISTER]
    connectionname="internet"
    username="youruser"
    password="yourpassword"




      My System SpecsSystem Spec

  6. #16


    Posts : 24
    WINDOWS


    @tommybc I've put some additional information on my above message
      My System SpecsSystem Spec

  7. #17


    Thanks just a few more questions
    For part 1, did you create the first script in the notepad, and save as .au3 ? what program do you open to compile it?
    Quote Originally Posted by mrapi View Post
    Solved using rasdial.exe "connectionname" username password

    to hide the command windows:
    1) I've downloaded and install AUTOIT ,put next script into a .au3 file:
    Code:
    $file=@ScriptDir&"\pass.ini"
    $section="REGISTER"

    $conn=IniRead($file$section"connectionname""")
    $username=IniRead($file$section"username""")
    $password=IniRead($file$section"password""")

       
    RunWait("rasdial.exe "&$conn&" "&$username&" "&$password, @WorkingDir, @SW_HIDE
    right click and chose compile,and I got the exe

    2) in the same folder as exe I've created pass.ini file :
    Code:
    [REGISTER]
    connectionname="internet"
    username="youruser"
    password="yourpassword" 
    when need to change username or password,just edit .ini file

    3) create task schedule as there
      My System SpecsSystem Spec

  8. #18


    Nevermind i ddin't have the correct program installed for it to appear, you have the task set to open internet.exe i don't have that though, what do i need to do to fix that and allow it to autoconnect, rename it to rasphone?
      My System SpecsSystem Spec

  9. #19


    Posts : 24
    WINDOWS


    no,don't rename it to rasphone,internet.exe is the file (exe) got when compile the script

    Quote Originally Posted by tommybc View Post
    Nevermind i ddin't have the correct program installed for it to appear, you have the task set to open internet.exe i don't have that though, what do i need to do to fix that and allow it to autoconnect, rename it to rasphone?
    review step 1 when compile,I put a little info there
      My System SpecsSystem Spec

  10. #20


    for some reason when i click on internet exe nothing happens, and i have pass ini in the same folder ill let you know if i fix it
      My System SpecsSystem Spec

Page 2 of 3 FirstFirst 123 LastLast
Setting PPPOE connection to autodial on startup
Related Threads
My parents bought a PC last year running W8. I set up there talktalk E mail accounts in the W8 Native E mail client from the Mail tile at the start screen without any problem. All worked fine until recently when in order to download an app they had to register an Outlook E Mail address. Not sure...
Windows 8 crashes by pppoe in BSOD Crashes and Debugging
My pc gives me a blue screen and restarts every time i connect and start browsing with my pppoe connection.
Recently, something odd has been happening. On initial start up of my PC, the network fails. It will show the yellow exclamation point and show as limited. When this happens, I cant even ping my directly connected router. It shows as PING: Transmit failed. General Failure. So far since this...
Hello everyone, I am facing a problem recently. I hope anyone of you can help me to solve it. Recently I have been installed Windows Eight Pro 64-bit in two of my desktop computers. One pc having motherboard Intel DG41 and the other one is Asus Sabertooth P55i. I have two external Realtek NIC...
I have a problem sharing PPPoE internet connection after installing Win8 in top of Win7. On my computer (say, "Computer A") I have 2 LAN ports on the motherboard: 1-st one ("Ethernet 1") is connected to internet provider 2-nd one ("Ethernet 2") is connected to "Computer B" I am trying...
Hello guys. Recently installed win 8 pro vt media center and have several issues .. my main concern s internet. I am unable to create new pppoe connection and evytym I try to create my pc restart just aftr verifying username password. I am using cisco dpq adsl modem connected using usb....
though I have set it as usual username and password, I use PPPOE by the way I've checked not to ask me again, also for all users, only one on this computer though. I use windows 8 x64 enterprise. I put network shortcut in the startup , I tried scheduling a task that runs rasdial or rasphone ,...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook