Windows 8 and 8.1 Forums

Accessible outside, not inside

  1. #1

    Posts : 59
    Windows 8.1 Pro

    Accessible outside, not inside

    Network Setup:
    • Fiber internet from the wall to an Actiontec C1000a Wireless Router/Modem
    • Port 1 on the Actiontec goes to a Belkin Wireless Router which branches off to all the devices in the entertainment center. (Xbox, PS3, DVR)
    • Port 2 on the Actiontec goes to a desktop with Windows 8.1 installed.
    • WiFi radio is turned off on the Actiontec and on on the Belkin.
    • There is also a Cisco Wireless Router at the other end of the house that is setup as a wireless repeater/bridge.

    Some Vitals:
    • The desktop has IIS installed and running.
    • Web server ports are forwarded in the Actiontec to the desktop.
    • I have registered a URL and have the DNS for that URL pointing to my public IP address.

    My Problem:
    While at work or any place other than my home, I can go to the URL and access the website set up on my desktop. Everything works fine. But, when I am at home and connected to the same network as the desktop, going to the URL won't work at all.
    Things I've Tried:
    • Pinging the URL while on my home network returns success.
    • Renaming the desktop to the URL is apparently not allowed.
    • DNS Host Mapping on the Actiontec does nothing.

    My Workaround:
    I've edited the hosts file with an entry for the URL and the LAN IP of the desktop. When I am not at home, I comment the entry and uncomment it when connected to my home network.
    My Questions:
    • Does anybody know of a setting I might be missing or configured wrong?
    • Does anybody have any suggestions on a better network setup?
    • Does anybody have any suggestions for better hardware?

      My System SpecsSystem Spec

  2. #2

    I believe you would need to set up a split DNS for this to work "without the host file edit work around" .

    The following link explains how this works and how to set it up.

    You Need to Create a Split DNS!
      My System SpecsSystem Spec

  3. #3

    Posts : 59
    Windows 8.1 Pro

    Will this work if I have an external DNS?
      My System SpecsSystem Spec

Accessible outside, not inside
Related Threads
Hi I have an external harddrive on a USB2 port that I have been using for ages without problems. Yesterday it just stopped being accessible for no apparent reason. The machine "sees" it (as the F drive) but can't access it. If I try to double click on the F drive the machine takes aaaaaages...
Flash memory is not accessible in Drivers & Hardware
Flash Memory ScanDisk Cruzer Blade 8 GB Tried to open Flash Memory , i found error message that it's not accessible , size of it is Zero !! also it's RAW drive how to fix it ? Kindly be notified that there is date in flash memory and it's important to me ( Formatting isn't solution)
Hello, I connected my existing external HDD (@USB2.0) to a new PC with Win 8.1. From the beginning all partitions mounted properly and were accessible as expected but later suddenly the first partition was not accessible due to insufficiant access rights. All other partitions keep being accessible...
Hello Everyone, I have a 1 TB hard drive that had four partitions, namely "Dell Utility", "Media Storage", "Windows Backup", and "Data Backup" in that order from beginning to the end. I have got myself into a lot of trouble by interrupting an operation where Paragon HDM 12 Pro was deleting a...
Thanks in advance for any help. I originally had a RAID 1 and windows 8 pro 64 bit installed. I had a boot error and could no longer boot into windows. I purchased two new HDDs and created a RAID 1. Loaded Windows 8 Pro with no problem. Then I added the original two HDD so as to retrieve data. ...
I've been backing up "My Documents" with CDBurnerXP because 1. I consider Windows Backups to be opaque and I prefer to keep them simple and to know what is going on 2. Windows Backups does some things I believe are risky so I will not use it 3. Windows 7 had a deep directory structure problem...
I have a 2 TB eSATA drive that contains my backups. This drive has been working well for years and isn't accumulating errors. It was a basic disk until I deleted a partition that I wasn't using any more and expanded the size of the backup partition. That worked fine until yesterday when I was no...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook