Windows 8 and 8.1 Forums

share win7 from win8.1 fails but the reverse succeeds

  1. #1

    Posts : 6
    Windows 8.1 and Windows 7

    share win7 from win8.1 fails but the reverse succeeds

    I have 3 laptops on my home group "MIGOL":
    (A) a Lenovo Thinkpad Yoga with Windows 8.1 Professional
    (B) a Samsung with Windows 8.1 Home (upgraded from Windows 8)
    (C) an Acer Aspire with Windows 7 Home
    All windows are 64 bits versions and all use Local accounts with my username "mo" as an Administrator.
    I have defined shares on all machines with names like "drv-c" or "drv-d". I all the shares I have only the user "mo" and the group Administrators having access to the shares and I have removed the "everyone" user.

    From laptop (C) I can access the shares is both laptops (A) and (B).
    From laptop (A) I can access the shares in laptop (B) and from (B) I can access the shares in (A)
    But... from laptop (A) or laptop (B) I cannot access any share in laptop (C). I get a pop-up asking for credentials where I put my username and my password but I get a "refusal" mentioning "the username of password are incorrect". I have tried to add the "everyone" user to get access to the shares in the Win7 machine but it does not help a bit.

    Summarizing: From Windows 7 I can access shares in Windows 8.1 machines, but from Windows 8.1 I cannot access shares in a Windows 7 machine.

    Does anyone has a solution for this anomaly?

      My System SpecsSystem Spec

  2. #2

    You didn't mention where you are removing or adding the Everyone share from?

    Both the Security tab and the Sharing tab on the Users folder requires the Everyone share to be enabled.

    It sounds like Network Discovery or File and Printer sharing may be turned off on the Windows 7 machine but I'm sure you checked that?
      My System SpecsSystem Spec

  3. #3

    Posts : 6
    Windows 8.1 and Windows 7

    Hello Chev65,
    Thanks for your reply.
    None of the shares in all 3 laptops gives permissions to the Everyone account. This includes the 2 laptops under Win8.1. And not withstanding that, I have access to the shares in those 2 Win8.1 laptops from the Win7 laptop.

    But assuming that there could be some special problem with the shares in the Win7 laptop not including the "Everyone" account, I made the experiment: I have included the Everyone account both in the Security tab of each share and the Sharing tab of each share on the Win7 laptop (with read access) and then I tried again to access those shares from a Win8.1 laptop. Same problem: "the username of password are incorrect".

    I have also checked the home group settings on the Win7 laptop: all check boxes on "share libraries and printers" are checked in and the home group password of the Win7 laptop has been entered in the Win8.1 machine, to no avail.

    Just to make sure, I have rebooted the Win7 laptop after including the Everyone account on the shares (like mentioned above) but unfortunately the problem persists.

    Any other suggestions?
      My System SpecsSystem Spec

  4. #4

    You didn't mention where you added the Everyone share back to? There was no mention of a Homegroup in your first post, I'm sure you checked that all machines are part of the same Homegroup etc. with the Library's shared out with Homegroup read/write via the Homegroup sharing settings.

    It's required that the Everyone share shows up under the C:\Users folder in order for the subfolders to be shared. Maybe I should ask why did you remove the Everyone share in the first place? There is really no reason to do this when you set up a Homegroup because any machine in the local Workgroup would be excluded from accessing Library's on the Homegroup machines unless they were purposely shared by Adding the Everyone share via the Homegroup share settings.

    You didn't mention if you checked the Advanced Sharing Settings on the Windows 7 machine via the Network and Sharing Center?

    I certainly have never seen this type of problem between my Windows 7 and 8 machines.

    In my experience removing the Everyone share from the main Users folder results in no folders being shared unless a user Group "with user names added to the Group" is added back in place of the Everyone share, the Authenticated Users share should work as well. I have a pretty good feeling this is where things went wrong.
    Attached Thumbnails Attached Thumbnails share with Everyone.PNG  
    Last edited by chev65; 05 Mar 2014 at 14:20.
      My System SpecsSystem Spec

  5. #5

    Posts : 6
    Windows 8.1 and Windows 7

    Hello Chev65,
    Thanks again for your reply.
    I have mentioned in the first line of my first post that I have a home group named "MIGOL". All the machines are member of the homegroup named MIGOL. That can be seen in the System settings of every machine.

    There seems to be some misunderstanding on terminology. I'm speaking about the Everyone users and you are mentioning the Everyone share. I don't know anything about any Everyone share. I certainly do not have any share named "Everyone" on the laptops, also not under the C:\users directory as you mention in your post as being required for the sharing to work. Do you mean "Everyone user" when you mention "Everyone share"?

    As I mentioned in the first post, I have created shares and I have named them "drv-c" and "drv-d". These shares are associated with the C:\ and the D:\ drives. I am the only user of the shares, they are not to be used by other people. What I did on the Win7 machine (after your first reply in this thread) - and only on this machine - was adding the Everyone user in the permissions for the shares "drv-c" and "drv-d". As I mentioned earlier, the Win8.1 machines containing the "drv-c" and "drv-d" shares can be accessed without any problem from the Win7 machine and, as already mentioned the Everyone user is not mentioned in the permissions for these shares under Win8.1 but of course the mo user (administrator) is mentioned in the permissions. And it works perfectly. This proves that at least for Win8.1 there is no need to include the Everyone user in the share permissions for the shares. I have mentioned that I have added the Everyone user (besides the mo user) in the permissions for the Win7 shares - assuming that could be the reason for the anomaly - and that has not helped a bit.

    I have checked Network and Sharing Center->Advanced sharing Settings of the Win7 machine. The following settings are ON in the Private profile:
    - Network discovery: ON
    -File and Printer sharing: ON
    - Home group: I have tried both "Allow windows to manage homegroup connections" and "use user accounts and passwords to connect to other computers". Setting the one or the other makes no difference for the negative result of trying to access the shares on the Win7 laptop.
      My System SpecsSystem Spec

  6. #6

    I think what confused me on the Homegroup is that I've never seen anyone "name" a Homegroup anything and I'm not completely sure how this was done?

    When I refer to the Everyone user Share I'm referring to the default share names listed on the Users folder as is showing in the picture.

    I'd say that in general once you start messing with share's and removing default values which are usually required then after that you are on your own as far as sharing goes because it's anyone's guess as to what exactly has been removed or added from the various different points along the file structure.

    I'd also have to point out that there is no reason to remove default users from the Users folder unless you want problems someplace down the line, in this case that is most likely the problem so I've posted default for Windows 8 here although Windows 7 is nearly the same.
    Attached Thumbnails Attached Thumbnails Everyone Share Users folder.PNG  
      My System SpecsSystem Spec

  7. #7

    Posts : 6
    Windows 8.1 and Windows 7

    Hello Chev65,
    Thanks again for your super quick reply.
    OK. The misunderstanding is solved. When you mention "Everyone share" you really mean "Everyone user". You can see the title "Group or user names" just above the list started with "Everyone" on the image you have uploaded, thus the correct classification for Everyone should be "user" (or "group") and not "share".

    You can change the name to the home group via Settings->System and then "change settings". The default name for the homegroup that windows uses is WORKGROUP but you can change it to anything you like.

    The reason I remove Everyone from the permissions list is security. I have learned years ago (in the XP and win2k epoch) that you should remove Everyone from the list and only include specific users or groups for security reasons. But anyway, it has no bearing on this anomaly: Everyone is not present in the Win8.1 shares and the shares can be accessed while Everyone is (now) present in the Win7 shares and it does not help a bit.

    Do you have other suggestions? Can you access windows shares on your windows 7 pc's from windows 8.1 pc's? If so, what else could be the reason why I cannot access shares in my situation?
      My System SpecsSystem Spec

  8. #8

    I'd never, ever suggest anyone remove the Everyone "share" because it relates to Everyone not a single user. I'd never suggest anyone to remove this share for any reason.

    Actually the Workgroup is the standard old type of sharing while the Homegroup "one word" is a completely different method for sharing. You can use what ever name you want for the Workgroup, this does not relate to an actual Homegroup which uses a unique password for security and is not namable.

    Suggest you set up an actual Homegroup and test to see if sharing works as it's a completely different method compared to what you are used to.

    I'd like to help more but I think you are failing to grasp the concepts which I am trying to convey. Have a nice day and I hope you figure out the problem.
      My System SpecsSystem Spec

  9. #9

    Posts : 6
    Windows 8.1 and Windows 7

    Hello Chev65,
    Thanks for your time and have also a nice day.
      My System SpecsSystem Spec

  10. #10

    Posts : 1
    win8.1 win7

    Hello migol,
    did you solve your problem in the meantime? I have exactly the same problem and couldn't solve it up to now. I would be eager to know what was the solution??

    Thanks for your effort to answer.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
share win7 from win8.1 fails but the reverse succeeds
Related Threads
Hello everyone, My basic issue is that my Windows machine fails to connect to a Mac samba share with known good credentials - rejected name and password, no permission to access. The weird thing is that this just started happening for the first time two days ago. I made no system changes over...
anyone seen this one? on booting up 8.1, lenovo z410, the first few attempts to use IE11 from the desktop fail. "cannot open page". connection troubleshooter produces nothing. go to APPS > IE and it works fine. after using chrome and the tile app for awhile, IE11-Desktop will gain coherency...
Hi, I had to buy a new laptop that I could take with me to work, and of course it runs Win8 (which I absolutely hate, incidentally). I decided it would be nice if I could share files with my primary computer when I'm at home, which is a desktop running dual-boot Win7 and Ubuntu. I initially...
IIS reverse proxy in Win8 in Network & Sharing
I am trying to setup a Win8 box as a "reverse proxy" web server using IIS. The goal is as simple as it gets. I do not need subdomains to go to different servers, but rather to redirect all port-80 and port-443 (HTTP and HTTPS) traffic to http://localhost:2080. I have been trying to get IIS...
On my Windows 8 Pro PC, I've enabled sharing and set my home network up as a private network. When it was running Win 8 Consumer Preview, I was able to login as "". Then when I shared a folder, I was able to connect to it from my Win7 PC by entering "joeblow" as my user name and...
I've done this about 10 times now, each time it fails. It installs the OS and it reboots itself a few times then it rolls back and boots back into Windows 7. I did some investigation and it seems that it's getting a blue screen. So the last 2 attempts, I've checked the minidumps it saves. ...
Hello, I am trying to upgrade my Win 7 x64 Pro to Win 8 x64 Pro RTM unfortunately it fails at the very last step. Just before getting access to the desktop, when it presents the choice of desktop color. The reason of the failure is displayed for a few seconds before it starts rolling back the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook