Hello andreas88de,
I have solved the problem.
The "lectures" that were given here about Everyone shares and Homegroup were just Quatsch. You can delete the Everyone user from the share like I do and the shares keep working. And you can use standard shares instead of Homegroup without problems.
The real reason for the problem was something entirely different.
The win7 machine had always used the same user name and password I use on all machines. But about some 2 months ago I got confronted with an anomaly in the win7 laptop: when logging in I could not feed the password in because the keyboard was not reacting. After some panic and wild clicking and wild typing I succeeded on entering the password. But as I did not like the experience of not being able to access Windows as a result of the keyboard not reacting at that initial stage, I decided to disable the password. When several weeks later I got the problem I mentioned - about not being able to access the shares on the win7 machine - I had forgotten that I had disabled the password. When I was asked on the win8.1 laptop to enter the user name and password to access the share on the win7 machine, I was entering the normal password I always use and win8.1 was saying that the credentials were incorrect. After some more experiments I remembered that I had disabled the password. I had assumed that the password was there but the requirement to use it for log-in had been removed. But now I think that there was no disabling of the requirement to enter the password but that Windows actually deleted it from the win7 machine. When I decided to activate the password again on the win7 laptop the problem was solved. Now I can access my shares on the win7 machine, no worries anymore.
I hope you solve your problem soon.
Best regards,