Windows 8 and 8.1 Forums


TCP/IP setting on windows 8 reverting back to automatic

  1. #1


    Posts : 3
    Windows 7

    TCP/IP setting on windows 8 reverting back to automatic


    Hi,
    Here at work we need to set a particular DNS addresses for our internet to work.
    All of our computers' network adapters have the Obtain IP address automatically checked, and use the following DNS servers:
    122.49.191.252
    122.49.191.253
    (Adam internet, for those of you in Adelaide )
    However, there is one particular Windows 8 Laptop that no matter what we do, reverts back to "get the DNS automatically." which makes the internet not work on there.
    What is bizzare is that during the morning and day it is OK and around 5PM it starts to cut off. Not sure if this has anything to do with peak users or Adam Internet but that is beside the point.

    How can we fix this TCP/IP properties issue?
    We run it off a dynadock so initially I thought it was that adapter somehow reverting back to original setting, But I tried the DNS setting on the onboard adapter and also the WiFi adapter, and they all go back to automatic setting, as soon as you click OK and Close.

    Please help!
    Thanks

      My System SpecsSystem Spec

  2. #2


    Posts : 467
    Windows 8 Pro


    My initial thought is (and I've just woken up so...) it's a piece of software that's being run or is running in the background that is resetting the DNS information.

    have you tried running it in safe mode , setting the DNS in the period you usually have issues and see if then resets back ?
      My System SpecsSystem Spec

  3. #3


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Why don't you just set the router's dns servers in WAN settings as those addresses and then enable dns relay in it?

    What that will do is make the machines' dns queries go to the router and the router will auto pass it to that primary dns you've set or fallback to the second you've set (for instance, the addresses you've shown.)

    You won't have to worry about each individual machine this way.

    The problem though that you're saying, is that you can't specify a particular dns server if the adapter is not set as a static one. For example, you are relying on the DHCP server of the router to pull ip addresses. That won't work. My above solution regarding router settings will.
    Last edited by MasterChief; 31 Jan 2014 at 02:21.
      My System SpecsSystem Spec

  4. #4


    Posts : 70
    windows 8.1


    I doubt that IT would be happy if you mess with the router config.
    However there are GPO (DNSClient) options and settings in the registry related to persistent DNS servers setup.
      My System SpecsSystem Spec

  5. #5


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    As I read it, Cookie IS IT. heh heh The clue: "there is one particular Windows 8 Laptop that no matter what we do,"
      My System SpecsSystem Spec

  6. #6


    Posts : 70
    windows 8.1


    so for one laptop he should change whole network config? Doubt it. The problem with system reverting to old network setup in windows is pretty well known, just need to co clear registry and or GPO. This may be something else too, but seems lakie easy step to check for the remnants of old configuration.
      My System SpecsSystem Spec

  7. #7


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Quote Originally Posted by Michal View Post
    so for one laptop he should change whole network config?
    No, he should change it so all laptops can work:

    Quote Originally Posted by cookie720 View Post
    Here at work we need to set a particular DNS addresses for our internet to work. All of our computers' ...and use the following DNS servers:
      My System SpecsSystem Spec

  8. #8


    Posts : 70
    windows 8.1


    However, there is one particular Windows 8 Laptop that no matter what we do, reverts back to "get the DNS automatically." which makes the internet not work on there.
    What is bizzare is that during the morning and day it is OK and around 5PM it starts to cut off. Not sure if this has anything to do with peak users or Adam Internet but that is beside the point.
    the problem is with one laptop.
      My System SpecsSystem Spec

  9. #9


    Posts : 3
    Windows 7


    Yes, I AM IT ...well graphic designer/web developer and by default (the IT guy....) and yes the problem is only happening to that one laptop.

    I have tried to set the DNS in the router but it's never worked, so I ended up setting each and every machine as we didn't have time to fix the problem. Maybe I haven't "enabled the dns relay" option...which I will look at now.
    The problem is only happening with one win8 laptop. We have 5 machines on win8 and another laptop which is win8 which holds the setting.

    So my plan of attack is:

    1. Investigate the software that's being run or is running in the background that is resetting the DNS information.
    2. Investigate the router settings to enable the dns relay
      My System SpecsSystem Spec

  10. #10


    Posts : 3
    Windows 7


    Quote Originally Posted by cookie720 View Post
    Yes, I AM IT ...well graphic designer/web developer and by default (the IT guy....) and yes the problem is only happening to that one laptop.

    I have tried to set the DNS in the router but it's never worked, so I ended up setting each and every machine as we didn't have time to fix the problem. Maybe I haven't "enabled the dns relay" option...which I will look at now.
    The problem is only happening with one win8 laptop. We have 5 machines on win8 and another laptop which is win8 which holds the setting.

    So my plan of attack is:

    1. Investigate the software that's being run or is running in the background that is resetting the DNS information.
    2. Investigate the router settings to enable the dns relay

    All fixed, just reformatted win8. Would have been faster than trying to figure out what it was...
    Thanks to all
      My System SpecsSystem Spec

TCP/IP setting on windows 8 reverting back to automatic
Related Threads
So I've had this problem for a couple of weeks now, everytime I reboot my PC to install the updates it will seemingly fail at 100% when configuring the updates "failure configuring updates, reverting back changes" I haven't done any critical changes to my PC, it just suddenly didn't configure the...
reverting back to changes in Windows Updates & Activation
Hello i have a lenovo windows 8 laptop which is having trouble updating and goes to reverting back. Recently its been stuck on that screen for a long time. I did reset it but it goes to the same screen
Good day everyone! I just had my laptop install Windows 8.1 tonight. It's a clean install, by the way. Now the problem is I noticed that every time I restart my laptop it's power plan reverts back to "power saver", I had it set on "high performance" before. I own a Samsung laptop, model is...
failure in update and is reverting back in Windows Updates & Activation
My acer aspire v5-571-6471 went to update last night. It ran into a problem of some sort told me failure in update and is reverting back to its last functions. I went to bed and when I woke it was on a please wait screen. Been there for 9 hours. I tried alt+f10 to access the recovery partion as I...
I have had this machine for 10 months ...Now when i boot it up it has started to boot up in recovery mode and I have to keep doing a system restore .... It then works for a day or 2 and starts the process all over again, its driving me mad. I have run anti virus and spybot etc and found nothing...
Im sorry, Im new to these forums so I couldn't figure out how to make a new thread. I got the Pro upgrade last night, and I want to do a "keep all files" install. I went into the BIOS and fixed the "NX" problem by enabling it. The problem is, I can't finish the install. It gets all the way to...
Hi there I had to revert one of my laptops back to W7 -- need it for work. I'm still using W8 at home etc. I did a CLEAN re- install of W7 Enterprise X-64 which INCLUDED SP1. After the install it needed over 120 updates -- even BEFORE installing OFFICE 2010. This was a W7 install which...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook