Windows 8 and 8.1 Forums


Updated from 8 to 8.1, now LAN speeds very slow

  1. #1


    Posts : 15
    Win8.1 Pro x64 w/MC

    Updated from 8 to 8.1, now LAN speeds very slow


    Updated my system from 8 Pro x64 to 8.1 pro x64 this past weekend. Ever since speeds from my computer to other computers on our home network (some Win 7, some Win 8) and especially to my two Synology Diskstations have dropped during file transfers from averaging 70/mbps running Win 8 to 22/mbps now running 8.1 .

    Updated the NIC driver for the Realtek RTL8111E built-in to my mobo (ASRock Z77 Pro 4) to the latest Oct 2013 but no difference.

    Any suggestions?

    Sam

      My System SpecsSystem Spec

  2. #2


    I've got a similar issue going on but in my case it's wifi. Linksys router and card, used to get 11 mb/s now it's like 3 mb/s and nothing has changed except 8.0 to 8.1. No other changes. I had to overwrite the default driver choice after upgrade to 8.1 because it was not right. But it's the same exact driver I was using in 8. Seems like there is something in 8.1 that is hamstringing network connections and I can't seem to find the root cause. Bummer because I love to be on the newest versions of the OS.
      My System SpecsSystem Spec

  3. #3


    Posts : 1,883
    7601.18247.x86fre.win7sp1
      My System SpecsSystem Spec

  4. #4


    Maybe they will notice that the latest driver is not from Oct. 2013 which is back in the original Windows 8 days, in reality the latest version 8.024 "1-24-2014" is sitting right there at the Realtek site for everyone to find.

    What gets me is why does Msoft need to change the entire network stack which requires a new driver every time they update this Op system?

    I know they did some changes because of DNS security but this is becoming ridiculous.
      My System SpecsSystem Spec

  5. #5


    Posts : 15
    Win8.1 Pro x64 w/MC


    My mistake, in my post I meant to say Dec 2013, don't know why I typed Oct. Anyway the driver I installed the other day was the 12/17/2013 driver.

    Sam
      My System SpecsSystem Spec

  6. #6


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    heh heh - nevermind - I just had to edit to correct. Yes, 12/17/2013 is latest.

    Can't hurt to try a router firmware update.

    If you have 3rd party security, uninstall to test.
      My System SpecsSystem Spec

Updated from 8 to 8.1, now LAN speeds very slow
Related Threads
Hello, I upgraded my speeds to 150mbps. I get this speed if I am just using the ISP's modem. Through the R7000 router, my speed drops to about 35mbps. I am directly connected through the LAN port. When I did a powercycle my speeds were normal, but the next day it was back to 35mbps. What...
Slow Transfer Speeds over Network in Network & Sharing
Hi guys, I have three computers on my home network: (a) desktop in the office with ASUS USB-N53 adapter (b) new desktop in the office with fairly old Broadcom PCI 802.11g adapter (c) media box hooked up to TV hard wired to router I recently mapped a drive on system A so that it could be...
I recently upgraded to Windows 8, but since my download speeds have been very low. I pay for 2mb, but I'm getting about 100-500 kb/s when I download things on, say, Steam. I've done speed tsts from speedtest.net and it says I'm getting over 2mb/s download speeds, but I'm not seeing this in my...
Mega slow transfer speeds between partitions in Performance & Maintenance
Hey, I am notices some seriously slow speeds when transferring files between either partitions or even to an external drive. The transfer speeds is running between 3mbs and 10mbs which feels very slow. The machine is not dual booting other OS's and was formatted when installing Windows 8....
Slow boot speeds and other issues in Performance & Maintenance
Alright, so to start, I've been having some boot issues with W8 lately. It's fast and all, and I've optimized it to my liking, disabled Hibernation, but still, booting is long. The OEM boot logo is fast, but from then I just get a black screen for about a minute until it boots. This is annoying...
Slow USB 3 speeds. in Drivers & Hardware
I have a new Asrock H77-Pro4-M motherboard and i'm running win 8 (fresh install). I haven't added any specific drivers that i can find to enhance usb 3 from the mb website, i thought Win 8 would come with its own. Im only getting 28-30mb/sec transfer speeds from both ports and on two seperate usb...
so i upgraded from Windows 7 to Windows 8, had a few complications along the way, but finally got it up and running, thought everything was cool, the i went to download a tv show. pre-Windows 8 my max downloading speed was about 540kbs, but now since i upgraded i get 170-230kbs. i went to...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook