Windows 8 and 8.1 Forums

Cisco AnyConnect

  1. #1

    Cisco AnyConnect


    I am currently running W7, downloaded W8 CP. We use Cisco AnyConnect 2.3.x, runs fine on 7, anyone tried it with 8 yet? I suppose I could always fire it off in a VM if it fails to run on 8.

    If anyone has any experience with this, let me know!

      My System SpecsSystem Spec

  2. #2


    Urf. Tried installing in VirtualBox... all LOOKS well until you go to do stuff. I keep losing mouse input, and when I was installing AnyConnect my screen went black and could not get it back. I am hoping this is all just due to running in VirtualBox... and it would be different on real hardware.
      My System SpecsSystem Spec

  3. #3


    Posts : 1
    Windows 8 x64


    Just did an upgrade from Win7 x64 to Win8CP x64. Anyconnect 2.3.0254 loads but fails to connect after entering password. Anybody got any ideas/workarounds?
      My System SpecsSystem Spec

  4. #4


    No... I've looked at the log but it doesn't mean much to me. Going to go over some of the values with a networking guy at work to see what he thinks. In the meantime I've resorted to running W7 in a VM (VirtualBox) to get work done.
      My System SpecsSystem Spec

  5. #5


    I see the connection establish, then it tries to take it to the next level and...
    -------------------------
    Function: IHostMgr::enableHostMgr Return code: 0xFE09000E File: .\VpnMgr.cpp Line: 1069 Description: VAMGR_ERROR_CVIRTUALADAPTER_FAILED.
    -------------------------
    Followed by a dump of all the connection data and this...
    -------------------------
    Termination reason code 13: Unable to start VA, setup shared queue, or VA gave up on shared queue..
      My System SpecsSystem Spec

  6. #6


    Still working to resolve this. I have a "network guy" who wants to help, but has been bogged down at work... so we will see next week if he is able to get some time.
      My System SpecsSystem Spec

  7. #7


    This page at MSDN shows a couple of solutions for the Cisco VPN that are working for some using Windows 8.

    Windows 8 and (Cisco) VPN
      My System SpecsSystem Spec

  8. #8


    The trick us to edit the display name of the anyconnect config in the registry.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnvaCheck the DisplayName data value. On my installation, it had a bit of inf information before the actual name. So deleted that info, and was left with just Cisco AnyConnect VPN Virtual Miniport Adapter for Windows x64. Fired up the VPN Client and connected without any problems
      My System SpecsSystem Spec

  9. #9


    Quote Originally Posted by Tuishimi View Post
    The trick us to edit the display name of the anyconnect config in the registry.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnvaCheck the DisplayName data value. On my installation, it had a bit of inf information before the actual name. So deleted that info, and was left with just Cisco AnyConnect VPN Virtual Miniport Adapter for Windows x64. Fired up the VPN Client and connected without any problems
    Yes I believe that was the main fix for this problem which is posted at the TechNet page I posted a link too earlier.

    Thanks for confirming that it works Tuishimi. I had no way of testing this out myself which is the reason I posted a link to the page with the information to fix the problem.


    Quote from TechNet page below:
    Hi Everyone,

    Just to update, the legacy Cisco VPN client (5.0.07.0440 for x64, 5.0.07.0410 for x86) is working for some people. You need to apply a small workaround as explained below –

    · Open Registry editor by typingregedit in Run prompt

    · Browse to the Registry Key HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Services\\CVirtA

    · Select the DisplayName to modify, and remove the leading characters from the value data upto "%;" i.e.

    o For x86, change the value data from something like "@oem8.inf,%CVirtA_Desc%;Cisco Systems VPN Adapter” to "Cisco Systems VPN Adapter”

    o For x64, change the value data from something like "@oem8.inf,%CVirtA_Desc%;Cisco Systems VPN Adapter for 64-bit Windows” to "Cisco Systems VPN Adapter for 64-bit Windows”

    · Try connecting again
    Please do revert back if this solution does not work
    Regards,
    Raman
      My System SpecsSystem Spec

  10. #10


    Yes! Thank you!
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Cisco AnyConnect
Related Threads
Cisco IOS switch? in Network & Sharing
Does anyone know what the least expensive (even if used) Cisco IOS switch is? I want to have one for messing around with on a home network. I do have Cisco Packet Tracer, but it would be nice to have a physical IOS device too. Also I should mention that I do not have a serial port on my PC, which...
Read more at: Multiple Cisco home products vulnerable to exploit | ZDNet Cisco Security Advisory: Cisco Wireless Residential Gateway Remote Code Execution Vulnerability
Cisco says it will fix backdoor found in routers - Computerworld
Windows 8.1 and Cisco VPN in Software and Apps
Fortunately, I decided to try it before I needed it, but I am unable to connect to my work's VPN using Windows 8.1. I will explain what has happened so far. The connection I make is a web VPN type connection, and the url I connect to says "Cisco Secure Desktop" in case that specifies a specific...
Belkin to buy Cisco in Chillout Room
I just found this and can't believe what I'm hearing.....I've been partial to Cisco/Linksys products since I entered the network environment. Cisco Exits The Consumer Market As It Sells Linksys To Belkin
Eight Forums Android App Eight Forums IOS App Follow us on Facebook