Windows 8 and 8.1 Forums

netsh cannot find loopback adapter anymore after update

  1. #1

    netsh cannot find loopback adapter anymore after update


    for a while I've been using netsh to add some IP addresses to the standard windows loopback adapter (interface idx=1) which worked fine until today when I ran windows update.

    I have always used this command to assign my loopback adapter an extra IP:
    netsh int ip add addr 1 address= mask= st=ac
    (using an example IP address)

    But since installing the updates, this returns the following error message:

    Failed to configure the DHCP service. The interface may be disconnected.
    The system cannot find the file specified.

    However, when I do "netsh int ip show int" it clearly shows the following interfaces:
    Idx Met MTU State Name
    --- ---------- ---------- ------------ ---------------------------
    1 50 4294967295 connected Loopback Pseudo-Interface 1
    3 25 1500 connected Wi-Fi
    4 5 1500 disconnected Local Area Connection* 2

    and it's not disconnected at all. The only fix I have found so far was reinstalling windows 8.1 and not installing any updates... I just installed the updates again and it stopped working.

    Any help would be greatly appreciated. I'm seriously contemplating on going back to windows 7, windows 8 has given me nothing but trouble as a power user so far...

      My System SpecsSystem Spec

  2. #2

    Posts : 1,883


    Off the top of my head...but doubtful it's gonna help...

    Did WU ask to reboot and you declined to do so as of yet?

    Can't hurt none to run an sfc /scannow command and also to ensure the latest adapter driver is installed.

    I understand it's an issue with when an update was applied, but these things may help nonetheless.

    If not, I think you'd be most successful by trying to figure out exactly which file it is complaining that it can not access or find. Maybe a permissions thing or maybe some file really is missing. Event logs? I dunno.
      My System SpecsSystem Spec

  3. #3

    Thanks for your reply, I did reboot after updating, that didn't help.

    I just found a solution, I fixed it with this:

    "netsh interface ip set dns 1 dhcp"

    Appearantly one of the updates messes with the dns settings.
      My System SpecsSystem Spec

netsh cannot find loopback adapter anymore after update
Related Threads
Adapter Can't Find 5ghz in Network & Sharing
Router is Netgear R6200 Laptop isn't capable, but I have a wireless adapter ( EDIMAX Technology - Official Website - N150 - Wireless nLITE 3dBi High Gain USB Adapter ) that should recognize the 5ghz band, I went into all my router settings, everything checks out out.. look at the properties under...
After updating my windows 8 computer and restarting it I found I was unable to connect via wireless internet. I'm currently connected with a Ethernet cable. 44444 Anybody have an idea of where I should go from here?
According to a driver update program, I have an old installed MS Basic Adapter driver and need v. Been looking on Google and Bing, but can't seem to find this exact one. Anyone know where I can download it? Thanks.
When I try to change my video adapter the only option I get is Microsoft Basic Display Adapter. I have a Nvidia Geforce Go 7400 Specs: Operating System: Windows 8 Pro 32-bit System Manufacturer: Dell Inc. System Model: Latitude D820 BIOS: Phoenix ROM BIOS PLUS Version 1.10 A10 Processor:...
loopback adapter in Drivers & Hardware
Hello , i recently instaled Windows 8 loopback adaptor and ran into a big problem. After shutting down my computer , i tryed to start it again and a smiley face was shown to me ":(" with the text saying something like this : " We ran into a problem , trying to fix it , w8ing for restart (and...
PS3 won't find my laptop anymore in Network & Sharing
With Windows 7 I used to stream videos on my PS3 all the time and it worked beautifully. I got a new laptop with Windows 8 and now I'm regretting it. I did everything the same way I did with Windows 7 to set up media sharing/streaming. It didn't work. I researched online for hours. I found a couple...
I have an old application that I can no longer get support for from a defunct publisher that uses a license key that is tied to a MAC address. I've been using it for years under XP with a Virtual NIC driver that allowed me to specify the MAC address of the Virtual NIC. The Driver is freeware and...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook