Windows 8 and 8.1 Forums


"Ethernet" does not have a valid ip configuration. Help?

  1. #1


    Posts : 7
    Windows 8.1

    "Ethernet" does not have a valid ip configuration. Help?


    Hey guys i'm stumped on what is going on with my network connection. I have tried updating the drivers, refreshing my computer, installing all updates.

    Type of computer: HP Pavilion 20-b010

    Code:
    Windows IP Configuration
    
       Host Name . . . . . . . . . . . . : Desktop
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
    
    
    Wireless LAN adapter Local Area Connection* 11:
    
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
       Physical Address. . . . . . . . . : A4-17-31-15-08-F8
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
    
    
    Wireless LAN adapter Wi-Fi:
    
    
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Ralink RT5390R 802.11bgn Wi-Fi Adapter
       Physical Address. . . . . . . . . : A4-17-31-15-08-FE
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 10.0.1.17(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Saturday, January 18, 2014 11:54:29 PM
       Lease Expires . . . . . . . . . . : Sunday, January 19, 2014 11:54:35 PM
       Default Gateway . . . . . . . . . : 10.0.1.1
       DHCP Server . . . . . . . . . . . : 10.0.1.1
       DNS Servers . . . . . . . . . . . : 10.0.1.1
       NetBIOS over Tcpip. . . . . . . . : Enabled
    
    
    Ethernet adapter Ethernet:
    
    
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
       Physical Address. . . . . . . . . : 70-54-D2-1B-BB-6B
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Autoconfiguration IPv4 Address. . : 169.254.150.64(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . :
       NetBIOS over Tcpip. . . . . . . . : Enabled
    
    
    Tunnel adapter isatap.{03DB802E-368A-4B45-A576-292D31FE8103}:
    
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    
    
    Tunnel adapter isatap.{106915AF-275E-4212-AF6D-223F163BDA08}:
    
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Ethernet Adapter: Realtek PCIe FE Family Controller

    Thanks for reading! Please help if you know how to.

      My System SpecsSystem Spec

  2. #2


    You should first try updating the Realtek driver directly from the HP site, the link below takes you there.

    What are you using for a router?

    Software & driver downloads HP Pavilion 20-b010 All-in-One Desktop PC | HP® Support
      My System SpecsSystem Spec

  3. #3


    Posts : 7
    Windows 8.1


    I have the latest driver from HP. I don't have a router nor a modem. I live in an apartment complex and we just plug the ethernet cable into the wall.
      My System SpecsSystem Spec

  4. #4


    Quote Originally Posted by montalvom View Post
    I have the latest driver from HP. I don't have a router nor a modem. I live in an apartment complex and we just plug the ethernet cable into the wall.
    In that case you are at the mercy of who ever is in control of the router in the apt. complex. Most likely that router will require a firmware update in order to work with Windows 8.1.
      My System SpecsSystem Spec

  5. #5


    Posts : 7
    Windows 8.1


    I have a laptop with windows 8.1 when I use the ethernet cable there it works fine.
      My System SpecsSystem Spec

  6. #6


    Quote Originally Posted by montalvom View Post
    I have a laptop with windows 8.1 when I use the ethernet cable there it works fine.
    Why not mention this in the first post? In that case I can't imagine what the problem might be, maybe a third party program or antivirus is somehow blocking the connection.
      My System SpecsSystem Spec

  7. #7


    Posts : 7
    Windows 8.1


    I get this error as well. Is there anyway i could be missing a registry file or something? I know its not the antivirus.
    Code:
    C:\WINDOWS\system32>netsh int ip reset reset.log hitResetting Interface, OK!
    Resetting , failed.
    Access is denied.
    
    
    Resetting , OK!
    Restart the computer to complete this action.
      My System SpecsSystem Spec

  8. #8


    Quote Originally Posted by montalvom View Post
    I get this error as well. Is there anyway i could be missing a registry file or something? I know its not the antivirus.
    Code:
    C:\WINDOWS\system32>netsh int ip reset reset.log hitResetting Interface, OK!
    Resetting , failed.
    Access is denied.
    
    
    Resetting , OK!
    Restart the computer to complete this action.
    This error message doesn't make much sense to me, the netsh commands are used to set up a hosted wireless network among other things but I'm not sure why you would get this.

    Try running the sfc and DISM repair commands per the link below. Let me know what the scan's say when they complete.
    Accessing internet
      My System SpecsSystem Spec

  9. #9


    Posts : 7
    Windows 8.1


    Code:
    C:\WINDOWS\system32>sfc /scannow
    
    Beginning system scan.  This process will take some time.
    
    
    Beginning verification phase of system scan.
    Verification 100% complete.
    
    
    Windows Resource Protection did not find any integrity violations.
    Code:
    C:\WINDOWS\system32>Dism /Online /Cleanup-Image /RestoreHealth
    
    
    Deployment Image Servicing and Management tool
    Version: 6.3.9600.16384
    
    
    Image Version: 6.3.9600.16384
    
    
    [==========================100.0%==========================]
    The restore operation completed successfully. The component store corruption was
     repaired.
    The operation completed successfully.
      My System SpecsSystem Spec

  10. #10


    Nothing wrong there. Seems to me that this particular Realtek NIC is having a problem connecting to this particular router although if you can't even access the router there isn't much we can do about this.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
"Ethernet" does not have a valid ip configuration. Help?
Related Threads
Hi guys. So when I turned on my desktop today, I got the limited network sign. I am using Powerline, so it showed as Ethernet, just as usual. I had the powerline adaptors unplugged, since I moved my PC to another room for a day, and then back again in the old place where it used to work perfectly....
You have probably heard this problem a lot of times and it have bin talked about in a lot of forums. But after searching and trying almost every posable fix I could find, nothing would fix the problem ""Ethernet" doesn't have a valid IP configuration". After playing a match in "League of...
Hello, Recently I have been intermittently getting disconnected from the internet while gaming / streaming. If I ran the troubleshooter, the error that I got was "Default gateway not available". Resetting my router/modem and restarting the PC every time it happened seemed to resolve this for a...
Hi Everyone, I bought a a Lenovo IdeaPad P400 Touch laptop last week, with Windows 8 64-bit OS. I went through the general setup and had the computer working in no time; wireless and Ethernet connections worked fine for a few days and then I began getting "Limited" connectivity errors on both...
So I've been using this router, Belkin N+ wireless router F5D8235-4 v2, for a while now and It hasn't had problems most of the time and I've been using it fine with my DSL modem. My mother connects with her Nook tablet, my father with his laptop, and sometimes my phone and no problems. Until the...
Hi all, I recently got windows 8 and have found it to be rather volatile. I use WiFi in my house on my desktop Intel PC and my computer strangely sometimes works to get to the internet and sometimes it doesn't coming up with connection limited and after troubleshooting it "doesn't have a valid ip...
Hi, I'm using an ethernet cord to connect to my internet and it has been working well until Thursday morning when I turned on my laptop (Windows 8) to see a yellow triangle sign in the bottom right hand corner, in front of the ethernet connected symbol. Since then I haven't been able been able...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook