Windows 8 and 8.1 Forums

Web Browsers works fine but STEAM APP still no web con.

  1. #1

    Web Browsers works fine but STEAM APP still no web con.

    So far you guys here at & have never failed to give me great answers or ideas. As always, I do my best on my end to search for my answer before I submit a new post. Well, I just cant find any answers through searching here, OR google that has helped me.
    So my web browser's works fine, all 3 in fact (Chrome,Firefox, Explorer) however, when I open my steam app (gaming program) it keeps telling me it is not establishing any internet service and to check my settings. I opened up origin and it works fine! another related note, My Nvidia Gforce Experience App that keeps tabs on latest updates for my Video card, tells me there is a new update. but when I press the green download button, it also tells me I have no internet connection... I searched under my allowed programs & apps in my firewall settings and its squeaky clean... I then did a system restore and used a restore point from 2 days ago when I know for a fact everything was running great, I still get same results. So that's it fellas. anyone have any idea what the hell is going on here? Thank you all as always for taking this time to read my problems.

      My System SpecsSystem Spec

  2. #2

    A few others I know as well as me had this same problem last night. What we did was reboot and then opened steam and steam opened right up.
      My System SpecsSystem Spec

  3. #3

    I've tried that and still no results. thank you for replying though..
      My System SpecsSystem Spec

  4. #4

    Depending on how many games you have, have you considered un-installing steam and re-install steam. I know it's a big PITA, but it might work.
      My System SpecsSystem Spec

  5. #5

    Just to clarify, are you using steam on the desktop? I've not heard of a steam app and just checking the MS store I see that there is. I personally just use steam in desktop mode.
      My System SpecsSystem Spec

Web Browsers works fine but STEAM APP still no web con.
Related Threads
Hi there It's a reliable source so I don't have any issues with this particular developer -- if you want to try and run an "Unofficial" but working XP SP4 then it's available here in this link Discussion Board :: View topic - Starting a Windows XP Service Pack 4 Project. Test...
I can access all my browsers but things like Skype and Steam won't open I was having a problem with a program yesterday that unpacked in the temp folder incorrectly and I have been trying to fix that since then I had to work yesterday or I would have resorted to something like this much sooner I am...
Hello, So glad to have found this forum and hope to get some input. My laptop has occasionally failed to start up (BSOD at boot) but eventually restarts correctly (after a hard restart or two) sometimes saying it is running a diagnostic and starting in a previous state. But this morning it...
(Windows 8.1) I have seen a problem quite like this. IE is not my default browser. I uncovered this due to an application that is hard coded top open IE. When I open IE nothing happens. When I enter a url it just sits there like it is not connected to the Internet. No errors, nothing. When I...
VMware workstation 9 seems to handle multimedia much better than previous releases including decent DVD playing. I posted this thread in the W7 Forum for more details. Vmware worstation rel 9 -- now plays DVD's perfectly in a VM - Windows 7 Forums This should make your testing of W8 in a VM...
Hi all Until now I've found it a real problem getting the built in Sony VAIO webcam to work --drivers are fine but apart from SKYPE I was unable to find any stand alone application which would make the webcam work. However I copied the AMCAP program from an old Philips FREEVENT computer -- and...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook