Windows 8 and 8.1 Forums

win8.1 upgrade and router

  1. #1

    win8.1 upgrade and router

    Hi all,
    I’m not exactly sure where this should go, so feel free to move it to the appropriate forum, thanks.
    My wife has a Toshiba laptop that came with win8 installed and was working fine. I installed software supplied by Belkin to get her access to the printer that is connected to the USB port of the router. Was working fine also until she installed win8.1 upgrade offered by MS. Also not working was Windows live mail, but I fixed that by going to programs and clicked on fix. This does not work on the “Belkin USB print and storage center” I have uninstalled and re-installed several times, but no luck.
    When windows starts up it gives me an error pop up telling me: Belkin USB print and storage center,a system error occurred.
    No error number or anything, just a system error with the yellow triangle. Also, a setup screen comes up and wants ne to input the network name and password, but it can never log on to the router.
    My wife has internet access and can get her mail, but cannot print anything.
    Any idea on how to fix this?


      My System SpecsSystem Spec

  2. #2

    Posts : 2,191
    Windows 8.1

    Hi Sven,

    Have you contacted Belkin directly because we can't help you without knowing the specs of all hardware involved with this issue.
      My System SpecsSystem Spec

  3. #3

    Thanks for your replay,
    I just came from the Belkin site and it appears that I am not the only one with that problem.
    As of now there is no real fix, just suggestion like update the firmware and reinstall the software.
    I have the latest firmware on my router and I have reinstalled several times. I guess I just have to wait till they come out with the software fix. In the meantime I will not update any more of my win8 computers to 8.1 my wife will have to just save the file and I will print it from my computer.

    Thanks again
      My System SpecsSystem Spec

  4. #4

    Hi all,
    I went back to the Belkin web site, and found the below suggestionthat worked for me.
    Hope this will help someone else:
    InWindows' Device Manager (devmgmt.msc), the SXUPTP driver was showing as disabled.Windows gave a warning that the device was known to have stability issues. Ifound out that SXUPTP is a driver from a company called Silex. Silex makesnetwork USB hubs, so I assume that the Belkin hub is a rebranded Silex hub.

    In order to update the Silex driver follow these steps:
    1. Close the Belkin network hub's tray application.
    2. Download the latest version of SX Virtual Link(
    3. Extract all of the files.
    4. In Windows Explorer, navigate to sx-virtual_link_win_3120\s-33a3120\Files\Bin\Sxcsapi\WinVistaX64if you are running a 64 bit OS, orsx-virtual_link_win_3120\s-33a3120\Files\Bin\Sxcsapi\WinVista if you arerunning a 32 bit OS.
    5. Right-click on "Sxuptp.inf" and select "Install" fromthe menu.

    The driver will be installed and the warning icon in the device manager shoulddisappear. You may need to reboot for the changes to take effect.

      My System SpecsSystem Spec

  5. #5

    Posts : 1
    windows 8.1

    Hi Sven, I also had this trouble with the Belkin Router and the USB Printer angd Storage, Here is a video that shows how easy it is to fix the problem,

    SXUPTP DRIVER FIX for Belkin Router - YouTube

    Thanks rwbrun
      My System SpecsSystem Spec

  6. #6

    Thanks Sven - you are a STAR!!

    Thanks for your very helpful posting. Belkin works great now.
      My System SpecsSystem Spec

  7. #7

    Posts : 1
    Windows 7 and Windows 8.1

    terriffic!!!! Thanks!!!!
      My System SpecsSystem Spec

  8. #8

    Posts : 1
    windows 10 upgrade

    In case anyone comes looking for a solution, I noticed the video link in post #5 is no longer valid. I installed the latest silex driver as described in post #4, but was still getting the error message at startup. I fixed this problem through device manager/system devices/SXUTP driver, which showed a yellow warning triangle. Right click on the driver, choose "update driver" and allow windows to go online to look for a fix. Worked for me.
    Last edited by Straight; 27 Feb 2016 at 12:40. Reason: clarify
      My System SpecsSystem Spec

win8.1 upgrade and router
Related Threads
Hi there, I use a small usb modem for my internet access and using a usb wifi adaptor and a virtual wifi router I was able to share my internet around home quite affordably. Every now and again the software 'virtualrouter' would cause a crash. Maybe once every 3 months. When I updated to...
Solved Upgrade from Win8 to Win8.1Update in Installation & Setup
Last Fall I bought my wife a Dell All In One with Win8 installed. I seldom, if ever use it for I am sticking with 7 for now. She has Live Mail, Firefox installed and that is about it. No apps other than those that came with the machine. Is it worth while upgrading to 8.1 and then 8.1Update?...
I upgraded two computers from win8 retail to win 81. One totally failed and had to removed the hard drive and put it in my working computer, to roll it back to win 8.0. It would not boot at all not even to bios after that fiasco. The other computer went just fine. The MSI P7N motherboard with...
Win8 Upgrade or Win8.1 New Install in Installation & Setup
What's better, upgrade a Win8 to Win8.1 or purchase Win8.1 ? Harold
Is it possible to upgrade from Win8 32bit to Win8 x64bit or trick the PC into thinking its x64bit so I can install x64bit programs
I just downloaded the Technet version of Win8 Pro. When trying to UPGRADE the RP version, I keep getting a message to "remove install media, boot windows normally, and then add the install media afterwards". Of course, nothing happens when I reboot, heh. It LOOKS like I will have to do a clean...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook