Windows 8 and 8.1 Forums


Connecting Windows 8.1 to a Windows 7 Homegroup

  1. #11


    In that case you might want to look into the fixing the corrupted user profile link that I posted.

    Honestly strange problem here, very.

    It might be worth checking if Windows Services which relate to Networking are enabled.

    •DNS Client
    •Function Discovery Provider Host
    •Function Discovery Resource Publication
    •Peer Networking Grouping
    •HomeGroup Provider
    •HomeGroup Listener
    •SSDP Discovery
    •UPnP Device Host


    A refresh or reset might even be easier.
    Refresh or Reset Windows 8 without Installation Disk

      My System SpecsSystem Spec

  2. #12


    Posts : 13
    Win 8.1 x64


    .1Just to check, is this link suitable for Windows 8.1? 8.1 was installed from the net.
      My System SpecsSystem Spec

  3. #13


    Quote Originally Posted by shag00 View Post
    Just to check, is this link suitable for Windows 8.1?
    Did you try running the DISM command in the first link I posted?

    Yes it relates to Windows 8.1 although I'm pretty sure there is a bigger problem involved, component store corruption is more typical lately which is where the DISM command may help.

    Dism /Online /Cleanup-Image /RestoreHealth
      My System SpecsSystem Spec

  4. #14


    Posts : 13
    Win 8.1 x64


    To try and summarise what I have done so far:

    1/ created a new user and deleted old user
    2/ checked that all the services are running
    3/ followed the Install.wim tutorial (not that I really understand what that is)
    4/ Disconnected from the Homegroup

    and now

    1/ I can access the drive on the Win 8 machine
    2/ I cannot access some of the folders within the drive
      My System SpecsSystem Spec

  5. #15


    Quote Originally Posted by shag00 View Post
    To try and summarise what I have done so far:

    1/ created a new user and deleted old user
    2/ checked that all the services are running
    3/ followed the Install.wim tutorial (not that I really understand what that is)
    4/ Disconnected from the Homegroup

    and now

    1/ I can access the drive on the Win 8 machine
    2/ I cannot access some of the folders within the drive
    I take it the DISM command didn't fix anything? I need to know this.

    So the user profile was corrupted and creating the new user allowed for access to some folders. Which folders can't you access? This really is expected behavior when there is a corrupted User folder involved.

    Have you tried taking ownership of those files using the take ownership option. Take Ownership Shortcut - Windows 7 Help Forums
    Last edited by chev65; 26 Oct 2013 at 10:52.
      My System SpecsSystem Spec

  6. #16


    Posts : 13
    Win 8.1 x64


    When I ran the DISM command from elevated prompt the reply was something to the effect that the parameters were not recognised. I am assuming that the Install.wim tutorial is the first step in running the DISM command as it did not appear to do anything even though it returned the expected result.

    In relation to taking ownership - it is not possible as the folder is not recognised and cannot be clicked or right clicked.

    Anyway I was so pissed off with this issue I went to the CLI, copied the files out, deleted the directory and made a new one.

    I am not sure what did it but Homegroup now works.
    Last edited by shag00; 26 Oct 2013 at 20:23.
      My System SpecsSystem Spec

  7. #17


    Quote Originally Posted by shag00 View Post
    When I ran the DISM command from elevated prompt the reply was something to the effect that the parameters were not recognised. I am assuming that the Install.wim tutorial is the first step in running the DISM command as it did not appear to do anything even though it returned the expected result.

    In relation to taking ownership - it is not possible as the folder is not recognised and cannot be clicked or right clicked.

    Anyway I was so pissed off with this issue I went to the CLI, copied the files out, deleted the directory and made a new one.

    I am not sure what did it but Homegroup now works.
    The lost Homegroup functionality was just a symptom of the major problem which was the User profile was corrupted. Creating the new User with correct credentials is what fixed that problem.

    This usually happens when someone moves the User folder from the original C: drive location to another location like D: drive, which is ill advised in Windows 8 or 8.1 because as you found out, it causes problems with the transition to 8.1.

    You definitely don't want to move the User folders from the default location as it's been causing endless problems with the upgrade, I have another thread with another guy that can't access the share button, same as you, and I suspect this problem will keep occurring.

    If the DISM restore health command did not pass with a clean bill of health than that system is still messed up.

    I'm glad the Homegroup is working again but being truthful here, this system is still messed up if it's not passing that DISM scan.

    You might find out that the store isn't working properly or that some of the Apps won't open as they should.

    You may be able to fix the problem by running the sfc, and the DISM scans again with reboot between scans, it may require multiple scans in order to fix the problems.
      My System SpecsSystem Spec

  8. #18


    Posts : 13
    Win 8.1 x64


    You have hit the nail right on the head, after spending the entire weekend plus some getting to grips with this issue I now know that User Accounts were the key to most of my problems plus a little bit of file corruption I fixed with chkdsk. In my case I did not move the user folders as I found that doing that caused some minor problems even in Windows 7.

    The problem is, and is repeatable, by having one user account, User1, then adding User2, then delete User1, reboot and recreate User1 again with the same credentials where User1 is a Microsoft account. The problem, at the very least, is caused because when User1 is deleted Windows 8.1 does not fully delete the account. If you run Netplwiz you will find User1 listed twice. Also, in C:\users an account folder is set up with a name other than the user name.

    Once this happens file and folder sharing goes out the window.

    What would be really good is a tutorial or utility showing how to clean out all users except the current user in the files that Windows 8.1 uses to track and control user accounts.

    Thanks for your help.
      My System SpecsSystem Spec

  9. #19


    I had the same problem between Win8.1 and Win7, but different reason - Simpler fix though. All I needed to do was to leave and recreate the homegroup on my primary computer. The Win 8.1 pc was then able to find and join the new homegroup.
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
Connecting Windows 8.1 to a Windows 7 Homegroup
Related Threads
I have a neighbor who has an OPEN network called @HOMED689 . For some reason my Windows 8 machines keep trying to connect to this SSID automatically. I've never tried to connect to it. Once it's connected however, with limited connectivity, I don't have the ability to right click on it and say...
Windows 8 Store Not connecting in Network & Sharing
wondering the same thing (I get the same error). I tweaked something wrong but can't remember what. Sadly comodo time machine doesn't work with RAID. I've tried winsock and tcpip reset, as well as general cache clearing and invalidation. It's not a firewall problem, and NO I am NOT using a...
Hoping one of the Windows 8 experts out there can help. Trying to play music from my Windows Media Player library (not Windows Media Center). This used to work flawlessly with the same router and my previous PC (Windows 7). After launching the System Music Player app on the Xbox, the Xbox...
new Toshiba Computer with windows 8. Will not connect to my phone. Phone is connecting with 2 other computers in the house plus a 1st generation Ipad. Printer is connected also.
Solved Windows 8 Store Not connecting in Software and Apps
My internet is working perfect and every other app is working just fine but this app refuses to load. I have tried reseting, updating, about everything in the book and still no signs of progress. Anyone have any idea how to fix this? Also maps refuses to find locations even when i type them in! ...
Does anyone know what would need to be done to connect a SkyDrive locations to Windows Explorer as perhaps a networked or mapped drive or drive letter? My intent would be to be able to copy, rename and work on SkyDrive files through Windows Explorer.
More...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook