Windows 8 and 8.1 Forums


Win 8.1 looses network connectivity

  1. #1

    Win 8.1 looses network connectivity


    Now that I've upgraded to Win 8.1 my computer looses network connectivity several times a day. I can't even ping other devices on my local network. Rebooting the computer makes the problem go away (for a while). Its this computer running 8.1, none of the other computers on the network (running Win 7 or android) have the problem at the time this computer can't connect.

    This is not good! If there's a way to refresh the network connection (some control panel function) that would be a not-very-good work around. Other than that it may be time to go back to Win 7.

    Are others having this problem? Any suggested solutions?

      My System SpecsSystem Spec

  2. #2


    Posts : 2,191
    Windows 8.1


    Just to be clear, you were running Win 8 and everything was OK and the problem only started when you upgraded via the Windows store to 8.1; correct? The reason I'm asking is because all of your other OK references are to Win 7 so I can't make the connection.
      My System SpecsSystem Spec

  3. #3


    Posts : 2,191
    Windows 8.1


    If there's a way to refresh the network connection
    You can try running the following commands from an elevated prompt:

    ipconfig /release

    followed by

    ipconfig /renew

    Not sure that this will fix your issue but what the heck. Its worth a try. Good luck.
      My System SpecsSystem Spec

  4. #4


    Quote Originally Posted by my2cents View Post
    Just to be clear, you were running Win 8 and everything was OK and the problem only started when you upgraded via the Windows store to 8.1; correct? The reason I'm asking is because all of your other OK references are to Win 7 so I can't make the connection.
    I only have one computer running Win 8 and it has the problem. I have 3 other computers running Win 7 and two android devices. When the problem occurs on the Win 8 computer, all other devices are happy. This problem never occurred on this computer until yesterday when I upgraded to Win 8.1. Next time it happens I'll try resetting the network adapter. I understand a command line 'netsh int ip reset' should do the job. If that works I'll make .bat to "automate" the process :-) Alternately the ipconfig suggestions.
      My System SpecsSystem Spec

  5. #5


    Posts : 3
    Windows 8.1 64


    I'm having the exact same issue.. I upgraded my desktop from Windows 8 to 8.1 and now my wireless adapter is losing connection. It seems like after a certain amount of data the wireless cuts off and I get "limited or no connectivity". Streaming video will cause this to happen sooner. I had no issues and immediately after the upgrade this started happening. I tried to reinstall the wireless usb driver, disabled usb selective suspend, and disabled power management on the adapter. None of this has fixed the issue.
      My System SpecsSystem Spec

  6. #6


    Posts : 9
    Windows 8 Pro


    I have the same issue too
      My System SpecsSystem Spec

  7. #7


    Posts : 3
    Windows8


    Uninstall adaptor and reinstall because of critical update go to device manager in control panel right click on wireless adaptor uninstall restart pc and this should work
      My System SpecsSystem Spec

  8. #8


    Quote Originally Posted by David1974m View Post
    Uninstall adaptor and reinstall because of critical update go to device manager in control panel right click on wireless adaptor uninstall restart pc and this should work
    Simply rebooting "fixes" my problem. That is not a solution, that is a work around until the next time the problem occurs in a few hours or the next day. Its like when you call Dish Network with a problem they say "50% of your problems can be resolved by rebooting the box". What that means is they have no idea how to actually fix 50% of their problems.
      My System SpecsSystem Spec

  9. #9


    Posts : 2,191
    Windows 8.1


    Just a comment that I see you have dual boot listed in your specs. Now I'm not sure if that has anything to do with your issue but I would have also included that in your first post (if applicable). Good luck.
      My System SpecsSystem Spec

  10. #10


    Posts : 3
    Windows8


    I did not say just reboot, I did say uninstall adaptor then reinstall with correct windows drivers first, then I said restart...

    You could also try setting a static IP address
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
Win 8.1 looses network connectivity
Related Threads
Hi, I'm using Asus N550JV (on latest updated Windows 8.1), which includes integrated Atheros wireless network Adapter. The laptop keep losing Internet connectivity many times. The following behavior is causing the laptop to lose its Internet connectivity on a random basis: a. downloading large...
I purchased a new Windows 8, Inspiron 15 7000 series - 7537 last December. I had been using a router at a hotel for the time, and it worked correctly. When I arrived home, I had a Belkin router, and i experienced network issues in that i could not connect to the wifi. I could connect with Ethernet...
Network connectivity Problem in Network & Sharing
HI , I am having an interesting issue here. I have two accounts on my windows 8 laptop.One has admin rights and other is default guest account. Initially every thing was ok as i bought this laptop couple of weeks back. But since yesterday when i use guest account i cannot connect to internet. I...
Last night my wife's laptop couldn't connect to the internet. Error message was DNS servers not responding. I unplug power cables and Ethernet cables from cable modem and router (WRT54GL DD-WRT). That didn't seem to work. Today, she was able to get on certain text heavy websites. The WiFi icon...
i have a sneaking suspicion that i'm inadvertently causing a function action to shut off wireless. i'm in tablet mode so not sure. any ideas? - System
When my new build wakes up, sometimes Windows 8 will report no network connectivity, even though the internet is not down. The problem is intermittent and goes away after a few seconds. It's not a wifi problem because of the connection is by ethernet. At the same time, the motherboard has exhibited...
I'm running Win8 Dev. Preview on a Dell Latitude D610 with a single-core 1.73Ghz processor, 2GB of RAM, and 256MB of video memory. I've been running Win8 for roughly 3 weeks with no problems. Now, for some unknown reason, the dialog box used to connect to wireless networks utterly refuses to open....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook