Windows 8 and 8.1 Forums

Can't execute setup / installation files from network

  1. #1

    Posts : 102
    Windows 8.1 Pro x64

    Can't execute setup / installation files from network

    I recently did a clean install of Windows 8.1 x64. I have a Synology DS213+ NAS server in my LAN. Before doing the clean install (had Windows 8 installed before), all hardware being identical, I could launch setup programs from the NAS volume without any problem.

    Now, after the clean install, I get an "Incorrect parameter" error when trying to run setup.exe files from the NAS. Some other exe files, like small programs that only consist of one exe file, can be run without any problem.

    The following things have been ruled out so far:
    - When first copying the installation files from the NAS to a local hard drive, they can be run without any problem, so it's not the installation files being corrupt. Also tried with many different installation packages.
    - I can directly launch the same installation programs from other computers in the same LAN, without the need of first copying to their local hard drive.
    - If I am in front of the computer causing trouble and run the same installation package from another computer in the LAN (having copied the files there in the first place) I can also execute the setup without that error.
    - The NAS firmware or configuration has not been changed.
    - The hardware of my main computer causing trouble in question has not changed.
    - It does not make a difference whether the setup.exe on the NAS is accessed through the network drive letter of the location or whether I browse to the location via the network address, e.g. //MYNAS/Software/setup.exe

    ==> Hence it must the software (Win 8.1) and its configuration. And it has also to do with the interplay of the computer with that particular network share.

    How can I sort this out? Do not even know how to start. When googling this problem on the web, it pops up now and then but have not found a definitive solution.

    I appreciate any helpful comments.


      My System SpecsSystem Spec

  2. #2

    Posts : 1
    Windows 8.1 Pro

    Are you running Windows 8.1 Pro RTM? I just came off of Windows 8.1 Preview and ran the update from Windows Store to 8.1 Pro RTM and am encountering the *exact* same issue. On preview everything was fine.

    My NAS box is running FreeNAS and it correctly emulates NTFS permissions. The files that I'm trying to run are on a mapped network drive. I'm on a domain network and the files are sitting in remapped user folders. What's your setup like? This is a pretty annoying issue and should never have made it into RTM...
      My System SpecsSystem Spec

  3. #3

    Posts : 102
    Windows 8.1 Pro x64

    I'm running Windows 8.1 Pro final, but believe it should be equal to RTM.

    I found the following work around thanks to the contribution of another user in this thread Synology Inc. Online Community Forum ? View topic - Cannot run Setup files VIA Mapped Drive : In my Synology software, I had to disable "Enable SMB2 and large MTU".

    Afterwards, the issue is resolved. It does not feel right to have to deactivate features, but that seems to be the deal with Microsoft these days, they want to go 1 step forward with their 8.1 update but force us the users to go 2 steps backwards, that is constraint functionality.

    Let's give them a chance and wait to see when/if they issue a bug fix for this.
      My System SpecsSystem Spec

Can't execute setup / installation files from network
Related Threads
I'm trying to install the Windows 8 Preview x64. I've successfully installed it on my old laptop and a Latitude ST from work, but it won't install on my main PC. I go through the setup wizard as normal; no errors. But, when it comes to the actual installing part, it gets stuck on "Getting files...
Hi eighforum, I have trouble with my laptop, This is a win 8 fresh installation(PS. I test with win 7 fresh installation, and the issue es the same) The laptop crash with bluescreen or face screen. I'd appreciate if you could look through my minidump and see if anything can be gleamed. ...
Attempted execute of no execute memory in BSOD Crashes and Debugging
Hello eightforums, I have another recurring issue, this is a fresh install of windows and I am not sure what the problem could be besides hardware. I'd appreciate if you could look through my minidump and see if anything can be gleamed.
As well as my C: drive, I have a large (2Tb) Z: drive on my PC. I then use the "subst" command (using XSubst as the GUI) to create virtual drives pointing to various directories on Z:. For example, P: actually points to Z:\PHOTOGRAPHS, M: points to Z:\MUSIC and O: points to Z:\DOWNLOAD. I can do...
35406 Getting this message every time I start up my computer. Really annoying. I tried deleting my appdata/local/temp and that didn't work. The exe is in a different folder (this time it is in s3ic) every time this pops up, but the folder is no where to be found when I look in...
Hi I prepared a ntfs partition on my second hard drive, big enough for W8. I also hid the other partitions of W7 so that only the new partition would be active. I started the installation CD (W8 enterprise, test version) and the list of all partitions apeared. As I choosed the prepared partition,...
Solved Setup dual boot after installation? in Installation & Setup
Had a dual-boot XP/W7 laptop... XP on partition 1, Win 7 on partition 2. I booted from a USB stick, reformatted partition 1 (XP) and installed Win 8 there. It did not setup a dual boot for me. I know I should have thought of this ahead of time (my bad), BUT... is there anyway, after the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook