Windows 8 and 8.1 Forums


Windows Firewall - Slows FTP / Telnet Connections.

  1. #1


    Posts : 9
    Windows 8

    Windows Firewall - Slows FTP / Telnet Connections.


    Hi
    I user FTP & Telnet a lot to connect to devices on our LAN.

    With Windows 8 I've been using ZoneAlarm as my firewall as I found Windows Firewall caused a 5 -10 second delay in every FTP / Telnet Connection.

    Last night I upgraded to Windows 8.1 and ZoneAlarm no longer works, so I'm back with the Windows Firewall and the delay in connections.

    I've ensured the APPS I use have access via the firewall and they do connect and work fine... but after establishing the connection there is a 5 - 10 second delay in the connection. With ZA this was all instant..

    Any ideas how to resolve this ? Thanks

      My System SpecsSystem Spec

  2. #2


    Posts : 2,191
    Windows 8.1


    Try FTPing in the passive mode. I use the Windows 8 (now 8.1) inherent firewall along with the Filezilla FTP client and I have absolutely no delay issues. good luck.
      My System SpecsSystem Spec

  3. #3


    Posts : 9
    Windows 8


    I'm in passive mode by default, still get this issue.
    I have tried Active mode as well.
      My System SpecsSystem Spec

  4. #4


    Posts : 2,191
    Windows 8.1


    Try changing your FTP client for a test.
      My System SpecsSystem Spec

  5. #5


    Posts : 2,191
    Windows 8.1


    FYI, I have my Windows firewall set to defaults. I have not created any unique inbound or outbound rules. With that said, did you create any special rules when using ZA? Did ZA auto-detect a possible security issue and prompt you to "allow" an inbound or outbound session on a permanent basis?

    Click image for larger version
      My System SpecsSystem Spec

  6. #6


    Posts : 9
    Windows 8


    I use FileZilla FTP and IVT Telnet
    ZA popped up and I allowed them.. then they worked fine.

    Windows firewall popped up this morning, I allowed them and there is still a delay.
    Tried using Windows Telnet and that has the same issue.
      My System SpecsSystem Spec

  7. #7


    Posts : 2,191
    Windows 8.1


    Quote Originally Posted by MadTomT View Post
    I use FileZilla FTP and IVT Telnet
    ZA popped up and I allowed them.. then they worked fine.

    Windows firewall popped up this morning, I allowed them and there is still a delay.
    Tried using Windows Telnet and that has the same issue.
    Thanks for that update. So, at this point I'm out of basic ideas to try because mine works and yours does not; however, I can only assume that you have disclosed all necessary details to make a proper comparison. For example, if you had to go through a proxy and I do not, that wouldn't be a fair comparison. Good luck.
      My System SpecsSystem Spec

  8. #8


    Posts : 9
    Windows 8


    Hi
    Thanks for your help.. The PC and the devices are all on the same LAN, Subnet etc, no proxies etc
    From my Mac laptop ftp / Telnet is fast.. with no delays.

    If I disable Windows firewall the connection is instant, so it is something to do with that.
    I wondered if it was a host name/DNS issue so I've added entries to my hosts file on the PC and remote device and that hasn't helped...

    Struggling to see what else it is..
    Thanks
      My System SpecsSystem Spec

  9. #9


    Posts : 2,191
    Windows 8.1


    So there are some noticeable differences because I am using a simple ethetrnet connection via a router to an ISP modem with default DNS routing provided by my ISP and no issues here. With that said, I hope you get someone to respond with more knowledge regarding your complete configuration (once known) so they can better assist you Good luck.
      My System SpecsSystem Spec

Windows Firewall - Slows FTP / Telnet Connections.
Related Threads
windows 8.1 slows down over time in Performance & Maintenance
I cant figure this one out some how over time windows 8.1 will start to slow down for example adobe lightroom takes about 2 seconds to open, i don't know how long but after some time it will take like 20 seconds or more and while loading it just does not look correct like black boxes that take time...
External HDD Slows Windows Down in Drivers & Hardware
Hello all, I am on an i7-12gb RAM+SSD Asus laptop, running Windows 8 x64. I am using two external HDDs attached via USB. One is an external-powered 2TB 3.5" WD, and the other is a 1TB 2.5" 5400 rpm Matshita HDD. I store my music and movie collection in these drives, and a few setup files...
Hi everyone...I am new here, just joined :) I am glad to be part of this great forum... I have a Lenovo Idea-PC laptop that I bought a year ago..It came with high specifications as follows: OS: Windows 8 64-bit (6.2, Build 9200) Intel (R) Core (TM) i5-3210M CPU @ 2.50 GHz (4CPU) 8 GB...
I am having a number of problems with my desktop, that I put together myself. I had been running windows 8 for a while, and within the last month I installed a new video card (Nvidia EVGA GTX560ti), and a new SSD (OCZ vertex 4 256GB). While still running Windows 8, I had been playing games, doing a...
HDD Usage 100% - Computer slows to a stop in Performance & Maintenance
Hp Laptop DV6 i5 2.4, 4gb RAM, 600GB HDD, GeForce GT 230M. Fresh install of Windows 8. If idle HDD usage drops to almost nothing. So I don't think it's programs running in the background. When I try to do something even as small as type in the password to log in the response time is really...
Hi, One thing I have always been missing from the Windows Firewall is and option to make it prompt if I want to allow and outgoing connection. Right now it does that with ingoing connections only. But for outgoing, the options are either to allow all or block all. Not prompt for a choice. ...
Solved Firewall and Connections problem in Network & Sharing
Hey, I installed Windows 8 about 3 weeks ago and everything was working until 2 days ago and the computer stopped connecting to the network. It is hard wired in via Ethernet port. I then tried going into the network connections to resolve the problem but there was no Ethernet icon so I tried...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook