Windows 8 and 8.1 Forums


Wireless connect problems

  1. #21


    Posts : 8
    Windows 8.1 64-bit


    I don't know, but I am also having problems with the same wireless network card. In Windows 8 everything was fine, but in 8.1 I get strange download speed drops when I speedtest it. My ping and upload speed is fine, but only the download speed is getting huge drops and sometimes is playing death, but I have no connection loses. I also tried all different drivers and no difference. Other computers are fine, but mine is not. I just think that the drivers aren't compatible with 8.1, but are for 8. Here on the windows page, Windows 8.1 compatibility for Asus PCE-N15 Wireless Network Adapter model they have no information about it, but some people also get same or different problems with the card, if you read below. I already send Asus a support message, so hopefully they will do something. The only 2 things you can do, is 1. use cable or 2. reļnstall 8 or lower.
    I have many programs installed, so I am not going to reinstall it and if I am going to use a cable, I would need a 20m cable So temporary you can use the cable if you can move a table closer to the router.
    Also what kind of wireless connection are you using? 802.11 b, g or n?
    If you don't know: press ctrl+shift+esc then click on the tab on top "performance" then click on the left on "Wi-Fi", now you can see on the bottom what type of connection it is. (I am running 802.11g, because of my router).

    Hopefully Asus responds with a message soon enough.
    Here is my latest speedtest: Speedtest.net by Ookla - My Results
    Download speed is just not stable, it sometimes gets even lower, normally I get 15+mbps atleast.

    I hope someone else has a solution, because I already googled every possible way to find a solution.

    Greetings killer.
    Last edited by killerboye; 26 Oct 2013 at 10:49.

      My System SpecsSystem Spec

  2. #22


    Yes the Realtek drivers which I have posted a link too should definitely be working for you. This is about the only option left.

    It's too bad that the original Op to this post flatly ignored my recommendation, I'm getting a bit tired of spinning my wheels here.
      My System SpecsSystem Spec

  3. #23


    Posts : 8
    Windows 8.1 64-bit


    EDIT: I also heard that the asus drivers are crap, so I am also using the realtek one. I think it is just a problem with 8.1, if I had no problems in 8. Btw I install drivers manually, because if I use the setup, it get stuck. Folder with drivers for Windows 8 64bit is ...\RTLWlanE_WindowsDriver_2007.12.0419.2013_ISS_1.00.0212.L\RTWLANE_Driver\Win8X64, right? Wait a sec, when I do it manually it says it has already the latest version or better installed and I just deleted all the previous drivers and device LOL So windows has it's own driver (version: 2008.5.423.2013). Strange ...

    Should I install it manually or not? because I am confused now.
      My System SpecsSystem Spec

  4. #24


    Quote Originally Posted by killerboye View Post
    EDIT: I also heard that the asus drivers are crap, so I am also using the realtek one. I think it is just a problem with 8.1, if I had no problems in 8. Btw I install drivers manually, because if I use the setup, it get stuck. Folder with drivers for Windows 8 64bit is ...\RTLWlanE_WindowsDriver_2007.12.0419.2013_ISS_1.00.0212.L\RTWLANE_Driver\Win8X64, right? Wait a sec, when I do it manually it says it has already the latest version or better installed and I just deleted all the previous drivers and device LOL So windows has it's own driver (version: 2008.5.423.2013). Strange ...

    Should I install it manually or not? because I am confused now.
    You need to uninstall the driver first before Windows will allow you do install an older version.

    You see it's not a problem with windows 8.1 directly, it's a driver problem pure and simple, these types of problems occur each and every time there is a new Op system.

    All you can do is try different drivers until an updated version comes out. You could also try installing the driver in compatibility mode.

    Compatibility Mode - Use in Windows 8
      My System SpecsSystem Spec

  5. #25


    Posts : 8
    Windows 8.1 64-bit


    Quote Originally Posted by chev65 View Post
    You need to uninstall the driver first before Windows will allow you do install an older version.

    You see it's not a problem with windows 8.1 directly, it's a driver problem pure and simple, these types of problems occur each and every time there is a new Op system.

    All you can do is try different drivers until an updated version comes out. You could also try installing the driver in compatibility mode.

    Compatibility Mode - Use in Windows 8
    Can you explain me how to uninstall the windows driver, because if I delete the device and search for it again then it automatically installs it. I even tried to delete the file in the system32\drivers, but it keeps coming back. So I first need to know how to uninstall it properly. Also how can I install drivers in compatible mode? It is only for running programs? Can you explain please?
      My System SpecsSystem Spec

  6. #26


    During the driver update process, select Browse my computer for driver software.

    Then select, let me choose from a list of device drivers on my computer.

    Then select have disk and navigate to where your drivers are stored on the machine.

    Or try the tutorial for this. > Driver - Install in Device Manager in Windows 8

    The link I posted explains how to use compatibility mode. I can only do so much from here.
      My System SpecsSystem Spec

  7. #27


    Posts : 8
    Windows 8.1 64-bit


    I finally could install those drivers, but nope still the same problem after restarting my pc. Do you have any more suggestions? Because I have no idea where the problem is.
    - provider not (other PCs have fine internet, no download speed drops)
    - hardware not (some weeks ago it worked fine, and the network adapter is only 2 months old)
    - biggest chance is that the drivers aren't working right with 8.1. (Because in 8 I had no problems what so ever)
    => Did Microsoft change something in the way how connections or drivers work?

    I am still waiting for a response from Asus, so either asus has to fix it or microsoft ...

    BTW anyone has any suggestions? This problem is just stupid :'(
      My System SpecsSystem Spec

  8. #28


    Sorry, I had a hard time getting connected (and I have been busy), thanks for everyone that replied.

    @chev65 Let me tell you what I have noticed, I moved my computer (and monitor) to right beside my router to test the connection and worked brilliantly (thats where I am now) I have figured out that I must be in a so called 'black spot' or too far away from my router to keep a stable connection, I do think that when I downloaded the drivers you suggested made things better than before, so I have to say thanks for all your help. I have now ordered a stronger antenna to try out and see how that helps. It might be a waste of money but it's worth a shot.

    I will be repping you as you did help me a lot and I am thankful for that, I do apologise for not replying instantly but as I said I had problems.

    Thanks very much again and if all else fails I may purchase a powerline adapter, I will let you know how my stronger antenna works when it arrives
      My System SpecsSystem Spec

  9. #29


    Posts : 8
    Windows 8.1 64-bit


    Good to hear that someone has solved their problem
    I first was thinking that I had like almost the same issue, but actually I don't. I am always connected to the internet. But my problem is that my download speed is unstable in 8.1 compared to 8. So I get huge downloadspeed drops that make playing online games hard. Strange thing is that my ping and upload speed are just stable and don't do strange things. It looks like I am now kind of alone with this problem if I google my issue.
      My System SpecsSystem Spec

  10. #30


    Posts : 96
    Win 8.1 Enterprise


    Stuartie - Glad to hear that you have resolved the issue and thanks for the Rep.
      My System SpecsSystem Spec

Page 3 of 3 FirstFirst 123
Wireless connect problems
Related Threads
A couple of days ago, my network manager started misbehaving after a system update. The computer has trouble connecting to every network it can find and when it finally connects, the connection becomes limited after 10 minutes. It happens to all networks I try to connect to and other devices in my...
This is a random issue, sometimes I can connect just fine, and usually a restart of my laptop lets me connect. However sometimes when I try to enter the password it does not work. I get the error message 'the network security key is not correct. Please try again.' I know for a fact that my...
How to Connect To or Disconnect from a Wireless Network in Windows 8 and 8.1 If you have a laptop or a PC with a wireless network adapter, you can see a list of available wireless networks in your area, and then connect to one of those networks. The wireless networks will only appear if your...
Upgraded ThinkPad laptop via ethernet from 8 to 8.1 then tested out fine. Shutdown for the night and removed the ethernet cable. Day later the Lenovo booted fine and the wireless SSID showed 5 bars on the charms bar. Clicked to connect and was prompted for the pw which was entered correctly. ...
my computer is Dell inspiron 15 win 8 x64 I have problem with my home wifi network; I cant connect ''the settings saved on this computer for the network do not match the requirements of the network'' but when I try other wireless its work; please help me
Hi, I just upgraded to Windows 8 on my work computer. I work from my home office quite a lot and connect wirelessly at home. I have a Netgear RangeMax WNDR3700 router at home that is connected to my broadband modem. Here's the observations I've made: 1. I cannot connect the wireless network...
I have an Acer IconiaTab W500 with Windows 8 developer preview installed on it and I cannot get it to connect to my Cisco 1142 APs. I have a Guest network that is for b/g speeds only and requires . I type the password in and Windows comes back and says something is wrong with the adapter or the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook