Okay, here's my situation:
I'm on a W8 machine connected over Wifi. Network is, a debian server is my DHCP (at pointing to the router at
This router is connected to another LAN (my Dad's) to a DSL router (
My router was given the address, but I fixed it and set the DHCP from the DSL router to assign addresses from .10 and up.
I've also set up DMZ (on the DSL router) for my router at
Before I did that, W8 Network Troubleshooting told me there where multiple NAT's on my network and hence it could not browse nor share over the local network.
W8 stopped telling me there are any problems as soon as I had set up the DMZ.

But still I can't see the W8 computer on the network whereas this previously worked perfectly.

The connection is treated by W8 as private and all sharing options are set up correctly.
I can't connect to any service on the W8 computer (VNC, DLNA, various remote control servers using a variety of ports).
The W8 also can't browse the network, but I can manually type in the ip address of the debian server in explorer and see these shares.

As a last resort, I've completely turned of the Windows Firewall, but that doesn't change my situation
(does turning of the firewall blocks all connections as ie Shorewall does or does it leave the computer unprotected as was the case with older version of Windows ?)

I will happily provide you with more details/logs if that could shine a light on this matter.