Windows 8 and 8.1 Forums

Limited Network with New Router

  1. #1

    Limited Network with New Router


    Basically, when I stick in a new router, it gives me limited connectivity and my old router works fine. I've RMA'd the new router twice now, once for overheating, once for dropped signal, and now it's giving me this. I have reason to believe it is software based, but if anyone could help me fix this problem, it would be greatly appreciated. I've been trying to scour the web for solutions over the past few months, and I have come up with nothing. On my old router, wireless works fine, but wired internet has the same problem. Weird.

    Now that the story's over, here are the main points:
    1) The new router shows "DHCP connection failed." when hovering over the LAN icon.
    2) Comcast denies all allegations that it is their fault. The modem is apparently connecting fine to their servers.
    3) I have exchanged the modem at Costco.

    I have already tried resetting to stock, all those quick fixes. If there's anything in depth I'm missing, please let me know.

    I'm exhausted, exasperated and frustrated. I've spent the past half a year looking for an answer, and I just cannot get it working. I can't return it after the first RMA, because it took 2 weeks to come back, thereby screwing over my return.

    Alright here are some details about the equipment:
    1) The modem is a SB6121.
    2) The old router is a D-Link DIR-825.
    3) The new router is a RT-AC66U.
    4) My PC has both a wired and a wireless connection.
    5) The reason for replacing the DIR-825 is the quality of the wireless is slowly degrading.

    I would hit more keys, but I'm attempting to keep this fairly civilized.
    I'm pretty sure this isn't computer based either, as I have bought a brand new computer in attempts to fix the problem (custom built), and same problem arose. It's also frustrating that the router has little documentation and very few people have had issues with it. Also, when I factory reset the RT-AC66U, it sometimes will work for a couple days, before it will start having the same issues.

      My System SpecsSystem Spec

  2. #2

    Posts : 2,191
    Windows 8.1

    Hi al4nw31,

    You have explained your issue very well; therefore, it almost certainly has to be the new router. With that said, I will start off with a simple recommendation and see where that leads. So, have you downloaded the latest firmware for your new router? By sheer coincidence the latest firmware update was just made available yesterday (9-12-2013):

    RT-AC66U - Networking - ASUS
      My System SpecsSystem Spec

  3. #3

    England, Northamptonshire
    Posts : 536
    Windows 8.1 Pro 64-bit ; Windows Server 2012 R2 Standard

    Quote Originally Posted by al4nw31 View Post
    1) The new router shows "DHCP connection failed." when hovering over the LAN icon.
    Can you upload a screenshot of this at all? I am almost certain that this is your issue.

    Screenshots and Files - Upload and Post in Eight Forums

    Also can you follow this tutorial and upload your IPconfig since this could backup my theory as to what the cause is.

    Network Posting Tips

    Many Thanks,
    Last edited by Shadowjk; 14 Sep 2013 at 11:25. Reason: Added Screenshot upload tutorial
      My System SpecsSystem Spec

  4. #4

    This router the AC66U does have compatibility problems with certain types of wireless NIC's. The latest firmware may help but I don't see any real compatibility updates there.

    I'm running this router in A/P mode, it works fine with my PCE-AC66U NIC which is made to work with this router. It also has no problems with my wife's IPad.

    There is no direct fix for the problem, and it's not a Windows 7 related problem, just certain NIC's aren't working well with this new wireless standard although it may help to change the advanced settings of the wireless NIC, > Properties, advanced tab, but no idea which setting may have an effect because the settings are different for each NIC.

    Best bet is to simply upgrade the wireless NIC to one that is compatible with the new 802.11AC. Either PCI-e or USB.
      My System SpecsSystem Spec

Limited Network with New Router
Related Threads
I'll try to explain this as best I can. Network is a mix of XP, Vista, W7 and W8 desktops and laptops. All connect to router which has a Buffalo Link Station NAS attached and all machines save direct to that. All worked fine until BT decided the router was faulty and installed a new BT...
Yesterday, I decided to relocate my PC from one room to the other. Not a big deal I would assume. However, I was unable to connect to the internet with Firefox at the new location. I checked my signal strength to my router and it seemed fine. So I opened Task Manager and checked the WiFi...
I have a lenovo G505 laptop - it will no longer connect to my BT home hub despite it showing as being available. I suspect it might be to do with the fact that it is has a passkey - I entered it yesterday when prompted and it connected fine, but now I'm not being given the option of entering the...
Solved Network Limited in Network & Sharing
Hey, this is my first thread to the forum. I've got a new routher from my internet provider: ZXV10 H201L And now I have a problem:33327 Theres a manual, i did everything that it says.. Still not working.. I updated the drivers, disable then enable.. Nothing works. Im using Windows 8 x64.
Usually, when I go to port forward my games I go to my computer-> network and i see a dropdown text named "Network infrastructure" with my router under it allowing me to open ports for games. I dont see it anymore for some reason. Any help would be appreciated. this is a picture of where it used to...
I set up a VPN connecting via SSTP & EAP-MSCHAP-V2. This works on multiple machines, just not on this one running Windows 8. It doesn't matter if I connect via 3G or via WiFi - whenever I connect the VPN, all network connections go to "Limited". I don't have any connection to any outside world...
Limited Network in Network & Sharing
Network Layout ASUS Desktop - Windows 7 ( Computer with Issue) S1080 Tablet - Windows 8 Pro With Media Centre CQ43-309AU - Same As S1080 WiFI Network Dialup Internet Connection Problem I just have got Windows 8 Pro with media centre, and I am having trouble connecting my CQ43 and my S1080...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook