I'm trying to stream my shared files to my LG BD570 Blu ray player, something which was no problem when I used Windows 7. I have done all the things required: I went to the files I want to share and select to option to share with Everyone and went to my Advanced Sharing settings where I turned file and printer sharing on and turned password protected sharing off.

This was enough to be able to access my shares on my blu ray using Win 7: my computer name showed up with my shared files listed underneath. Now my computer name shows fine but with no files under it. Now the problem: when I select my computer name a CIFS login screen pops up asking for a username and password. I never chose a username and password anywhere and have NO idea what they could be.

I tried to use my user name with no password (my user account has no password) to no avail. I tried to use my network name as username with my WPA key as password, to no avail. I tried to create a new user named test with the password test and use these, also to no avail.

Then I tried stuff I read on line:

I went to CMD as admin and entered these commands:

powershell.exe Set-SmbClientConfiguration -RequireSecuritySignature $true

powershell.exe Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" RequireSecureNegotiate -Value 0 -Force

and these to turn of SMB (a synonym of CIFS):

sc config lanmanworkstation depend= bowser/mrxsmb10/nsi

sc config mrxsmb20 start= disabled

All this did not work and I am at a loss, thinking of reverting to Windows 7.

I would appreciate your help.