Windows 8 and 8.1 Forums

"Windows can't remove your computer from the homegroup"

  1. #1

    Posts : 2
    Windows 8

    "Windows can't remove your computer from the homegroup"


    I have a Samsung Series 9 13in laptop running windows 8, and I'm attempting to stream video to my xbox 360 (it's one of the new, "slim" ones). I've read you need your homegroup set up in order to facilitate this, but I'm having nothing but trouble with it.

    When I try to change any settings on the homegroup, most of the settings are greyed out, and the ones a can change reset as soon as I do it.

    Screenshot is here:

    How do I enable these settings?

    Any tips for streaming from win8 to xbox?

    Attached Thumbnails Attached Thumbnails homegroup.png  

      My System SpecsSystem Spec

  2. #2

    This tutorial should help:

    Homegroup - Create in Windows 8
      My System SpecsSystem Spec

  3. #3

    Posts : 2
    Windows 8

    That tutorial didn't address my problem, I am unable to leave the homegroup or change any settings. The dialogue box simply tells me "Windows cannot remove your computer from this homegroup."

    Any suggestions?

    I have tried conbinations of disabling, re-enabling and restarting Homegroup services, and cleared out the NetworkingProfiles roaming folder, still no luck.
      My System SpecsSystem Spec

  4. #4
      My System SpecsSystem Spec

  5. #5

    I think were dealing with a bigger problem than just not leaving the Homegroup.

    Does Network Discovery stay on in the Advanced Sharing Settings?

    In general just removing the files at peer networking can fix the "not leaving Homegroup" problem but with everything greyed out we may be dealing with a different problem this time.

    Homegroup Not Working - Windows 7 Help Forums
      My System SpecsSystem Spec

  6. #6

    Posts : 31
    Windows 8.1 Pro

    I had the same problem : I tried many other steps, but finally what worked was this awesome tip from Microsoft Answers :

    I had a similar issue just recently and none of the fixes mentioned anywhere worked.First thing was to figure out exactly what clicking "Leave the homegroup" does. I opened Process Monitor, added a filter to include results from explorer.exe (as that's the process that spawns the control panel window) then started capturing. Clicking on that link caused explorer.exe to create a new thread then destroy the thread with nothing in between, so I disabled the filters and saw that it was calling svchost.exe. svchost.exe then traversed the registry until it hit a snag. One registry key was giving an access denied error.
    Instead of fiddling with permissions, I exported that key, deleted it, then re-added it, and lo and behold, no more access denied error. After this, I did the usual routine of stopping the three Peer* services, deleting the C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking folder, then restarting said processes. This time, clicking on Leave the homegroup worked as intended. With a few more tweaks (disabling and stopping the two HomeGroup services), any mention of HomeGroup in the navigation pane in Explorer was gone.
    Ironically, starting the HomeGroup Listener service still gave me some about %%-2147023143. But nevertheless, I'd fixed my issue so all was well.
    When in doubt, bust out Process Monitor.
    Smart guy(/gal?)!
      My System SpecsSystem Spec

"Windows can't remove your computer from the homegroup"
Related Threads
i installed a video converter sometime ago named "wondershare" video converter & I recently noticed in "internet options" under the "security" tab when i select "trusted sites", a website is listed that I have never entered & allowed. I remove the website and when i apply the changes then close the...
Hi all, So I'm kind of stuck.. I currently have the problem where I am in an endless cycle of "loading files" -> "Windows Boot Manager" (see: How To Boot Into Safe Mode On Windows 8 (The Easy Way)). I have tried to load all of the options -- and none successfully load. I also end up at...
I recently installed Windows 8.1. I didn't like all the folders under Computer so I registry tweaked it to remove all the libraries folders. However, later on, I accidentally dragged the Downloads folder from Favorites onto the Computer tab and now there's a Download folder listed under Computer...
Hello, I just upgraded my legal copy of Windows 8 to Windows 8.1. I've also installed all the currently available updates. The problem I'm faced now is the watermark on my wallpaper near the clock (Bottom-right side of the desktop). It currently says: "Windows 8.1 SecureBoot isn't configured...
I've been able to remove Homegroup's icon from File Explorer, but not from the "save as" menu. Since I disabled the Network icon using the same steps, I've noticed there's a specific registry key for this menu when using 64-bit, and the folder name is the same...
During the Customer Preview (CP for short) I ran Windows 8 in a Virtual Machine on a Windows 7 system. When the preview was over I simply deleted the image of the Win8 system. Now that I have Windows 8 Pro, I've joined my Homegroup and now the CP install I had been running on the homegroup as...
What's a quick and easy way to remove windows.old since Disk Cleanup seems to be missing the option to do so in Windows 8 Consumer Preview. Edit: I gave myself permissions via CMD which failed(Every file access denied, even in an admin CMD), so I tried one last time to run a Disk Cleanup and...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook