Windows 8 and 8.1 Forums


Problems with Windows wireless service turning off

  1. #1


    Posts : 3
    Windows 8, Linux Mint 14, OpenSUSE

    Problems with Windows wireless service turning off


    Hello, I installed Win8 a few weeks ago, and I have had quite a few problems, but most I have been able to figure out myself. Now, however, I have an issue that doesn't really cause any cataclysmic problems, but it sure is irritating. Consistently, when I turn on my PC, I can connect wirelessly to my home network, but after anywhere from a few seconds to ~30 minutes, I lose connection and the little icon in the bottom right corner of my monitor becomes the symbol that I believe denotes I am connected via a wired connection...which simply is not the case. I then have to open the "change adapter settings" page and manually restart my WLAN card, then use the "diagnose" feature, and every time it finds that "the Windows wireless service is not running on this computer." I then fix this and all is hunky dory once again...but not for long. After another few seconds to a few minutes, the same exact happens again. Then again a third time. It is always exactly three times.

    So, what exactly is going on? Is the wireless service crashing, or just turning itself off? I have a couple of different distros of Linux also installed on this PC, and I don't have any similar problems there, and when the signal is working it is strong. This also happens when I move my computer anywhere else, even right next to the router. Any help would be appreciated.

      My System SpecsSystem Spec

  2. #2


    England, Northamptonshire
    Posts : 536
    Windows 8.1 Pro 64-bit ; Windows Server 2012 R2 Standard


    Could you please go to services.msc and verify that the WLAN AutoConfig service is running? If not then please start the service to see if that solves your issue. Also could you go to the properties of that service and verify that startup type is set to 'Automatic'

    Services - Start, Stop, and Disable in Windows 8 - Follow option one of this tutorial only but replace any service reference with 'WLAN AutoConfig'


    Hope This Helps,
    Josh!
      My System SpecsSystem Spec

  3. #3


    Quote Originally Posted by whamajama View Post
    Hello, I installed Win8 a few weeks ago, and I have had quite a few problems, but most I have been able to figure out myself. Now, however, I have an issue that doesn't really cause any cataclysmic problems, but it sure is irritating. Consistently, when I turn on my PC, I can connect wirelessly to my home network, but after anywhere from a few seconds to ~30 minutes, I lose connection and the little icon in the bottom right corner of my monitor becomes the symbol that I believe denotes I am connected via a wired connection...which simply is not the case. I then have to open the "change adapter settings" page and manually restart my WLAN card, then use the "diagnose" feature, and every time it finds that "the Windows wireless service is not running on this computer." I then fix this and all is hunky dory once again...but not for long. After another few seconds to a few minutes, the same exact happens again. Then again a third time. It is always exactly three times.

    So, what exactly is going on? Is the wireless service crashing, or just turning itself off? I have a couple of different distros of Linux also installed on this PC, and I don't have any similar problems there, and when the signal is working it is strong. This also happens when I move my computer anywhere else, even right next to the router. Any help would be appreciated.
    You mentioned that when the wireless quits working that it keeps showing you as connected with a wired connection. Do you have an active Ethernet cable connected to this machine?
      My System SpecsSystem Spec

  4. #4


    Posts : 3
    Windows 8, Linux Mint 14, OpenSUSE


    Quote Originally Posted by Shadowjk View Post
    Could you please go to services.msc and verify that the WLAN AutoConfig service is running? If not then please start the service to see if that solves your issue. Also could you go to the properties of that service and verify that startup type is set to 'Automatic'

    Services - Start, Stop, and Disable in Windows 8 - Follow option one of this tutorial only but replace any service reference with 'WLAN AutoConfig'


    Hope This Helps,
    Josh!
    Thank you for the quick reply, this seemed to fix it, at least for now. Interestingly, it was not running but it was set to start up automatically.
      My System SpecsSystem Spec

  5. #5


    England, Northamptonshire
    Posts : 536
    Windows 8.1 Pro 64-bit ; Windows Server 2012 R2 Standard


    I am glad your problem is solved. I'll get this thread to marked as solved however if you have any further queries relating to this issue then please do not hesitate to post back and someone will help

    Josh!
      My System SpecsSystem Spec

Problems with Windows wireless service turning off
Related Threads
Since upgrading from Windows 7 to Windows 8, I'm having serious problems with my wireless connection. Occasionally I have problems with my wireless connection dropping out. If this happends I am unable to re-estabalish a connection unless I reboot the computer. Sometimes even this does not...
Hello, I do not seem to be able to turn off Windows Firewall on Windows 8. At least, I can turn it off, but then Network detection automatically switches on. I would like to turn both network detection and windows firewall off, but I cannot seem to find the reason why that is not possible. I...
So, I'm trying to use the method shown at How to Turn Your Windows 8 Laptop into a Wireless Access Point I get the same results he shows in the screenshots and it shows up as running. Problem is when I try to connect to it from another device it gets stuck on "Authorizing..." and gets stuck in...
Windows Wireless Driver Problems! in Network & Sharing
Hi all, I have a Lenovo Ideapad Z510, running on Windows 8 64-bit. When I bought it, I had trouble connecting to one particular wi-fi connection. The laptop worked fine with other connections, but it didn't work well with this one connection (that my other laptops could use no problem). It...
Hey, I have a problem which I hope some of you may be able to answer. I have a desktop running Windows 8 x64 which no matter what I try just wont remember the WIFI I connect to at home. Each time I boot up the PC I have to enter the details again I tried everything (several times), new drivers...
Windows 8 Wireless problems HELP in Network & Sharing
Right, so I have this wireless adapter - Edimax EW-7811UN Wireless 802.11b/g/n 150Mbps Nano USB Adaptor: Amazon.co.uk: Computers & Accessories On Windows 7 I plug it in, install the EDIMAX driver and have no problems. On Windows 8 I plug it in and it works WITHOUT the need for the EDIMAX...
Hi, I have a Dell XPS M1530 which ran Windows Vista 32 bit OS. I have recently upgraded to Windows 8 OS and everything works fine except the following: Whenever I restart/ shut down/ put my laptop to sleep; the next time I turn it on, the wifi driver does not get switched on and I need to...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook