Windows 8 and 8.1 Forums


Hosted network doesn't set IP address

  1. #1


    Mumbai, India
    Posts : 98
    Windows 8.1 Pro, OS X Yosemite 10.10.4, Ubuntu GNOME 15.04

    Hosted network doesn't set IP address


    This problem happened today. I was having some network related issues and ran the script here Network Posting Tips

    While it solved my problem, I have a new one. I generally create a hosted network with this command:

    netsh wlan set hostednetwork mode=allow ssid=foo key=foo
    netsh wlan start hostednetwork

    However, after running that script and restarting, it is unable to set the IP address (please see screenshot).

    Also, there are many logs in Event Viewer which says this:
    The DHCP allocator has disabled itself on IP address 169.254.212.34, since the IP address is outside the 192.168.137.0/255.255.255.0 scope from which addresses are being allocated to DHCP clients. To enable the DHCP allocator on this IP address, change the scope to include the IP address, or change the IP address to fall within the scope.

    Please help me. I need to get this hosted network up and running!
    Attached Thumbnails Attached Thumbnails Untitled.png  

      My System SpecsSystem Spec

  2. #2


    The IP address showing is usually what you get when either the modem or router requires a reset. Most likely the modem requires a reset in this case.
      My System SpecsSystem Spec

  3. #3


    Mumbai, India
    Posts : 98
    Windows 8.1 Pro, OS X Yosemite 10.10.4, Ubuntu GNOME 15.04


    Right, so I reinstalled my WiFi drivers and it started working again. But, I have another problem now. Whenever I start my hosted network, some Metro apps like Weather, News etc. show "Offline" when I am actually connected to the Internet. What's the reason for this?
      My System SpecsSystem Spec

  4. #4


    Mumbai, India
    Posts : 98
    Windows 8.1 Pro, OS X Yosemite 10.10.4, Ubuntu GNOME 15.04


    Quote Originally Posted by pratnala View Post
    Right, so I reinstalled my WiFi drivers and it started working again. But, I have another problem now. Whenever I start my hosted network, some Metro apps like Weather, News etc. show "Offline" when I am actually connected to the Internet. What's the reason for this?
    Any solution to this new issue?
      My System SpecsSystem Spec

  5. #5


    Mumbai, India
    Posts : 98
    Windows 8.1 Pro, OS X Yosemite 10.10.4, Ubuntu GNOME 15.04


    And now Metro apps don't say offline but just don't connect to the Internet even when hosted network is off!
      My System SpecsSystem Spec

  6. #6


    England, Northamptonshire
    Posts : 536
    Windows 8.1 Pro 64-bit ; Windows Server 2012 R2 Standard


    Quote Originally Posted by pratnala View Post
    And now Metro apps don't say offline but just don't connect to the Internet even when hosted network is off!
    Does this happen with other users?
      My System SpecsSystem Spec

  7. #7


    Mumbai, India
    Posts : 98
    Windows 8.1 Pro, OS X Yosemite 10.10.4, Ubuntu GNOME 15.04


    My laptop has only one user. The devices connected to the hosted network can access the Internet normally.
      My System SpecsSystem Spec

Hosted network doesn't set IP address
Related Threads
I am asking this question with a lot of expectation that I will get a solution for this issue. I have got seen a lot of questions being asked about this but there is no proper answer. I use a USB modem in Windows 8.1 laptop. I want to share the internet to other devices by creating a...
53596 how to change the max cilents ?
First of all, apologies because i don't know where else to post this... However since this community has been really helpful to me, i thought i should post it here.. I own a Wifi connectivity from an ISP whose login method is to 1st connect to the wifi network and then login to its own...
Hello, for the last few days I have had a bit of trouble with my network connection on my laptop. I recently moved up to my college and am now on their network. However, I didn't have this problem at first. But recently if I go to my network connections, there is always a wired connection listed...
Hosted Network Starting issue in Network & Sharing
Hi, I was trying to share my datacard connection by creating a hosted network. The command netsh wlan set hostednetwork mode=allow ssid='' key='' was successful I tried to run the command to start hosted network netsh wlan start hostednetwork - I got the error as below.
Have 3 PCs on home network and recently upgraded computer 2 to Windows 8 Computer 1 has lan connection, Windows 7 (can see all computers on network, can't access Computer 2) Computer 2 Wi-fi connection, Windows 8 (can't see or access other 2 computers on network) Computer 3 lan connection,...
Hi, I am having a strange issue with my windows 8 pc as it sometimes doesn't detect any network present and i have to restart it again to get the network. The issue happens usually every time i boot. But restarting once solves it. Any help?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook