Windows 8 and 8.1 Forums


""Ethernet" does not have a valid IP config" help

  1. #1


    Posts : 18
    Windows 8

    ""Ethernet" does not have a valid IP config" help


    So I've been using this router, Belkin N+ wireless router F5D8235-4 v2, for a while now and It hasn't had problems most of the time and I've been using it fine with my DSL modem. My mother connects with her Nook tablet, my father with his laptop, and sometimes my phone and no problems. Until the other day when I randomly went to go on my computer I had no internet connection so I
    1) Reset modem and router like I always do, still nothing.
    2) Tried windows trouble shooting and gave me this message """"Ethernet" does not have a valid IP config".
    3) I unplugged my Ethernet cable from my modem to the router and directly connected it from modem to computer and everything works fine and doesn't randomly lag out like before.

    Could my router have become faulty? or did somehow the settings messed up for my router and I have to manually put ip addresses somewhere. Help please.

      My System SpecsSystem Spec

  2. #2


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    I suggest:
    1. Go to Belkin website and check if they have new firmware update. If so, update it.
    2. Open the elevated command prompt and type ipconfig /flushdns then type ipconfig /renew
      My System SpecsSystem Spec

  3. #3


    Posts : 18
    Windows 8


    No luck. I can't update the firmware without internet connection. Tried ipconfig/renew and says "and error has occurred while renewing interface Ethernet : unable to contact your DHCP server. Request has timed out"
      My System SpecsSystem Spec

  4. #4


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Connect your PC directly to the modem (without router) and download the firmware then reconnect your router and login into it: http://192.168.2.1 to update the firmware.

    Double check if you have the cable connected into the dedicated port on the router from the modem also.
      My System SpecsSystem Spec

  5. #5


    Posts : 18
    Windows 8


    Yeah, I have the firmware downloaded but I just cant access that link for the router. It won't load. and it is in the dedicated port
      My System SpecsSystem Spec

  6. #6


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    To isolate the problem. Can you use a laptop (if available) and connect directly to the router ?
    and when you reset the router, did you just power cycle it or you actually pressed and held the reset button on the router ?
    Last edited by topgundcp; 12 Apr 2013 at 22:00.
      My System SpecsSystem Spec

  7. #7


    Posts : 18
    Windows 8


    I tried both power cycle and pressed and held reset button. Going to get a friends laptop real quick
      My System SpecsSystem Spec

  8. #8


    Sometimes it takes the full 30-30-30 treatment.

    The 30-30-30 Hard Reset Rule for Routers

    and unplug the modem for few minutes while this is going on, then power modem till lights are on plug in router etc.

    Good luck been here before.
      My System SpecsSystem Spec

  9. #9


    Posts : 18
    Windows 8


    I apologize for not replying to this thread. I have been quite busy the past week with death of a co-worker and added work hours. So I tried connecting my laptop directly to my router and didn't work. The modem light and internet light on my router is always yellow instead of blue. I also tried the 30-30-30 thing that guy posted and still nothing.
      My System SpecsSystem Spec

  10. #10


    Posts : 18
    Windows 8


    aslo, before I knew it wasn't my computer I reformatted my computer back to Windows 7 to try and fix the problem.
      My System SpecsSystem Spec

""Ethernet" does not have a valid IP config" help
Related Threads
Hi guys. So when I turned on my desktop today, I got the limited network sign. I am using Powerline, so it showed as Ethernet, just as usual. I had the powerline adaptors unplugged, since I moved my PC to another room for a day, and then back again in the old place where it used to work perfectly....
You have probably heard this problem a lot of times and it have bin talked about in a lot of forums. But after searching and trying almost every posable fix I could find, nothing would fix the problem ""Ethernet" doesn't have a valid IP configuration". After playing a match in "League of...
Hi all, So I'm kind of stuck.. I currently have the problem where I am in an endless cycle of "loading files" -> "Windows Boot Manager" (see: How To Boot Into Safe Mode On Windows 8 (The Easy Way)). I have tried to load all of the options -- and none successfully load. I also end up at...
Hello, Recently I have been intermittently getting disconnected from the internet while gaming / streaming. If I ran the troubleshooter, the error that I got was "Default gateway not available". Resetting my router/modem and restarting the PC every time it happened seemed to resolve this for a...
Hey guys i'm stumped on what is going on with my network connection. I have tried updating the drivers, refreshing my computer, installing all updates. Type of computer: HP Pavilion 20-b010Windows IP Configuration Host Name . . . . . . . . . . . . : Desktop Primary Dns Suffix . . . ....
Hi Everyone, I bought a a Lenovo IdeaPad P400 Touch laptop last week, with Windows 8 64-bit OS. I went through the general setup and had the computer working in no time; wireless and Ethernet connections worked fine for a few days and then I began getting "Limited" connectivity errors on both...
Hi, I'm using an ethernet cord to connect to my internet and it has been working well until Thursday morning when I turned on my laptop (Windows 8) to see a yellow triangle sign in the bottom right hand corner, in front of the ethernet connected symbol. Since then I haven't been able been able...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook