Windows 8 and 8.1 Forums


Problems connecting with network devices

  1. #1

    Problems connecting with network devices


    Hi,

    I'm having trouble connecting my wifi printer (Canon pixma mg3100) and my Lacie Network Space on Win8, while I haven't experienced any problems connecting these same devices to my Win7 computers.

    The driver for the printer is, according to Canon, compatible with windows 8.

    When I install the software on both my windows 7 laptops, it immediately recognize the network and after 5 minutes I can print wireless without any problems.

    However when I try to install the same software on my win8 computer it keeps asking to first plugin a usb cable and do a lot of manual steps, like pressing several buttons on the printer, it's ridiculous! After a while the software succeeds in finding my Wifi but it keeps on saying 'unable to connect'

    Same story for the Nas. (and problably for all network devices)

    My win8 laptop is a brand new Dell Inspiron and I didn't change any network settings.

    Am I missing something here?

    Raymond

      My System SpecsSystem Spec

  2. #2


    There are new drivers for Windows 8 from Canon in the link below, these drivers are dated 4-5-2013, for MG 3100 series printers.

    Canon U.S.A. : Support & Drivers : PIXMA MG3120



    Windows 8 / Cannon PIXMA MG3100 Series Printer - Microsoft Community
      My System SpecsSystem Spec

  3. #3


    Hi,

    Thanks for replying!

    I already have the latest drivers, I'm certain this has something to do with the network configuration on my (win8) laptop because everthing works just fine on my win7 laptops (with the same win7/8 drivers)
      My System SpecsSystem Spec

  4. #4


    From Microsoft site: " If your printer is a network or wireless printer that is already on your home network, no other work is required."
    My wireless printer is already on my home network, since it works perfect with windows7...
      My System SpecsSystem Spec

  5. #5


    Quote Originally Posted by Raymond1984 View Post
    Hi,

    Thanks for replying!

    I already have the latest drivers, I'm certain this has something to do with the network configuration on my (win8) laptop because everthing works just fine on my win7 laptops (with the same win7/8 drivers)
    Did you try setting up a Homegroup between the Windows 7 and 8 machines?

    Do you have any type of third party anti virus software installed on the Windows 8 machine?
      My System SpecsSystem Spec

  6. #6


    Nope, should I? Yes, I have Avast on both my win7 & win8 laptop...
      My System SpecsSystem Spec

  7. #7


    I would think about disabling Avast or configuring it to allow printer sharing. Just the other day it was the Norton firewall causing this same problem with a Network printer.

    Setting up a Homegroup may also help.

    If it were me I'd dump Avast and set up a Homegroup between those machines, it's very likely the problem would be solved in a few minutes.
    Last edited by chev65; 12 Apr 2013 at 11:11.
      My System SpecsSystem Spec

  8. #8


    But if I set up a homegroup, my old pc has to be turn on before I can print something? I'd rather work without homegroups and let every pc connect to the printer (and nas) separately if possible

    I'll try turning off avast.

    Thanks for your help so far!
      My System SpecsSystem Spec

  9. #9


    Quote Originally Posted by Raymond1984 View Post
    But if I set up a homegroup, my old pc has to be turn on before I can print something? I'd rather work without homegroups and let every pc connect to the printer (and nas) separately if possible

    I'll try turning off avast.

    Thanks for your help so far!
    Homegroups has no effect on this.

    Is this printer plugged into another machine for some reason? If so that would be incorrect, you need to plug the printer into either a switch or the router.
      My System SpecsSystem Spec

  10. #10


    No, it's a wifi printer, so I'm intended to use it that way

    Maybe helpful to know that I'm unable to ping my NAS On my win8 laptop.

    Ps. Turning off avast didn't do the trick.
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
Problems connecting with network devices
Related Threads
Hello, I have two desktop PCs connected to my router, one named Mirabel running Win7 Pro, and one named Bessie running Win Server 2008 R2 (both 64-bit). These can see each other quite happily. I just installed Win8.1 Pro 64-bit on my Dell Vostro 3750 lap top, which I named Rosie, but am...
Have a question regarding "Local Account". I'm having problems connecting to the Win 8 laptop from Win 7 as it will not accept my sign in credentials. With that, am I to assume that this is because the credential aren't "Local", and thus this is what this is for??? 21428 It will not accept...
Not connecting to Network in Network & Sharing
I've had Windows 8 Consumer Preview installed for a couple weeks now and all of a sudden my computer stopped connecting to my home network. I have a wired connection and when I mouse over the network icon in the tray in the bottom right, it just says"Identifying... No internet." I can connect to...
hi, I'm using win8 release preview. It shows available WiFi networks to me but when i try to connect it shows cannot connect. I have tried reinstalling WiFi drivers in win 7 compatibility mode, after this step it connects to network for 2 min or so and then disconnects and doesn't allow me to...
I have noticed that when a program or something using sound is running, if I unplug my speaker device and then either plug it back in, or plug in a new audio playback device, the sound will stop working altogether and within a matter of about two minutes, the entire computer will become...
BSOD when connecting to network in Network & Sharing
I have a fresh install of windows 8. Using a Netgear WMA1100 network adapter, with netgear Qwest router. I have the latest drivers from Netgear, and my system says drivers are up to date and everything is working well. Ive even rolled back to two previous versions of the drivers and It still wont...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook