Windows 8 and 8.1 Forums


can't get a simple peer-to-peer connection to work

  1. #1


    Posts : 1
    windows 8

    can't get a simple peer-to-peer connection to work


    Hi,

    I recently purchased a laptop with windows 8 pre installed. I bought a crossover cable to connect it with my other linux laptop.

    Linux: 10.10.0.1, 255.255.255.0

    I configured Win8 from
    start > control panel > network and internet > view network status and tasks >
    unidentified network > ethernet > properties > internet protocol version 4:

    ip: 10.10.0.10
    netmask: 255.255.255.0
    gateway: 10.10.0.10

    These are the only steps that I need to do as far as I remember, back from the winxp days.

    I turned off (norton) firewall and wifi for good measure.

    I'm sad to report that this doesn't work. I feel that I'm missing something but I don't know what. Google search doesn't yield much.

    to prove that the linux laptop and the cable isn't the problem, I booted up a linux liveusb on the win8 laptop's hardware, and configured peer to peer there. it works.

    Anything I'm missing?

    TIA

      My System SpecsSystem Spec

  2. #2


    Posts : 1
    Dual boot: Windows 8 Home Premium/Fedora 18


    I came here from Google looking for a solution to this and thought since nobody has responded I will offer a solution that worked for me.

    If you are running from the command line on Linux you need to configure your network as such:
    IP=10.10.0.1
    NETMASK=255.255.255.0
    GATEWAY=10.10.0.1

    and on Windows:

    IP=10.10.0.2
    NETMASK=255.255.255.0
    GATEWAY 10.10.0.1


    The gateway and netmask both need to be configured the same on both machines.
    N
      My System SpecsSystem Spec

can't get a simple peer-to-peer connection to work
Related Threads
Hello, I have just recently installed Windows 8 Pro and have had no problems, except my internet browsers. I am connected to the internet and can use some programs using it such as skype, but none of my browsers will work. (Internet explorer, Google chrome, Firefox.) In google chrome i get...
My Internet is fine. I can connect with my iPhone, and with Ubuntu OS. It's just the button in the bottom right hand corner (the wireless signal bars) doesn't do anything after I click it on my windows laptop.. It happens every so often disallowing me from connecting to the Internet in times...
My Internet connection icon/button (either on the desktop to the right of the task bar or on the settings when you slide in from right) doesn't work... I mean when I click it it does absolutely nothing. Also, when I open the network and sharing center after clicking change adapter settings it...
I sometimes tether to my smartphone (HD2, running Windows Mobile 6.5) with an app called WMWiFiRouter, which creates a wi-fi hotspot using the 3g connection of the phone. Despite "router" being in the app's name, it sets the connection up as a peer-to-peer (adhoc) network. This works with...
I had a problem with my old user account and followed instruction that said I needed to create a new account in order to fix my "Microsoft Store" account. I did this, I created a new user account and deleted the old broken one, because this new account fixed my problems. Unfortunately I can...
Hi, I have a problem that I haven't found a cure for anywhere: I have a Sony Vaio with Windows 8 installed, and last night I tried to intall Open Office, Firefox and a program called Paint.net on it. The system wanted to restart, and it installed some updates, but after the updates were...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook