Windows 8 and 8.1 Forums


"Ethernet" doesn't have a valid IP configuration

  1. #1


    Posts : 2
    Windows 8

    "Ethernet" doesn't have a valid IP configuration


    Hi,

    I'm using an ethernet cord to connect to my internet and it has been working well until Thursday morning when I turned on my laptop (Windows 8) to see a yellow triangle sign in the bottom right hand corner, in front of the ethernet connected symbol. Since then I haven't been able been able to access the internet from my computer. When I hover over it, it says that it is an "Unidentified network" and there is "No internet access". I've run the Windows 8 troubleshooting and it says that the problem found was ""Ethernet" doesn't have a valid IP configuration", but I'm unsure how to fix it.

    I'm thinking that the problem is to do with my computer rather than my network, because I've tried another laptop (Windows 7) through the same ethernet cable and connection and the internet works fine on the other laptop. I've tried so many fixes that I've found online, with none of them actually working. Yesterday I even tried a full system reset, where I reinstalled Windows 8, repartitioned and wiped everything off the hard drive, but it still appears have the exact same problem.

    Today I also purchased and tried a new ethernet cable which didn't work, so I then purchased a USB to Ethernet adapter, to make sure that it wasn't my ethernet port on my laptop that was faulty. That didn't work either, and the same problem still remains.

    I feel like I've tried everything, so can someone please help me?

    Thanks in advance,
    Xuzuno

      My System SpecsSystem Spec

  2. #2


    Hi,
    With your Windows 7 laptop make note on IP address, subnet mask, default gateway, and DNS.
    Unplug Windows 7 laptop from network and connect Windows 8 laptop instead. Configure manually exactly same as above.
    If it works, then problem on DHCP configuration.

    Cheers.
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8


    Thanks for your response Nugroho. I'll be sure to give that a try later on when I have access to the Windows 7 laptop. So I'll be able to find all that information by typing "ipconfig /all" in the command prompt?
      My System SpecsSystem Spec

  4. #4


    Yes, ipconfig /all will give you all information.
      My System SpecsSystem Spec

  5. #5


    Quote Originally Posted by Xuzuno View Post
    Hi,

    I'm using an ethernet cord to connect to my internet and it has been working well until Thursday morning when I turned on my laptop (Windows 8) to see a yellow triangle sign in the bottom right hand corner, in front of the ethernet connected symbol. Since then I haven't been able been able to access the internet from my computer. When I hover over it, it says that it is an "Unidentified network" and there is "No internet access". I've run the Windows 8 troubleshooting and it says that the problem found was ""Ethernet" doesn't have a valid IP configuration", but I'm unsure how to fix it.

    I'm thinking that the problem is to do with my computer rather than my network, because I've tried another laptop (Windows 7) through the same ethernet cable and connection and the internet works fine on the other laptop. I've tried so many fixes that I've found online, with none of them actually working. Yesterday I even tried a full system reset, where I reinstalled Windows 8, repartitioned and wiped everything off the hard drive, but it still appears have the exact same problem.

    Today I also purchased and tried a new ethernet cable which didn't work, so I then purchased a USB to Ethernet adapter, to make sure that it wasn't my ethernet port on my laptop that was faulty. That didn't work either, and the same problem still remains.

    I feel like I've tried everything, so can someone please help me?

    Thanks in advance,
    Xuzuno
    I hate to state the obvious but have you tried to reset the router or modem using the push button on the side of the router?
      My System SpecsSystem Spec

"Ethernet" doesn't have a valid IP configuration
Related Threads
Hi guys. So when I turned on my desktop today, I got the limited network sign. I am using Powerline, so it showed as Ethernet, just as usual. I had the powerline adaptors unplugged, since I moved my PC to another room for a day, and then back again in the old place where it used to work perfectly....
You have probably heard this problem a lot of times and it have bin talked about in a lot of forums. But after searching and trying almost every posable fix I could find, nothing would fix the problem ""Ethernet" doesn't have a valid IP configuration". After playing a match in "League of...
I have no idea what the problem is with my network. I know I have the password right and I am definitely in range. Other devices work on the network also. I have the network diagnostics report and a screenshot of my IP configuration included. Please help! PrintWindows Network Diagnostics...
I've had my modem connected straight to my computer via ethernet cable and never really had any problems. I recently downloaded itunes to listen music on my ipod and i know this probably isn't the problem but weeks later i was prompted to download an update for itunes and of course I clicked...
Hey guys i'm stumped on what is going on with my network connection. I have tried updating the drivers, refreshing my computer, installing all updates. Type of computer: HP Pavilion 20-b010Windows IP Configuration Host Name . . . . . . . . . . . . : Desktop Primary Dns Suffix . . . ....
Hi Everyone, I bought a a Lenovo IdeaPad P400 Touch laptop last week, with Windows 8 64-bit OS. I went through the general setup and had the computer working in no time; wireless and Ethernet connections worked fine for a few days and then I began getting "Limited" connectivity errors on both...
Hi all, I recently got windows 8 and have found it to be rather volatile. I use WiFi in my house on my desktop Intel PC and my computer strangely sometimes works to get to the internet and sometimes it doesn't coming up with connection limited and after troubleshooting it "doesn't have a valid ip...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook