Windows 8 and 8.1 Forums


WiFi dies after returning from sleep/hybernation

  1. #1


    MA
    Posts : 6
    Windows 8 Professional 64-Bit

    WiFi dies after returning from sleep/hybernation


    So this has been a problem ever since I installed Windows 8 Pro on my Dell XPS15 L502X. Everything works fine but when I put the computer to sleep, if I come back after a lengthy period of time the computer will turn off, and when I turn it on it boots instantaneously but will not connect to the wifi networks. The Wifi icon has the little star to indicate that it is on and not connected and when you mouse over it, it says there are available networks however clicking it does not bring up the network selection panel. Mousing over to the right and clicking on settings does the same thing, wont bring up the network selection panel. Going in via control panel, the same thing. Logging out and logging in does not solve it either. It requires a full reboot. After a reboot it works fine again. This is not a problem with sleep if it is just for a short period of time, but for a longer (sorry I can't give you an exact time) it happens, and it is very annoying. Also it will not auto-connect to networks it recognizes in this mode.

      My System SpecsSystem Spec

  2. #2


    MA
    Posts : 6
    Windows 8 Professional 64-Bit


    Sorry for the bump, but I have something to add and no one replied yet. I found another thing,when you disable wifi using a hot key it wont change the sign on the bottom right. Basically disabling and enabling wifi does nothing.
      My System SpecsSystem Spec

  3. #3


    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP


    Quote Originally Posted by DeathShot View Post
    So this has been a problem ever since I installed Windows 8 Pro on my Dell XPS15 L502X. Everything works fine but when I put the computer to sleep, if I come back after a lengthy period of time the computer will turn off, and when I turn it on it boots instantaneously but will not connect to the wifi networks.
    Try turning fast startup off: Fast Startup - Turn On or Off in Windows 8. Not sure this is your answer, but give it a try.
      My System SpecsSystem Spec

  4. #4


    MA
    Posts : 6
    Windows 8 Professional 64-Bit


    Thanks znod, I just disabled it. I will reply here if it works or does not work. BTW, I was thinking about it and I believe this only happens if the computer is disconnected from the active network while sleeping (via being taken too far away) and then tries to connect to any network again. That would account for the extended periods of time, because the only time my laptop is put to sleep for extended periods of time is when i leave the house.
      My System SpecsSystem Spec

  5. #5


    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP


    You are very welcome. The computer should disconnect from the network regardless of distance from the network when sleeping. Do you have an external Wifi connection light? If yes, then check it out. And, yes, do post back.
      My System SpecsSystem Spec

  6. #6


    MA
    Posts : 6
    Windows 8 Professional 64-Bit


    Quote Originally Posted by znod View Post
    Do you have an external Wifi connection light? If yes, then check it out.
    There is one, but the windows 8 drivers don't work with it, it never lights up aside from the LED "swoop" the computer does on boot. Speaking of which I picked the worst time to finally post (this has happened for a while), since we just left for spring vacation, and I live in my computer >.<

    I'll find an excuse to leave soon, to see if I can recreate this.
      My System SpecsSystem Spec

  7. #7


    MA
    Posts : 6
    Windows 8 Professional 64-Bit


    So I left for a while and it did it again, even without fast boot.
      My System SpecsSystem Spec

  8. #8


    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP


    Well heck. No more thoughts for now. I hope spring break at least was good.
      My System SpecsSystem Spec

  9. #9


    MA
    Posts : 6
    Windows 8 Professional 64-Bit


    Thanks for trying, and yeah the break is great
      My System SpecsSystem Spec

  10. #10


    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP


    You are very welcome.
      My System SpecsSystem Spec

WiFi dies after returning from sleep/hybernation
Related Threads
Hello, So I've been working with a computer I've put together for a couple of months now, and I haven't been able to figure out what exactly is causing various BSODs. They mostly happen when coming out of sleep mode. The crashes would generally happen once every couple of days. One time I did...
After windows 8.1 restarts then it doesn't happen again. I already have run the check disk utility and continues to happen. Thanks in advance, George Ch.
hi there, I have a Acer Aspire E1 570 laptop that I use for college, the laptop is less then 8 months old. For some reason recently it starting going dead at 40% battery charge remaining. I ran a powercfg -energy from the command prompt and it said that my batterys designed charge is 37000 and...
For the past few days, my laptop has been crashing upon waking from hybernation. I initially thought it was a trojan or virus, but after poking around more I think its either a HD or driver issue. I installed WhoCrashed and BlueScreenView, which mostly return ntoskrnl.exe, but have also thrown in...
Hello, i have problem with my dualboot. When installing ubuntu 13.04 and window 8 along each other, windows 8 won't hybernate (screen just gets blank and lock itself), tha same with turning computer off (when fast bootup is enabled). When i recover mbr using bootrec.exe /fixmbr (basicly switch back...
I saw some older threads but nothing that relates to windows 8. Anyone have any possible solutions to this issue? I have downloaded the latest Sony divers, tested the router, and asked Sony for assistance but nothing has worked so far.
Hi, I've just installed Windows 8 Pro 64bit edition on a 600gb VelociRaptor hard drive, Asus P6X58D Motherboard, I7 950 cpu my bios is up to date if that matters. The system runs ok except for several times i notice it freezes and then restarts after waking up from sleep mode / hibernate. I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook