Windows 8 and 8.1 Forums

Cannot start the Peer Name Resolution Protocol service

  1. #1

    Posts : 2
    Windows 8, duh?

    Cannot start the Peer Name Resolution Protocol service

    I had a problem with my old user account and followed instruction that said I needed to create a new account in order to fix my "Microsoft Store" account.

    I did this, I created a new user account and deleted the old broken one, because this new account fixed my problems.

    Unfortunately I can no longer access HomeGroup. I couldn't create a HomeGroup because my system kept insisting that the old user account name had created a HomeGroup, but the account was deleted, so I can't join a non existing HomeGroup. I found a solution by leaving the HomeGroup in my other computer on the network and it made the existing homeGroup (old account) go away, letting me create a new HomeGroup, but when I try to create the group I get errors.

    I ran the troubleshooter from the HomeGroup control panel and it ends with the error saying I have a network error which leads to the Windows network diagnostic which ends with the following error:

    Either the Peer Name Resolution Protocol service (PNRPsvc) or the Peer Networking Identity Manager service (p2pimsvc) is not running.

    When I use the administration tools to access services and look at the services p2pimsvc is running and when I try to manually start PNRPsvc I get the following error:

    Windows could not start the Peer Name Resolution Protocol service on Local Computer. Error 0x80630203: Unable to access a key.

    I read a few posts that mention deleting the idstore.sst file from the
    C:\windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking folder but that didn't worked.

    Tried Net stop p2pimsvc and deleting (moved for safe keeping just in case) the files under C:\Windows\ServiceProfiles\LocalService\AppData\Roaming \PeerNetworking didn't work.

    How do I fix this? Can the permissions to this key be repaired? It looks like some kind of permission problem, but how do I find the file in question in order to change permissions?

    I found a thread here that explains how to repair access to HomeGroup folder permissions, but I don't have these folders in Windows 8!

    So where is this key? how do I fix permissions so the service can access it and start?

      My System SpecsSystem Spec

  2. #2

    "Windows cannot set up homegroup on this computer"

    1. Click Start, type services.msc in Start search box and hit Enter.

    2. Right-click the Peer Networking Identity Manager and select Properties.

    3. Set the Startup type to Automatic under Properties.

    4.Check if the service is started; if not, right-click and select Start.

    5. Click OK.

    Hope it Helps!!

    Also restart the Homegroup Listener Service.

    If all else fails try a refresh or reset of Windows 8.

    Refresh Windows 8

    Reset Windows 8
      My System SpecsSystem Spec

Cannot start the Peer Name Resolution Protocol service
Related Threads
Hi, This error appears at every Windows (8.1 update 1) start: Issue Details AODDriver 4.2.0 service failed to start - The system cannot find the specified file. This from Event Viewer: - System
I just upgraded to W8.1 and now I find the my indexing/search service won't start. It tries, but won't start. I have used the Search Troubleshooter and Search Service still fails to start. Also, a right click on the start button, a menu pops up that resembles classic Windows Start Menu. Most...
Hi, I recently purchased a laptop with windows 8 pre installed. I bought a crossover cable to connect it with my other linux laptop. Linux:, I configured Win8 from start > control panel > network and internet > view network status and tasks > unidentified network...
I sometimes tether to my smartphone (HD2, running Windows Mobile 6.5) with an app called WMWiFiRouter, which creates a wi-fi hotspot using the 3g connection of the phone. Despite "router" being in the app's name, it sets the connection up as a peer-to-peer (adhoc) network. This works with...
Audio service won't start in Sound & Audio
I did an upgrade from Windows 7 to Windows 8, and am using the on-board sound (which is realtek), until Auzentech release new Windows 8 driver, the problem is on reboot, Windows 8 loads up and each and every time I get the Windows audio service hasn't started, so it's either use the audio trouble...
My screen resolution is 1280x1024 running Win 8 RP I formatted my computer and reinstalled Win 8 CP because I had too many BSODs. When I installed Win 8 CP and created a local account. I had 5(or 6) tiles per column. But once I switched to the Microsoft account to get my synced wallpaper ...
Start Screen Resolution in Installation & Setup
Hey all, I just installed Win 8 Build 7989 on my Acer W500 tablet. It installed perfectly and seems to work pretty well, other than the OSK occassionally popping up at random and disappearing. My main question is this, is there a minimum resolution required to be able to use the Start Screen? I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook