Windows 8 and 8.1 Forums

Wake On Pattern Match / WOL from WAN was working, now not

  1. #1

    Posts : 4
    Windows 8 x64

    Wake On Pattern Match / WOL from WAN was working, now not

    Hey, a bit of a strange [and long] one that has me at my wits' end. My setup is a bit complicated so here's a diagram to make it easier to explain:

    Click image for larger version

    The Huawei RG256 is supplied by my ISP and I have to keep it in order to use the SIP VOIP service. It's set in DMZ mode to forward almost all traffic to the WAN port of my Asus RT-N66U, which then does DHCP, WiFi, firewall and other network services. The only exceptions are port 21 and port 80, which the Huawei box loops back to its own local IP so I can remotely access the web GUI and FTP into the hard disk that I have hanging off the USB port.

    Eth0 goes through CAT6 in the walls to a gigabit switch, into which my PC and a couple of other devices are plugged.

    I frequently RDP into my home PC from work. I have a DynDNS and the correct port forwarding set up and this all works fine. I leave my PC asleep and I have wake on LAN and wake on pattern match configured on my NIC.

    Until recently, I was able to RDP to [my DynDNS address]:13389 (custom RDP port), the connection attempt would cause my PC to wake up and I was able to connect first time to my sleeping PC with virtually no delay [gotta love SSDs!].

    A couple of weeks ago, my Huawei DMZ router failed and I had to get a replacement from the ISP. While I was waiting they lent me a 3G modem/router, which I configured as DMZ to my Asus router. This was so slow as to be useless so I ended up using my phone to create a 4G WiFi hotspot.

    My ISP replaced my Huawei router and I have reconfigured everything how it was, at least I think I have... Problem is now wake on pattern match is no longer working. Wake on LAN is working fine; I can remotely log in to the web GUI of my Asus router, send a magic packet to the MAC address of my PC's NIC and it wakes up. I can then RDP in no problem.

    I initially assumed that it must be a misconfiguration on my new DMZ router, but as RDP traffic coming from the internet on 13389 is getting correctly routed when the PC is awake, I can assume it's reaching my internal router just fine. As WoPM is not working from inside my LAN either it has to be either my Asus router or my PC, right? The Asus router is the only device that has not been changed at any point since the issue occurred, so I guess that leaves only my PC as the culprit.

    I assume that WoPM relies on the router using ARP to translate the destination IP address into the MAC address of the NIC. It then sends the packets to that physical address regardless of whether the destination host is up. My only theory is that all the messing about with different devices [3G router, 4G hotspot, WiFi NIC] has messed up an ARP table somewhere.

    I have SSH'd into my Asus router and checked the ARP table and it looks fine. I powered the router off for 30 seconds to clear the dynamic ARP entries, and the entry for my NIC reappeared exactly as it was. I have also tried creating a static ARP entry for my PC's NIC but that didn't work either.

    My last thought is to connect an old HDD and do a temporary OS install on that, see if WoPM works on a clean OS. I recall when I configured my DMZ and internal router initially WoPM from LAN & WAN "just worked" - no additional configuration or messing about with SSH and ARP tables was required - so this shouldn't be this hard!

    So to summarize:
    - DMZ router replaced; reconfigured as before as far as I remember
    - Previously disabled WiFi adapter enabled in motherboard BIOS. Now disabled again.
    - NIC config temporarily changed while testing. Now reverted to previous static IP.
    - All WOL & WoPM features enabled in NIC config
    - Temporary 3G router introduced in DMZ. Now removed.
    - WOL working from inside LAN
    - Port forwarding working; allowing RDP access from WAN
    - WoPM not working from LAN or WAN

    Please help... ?

    Thanks for reading

      My System SpecsSystem Spec

  2. #2

    Posts : 4
    Windows 8 x64

    I never really got to the bottom of why this happened, but it provided the incentive I needed to finally get round to flashing my Asus RT-N66U with Tomato firmware. WoPM is working fine now.
      My System SpecsSystem Spec

Wake On Pattern Match / WOL from WAN was working, now not
Related Threads
This has been going on for a very long while and now it is becoming extremely frustrating as from what I can see the Bug Check String is almost different at various occasions and also I cannot seem to reproduce the BSOD and cannot work out a regular pattern. This is happening on Windows 8.1 fully...
Random BSOD and crash. No discernible pattern. in BSOD Crashes and Debugging
Hi and thank you for reading this. My PC started randomly crashing and BSODing with no discernible pattern. It was fine for about 4 months after I built it and had no issues at all. Without warning it rebooted itself while I was away and I returned to find it in the BIOS. Since then I have...
Hi, I have a Dell Inspiron 530 and I cannot get WOL to work. I have installed a new TP-LINK TG-3468 Network Card, which supports WOL. Remote Wake Up is enabled in the BIOS, as are the usual required settings on the Network Card properties. However whenever I hibernate, sleep, or shutdown...
I was just curious, on the forums front page it lists the amount of total viewers. But, when I add up the numbers of the viewing totals for each section, it is almost half of the total as reported. Does that mean there are a lot of sections not visible to most viewers? Just being nosy.
I am running Windows 8 x64 on an Intel DX48BT2 motherboard. The Network adapter is a built-in INtel 82566DC-2. Simply put, WOL works fine as long as I don't let the computer sit in sleep mode for too long. However, if I let it, for example, sit overnight, then it cannot be woken with a magic...
Windows 8: Android-like pattern logon screen demo | WinRumors
Eight Forums Android App Eight Forums IOS App Follow us on Facebook