Windows 8 and 8.1 Forums

FTP will not connect under windows 8

  1. #1

    Posts : 2
    windows 8

    FTP will not connect under windows 8

    Hey all,

    I installed Windows 8 and now all FTP programs will not connect to any FTP accounts. I've connected to the ftp on other computers and its worked fine, so the password and all are correct. I've tried:

    Connecting with FileZilla, FireFTP, and Windows IE
    Turning off firewall entirely.
    Adding or removing special exception to the windows 8 firewall setup.

    No luck, any thoughts?

      My System SpecsSystem Spec

  2. #2

    This link mentions you need to install the SmartFTP client before trying to connect.

    How to connect to FTP in Windows 7 and Windows 8

    For File Zilla, Windows 8 is not officially supported yet although version is supposed to work.

    FileZilla - The free FTP solution

    This link talks about the problem with one guy "last post" saying that worked with Windows 8 Pro.

    FileZilla Forums • View topic - Windows 8 Pro doesn't allow me to download from my FTP Serve
      My System SpecsSystem Spec

  3. #3

    Posts : 2
    windows 8

    As you can tell from my post I've already tried FileZilla. I've tried the windows command line FTP client as well. I've tried IE. I do not think a different ftp client will help.
      My System SpecsSystem Spec

  4. #4

    Posts : 4
    windows 8.1

    Did you ever find a solution

    Quote Originally Posted by msilver View Post
    As you can tell from my post I've already tried FileZilla. I've tried the windows command line FTP client as well. I've tried IE. I do not think a different ftp client will help.
    I have several ways of connecting FTP to Windows 8 that all work but not as I want them to and not as MS says they should.
    they do work.
    Oddly, one of them is Filezilla which I think you said would not work for you. I was wondering what OS is running on the FTP server end as I am still trying to solve the problem of getting a Mapped drive letter to link to the ftp connection.

      My System SpecsSystem Spec

  5. #5

    I have a question, is the server you're trying to connect to on a LAN or on the WEB? IF it is the WEB, then your router could be blocking FTP traffic. If it is on your local LAN, then something is not configured properly. We would need more information concerning why it wouldn't connect on a LAN as to what is the OS of the workstation you're trying to connect to and the OS of the workstation is unable to connect to it. Hope this helps.
      My System SpecsSystem Spec

  6. #6

    Posts : 4
    windows 8.1

    Thanks for your input. The server is on a static IP. Access type needed is via Internet. Local network users just map directly to the drive but cannot do so when not in the office. This used to be a VPN connected drive but when ISP's began blocking outgoing port 445 that put an end to mapping a drive letter due to Samba's protocol needs. I would be glad to hear a better explanation but I sonta lot of time testing the various options and this is the ONLY one that matters.
    The same system on any business network (or some smaller home ISP's) has no problem just connecting the VPN and mapping the shared folder as a drive-letter as usual. But those on most Home Internet can only connect to the VPN and then settle for a "network place". Unless they pack up their laptop and drive to a location with business Internet. I did check all my facts. This is something done Only to HOME internet users. Business users have no such block. And some Home ISP's still don't either. My own doesn't to this day. Which was a big problem in the beginning since i could not replicate the problem experienced by others at my own home. The port 445 block (back then) was not posted as a "fact" on any of the ISP's sites and their techs probably really did not know anything about it.

    I found that the ONLY difference was that their home internet had no outbound on port 445. Not only did i find this true by testing the port, but it is even (belatedly) posted on most ISP's main web pages now with the reason being to "Provide Better Internet Security). Note that only outbound port 445 is blocked. Look up the requirements for SMB drive mapping.

    Knowing why it wont work does not help though. I have no way to circumvent the need for port 445 to provide a mapped drive letter and a "Network place" is not accepted by the program that needs access to the drive. I have tried every way i know to "fake it out" using a network place with no working solution.

    While an FTP connection is slower than direct mapped, it is better than nothing and the software that needs the access will accept a mapped FTP drive letter.
    Once you get the FTP drive contents showing in Windows Explorer it plainly instructs you to click ALT VIEW to change it to File Explorer where you are offered the option of making EASY ACCESS by mapping a drive letter to it by just clicking the option.
    Only that doesn't work. The errors received are always one of the "catch-all" 0x800 etc that just says "something is wrong"
    But it isn't as I just had the files up on my screen in Internet explorer And Windows File explorer which rules out name, password, incorrect network path, etc.
    Out of all the 3rd party tools that CAN complete the task, Net drive 2 is the best. But WinDrive and several others work as well.
    FTPUSE I am not so sure about though it is by far the simplest of the bunch being extremely small but talking about using a DOKAN file type and I am not familiar with that. While I have not been able to get it to work, I know of other who have.

    Anyway, this should be enough to show you that it isn't a router issue. I even tried it with the Server connected directly to the ISP's provide fiber line with nothing in between. I will say that I have not made any changes to the settings on the NIC but those are settings i have never had to change before and don't need to be changed for NetDrive or the others.

    I am inclined to think it is something to do with the the structure of the passed parameters for mapping drives. just as ftp://name@server/shared folder is the correct way to get to many others such as Skydrive. But nothing I have found works.
    As another oddity, I CAN add a 3.5" usb drive to the ready-share port on a router using the same ISP and get access with no problem. I did not register the device with Netgear to do this as we have a static IP. Just entered the ftp://admin@IP address/readyshare/(+ whatever folder I want to map). This is after making the necessary entries into the router for what to access and adding a password of course.
    The problem with that method is that it only allows ONE user. All access must be done using "admin"/"admin's readyshare PW".
    I also found out that if you try to do any large amount of work with it, the router will freeze and require rebooting.
    This is not a programming issue but it does rule out that method of access for sure (which I originally had high hopes for)

    The WD My Cloud and similar offerings depend on the users getting access to the WD servers to get rererouted access to the drive and in my experience was far too slow to be of much use. a LOT slower than the internet connection would dictate.

    I added all the rest of this just to show you that I have tried every possible alternative i could come up with and when they did not work, even tried to find a way to MAKE them work.
    While Netdrive2 is the current winner, I am just curious. I would like to know WHY it does not work as it should. And if it doesn;t why don't they (MS) simply remove the option and directions on how to use it?

    Thanks for reading.
      My System SpecsSystem Spec

FTP will not connect under windows 8
Related Threads
Hi, up until recently the network has been fine. Now whenever I try and connect to this wireless network I get "Can't connect to this network". I tried forgetting the network, and reconnecting, and now all that happens is it asks me for the WEP key before telling me the same error. Because I can no...
Hi All, After much trawling on the net, i have finally given in and am seeking direct help. When i choose the connection's icon from the task bar, to connect to wifi, the connection side bar appears for a brief instant and disappears. At the moment i can connect to the network in my home,...
I'm having a devil of a time with connecting my desktop computer. The computer connects to the network fine, and other computer s in the house are connected to the internet, so it's not the modem or the connection. I spent nearly an hour on the phone with Internode Support, even though this...
Windows Connect in Network & Sharing
I don't know how I picked up this Windows Connect but I can't find a place to destroy it. Where can I find out how to do this Thanks
Hi I moved to windows 8 recently and i am not able to connect to my vpn,I checked with support team and they told to change registry name for vpn and In websites also it was like that I did everything like that but still same issue..can anyone help me in resolving this issue....
I am having a TV box (a satellite receiver capable of playing video files from a network share via Samba) tha I use to play video files. It worked 100% OK with Windows 7 being the "Video File Server". I upgraded to windows 7 and since then I cannot connect to the shared files anymore. I reinstalled...
hi, i have an alienware m15x r2 which i recently upgraded to windows 8 through a clean install. everything works great except for the wireless, and i cannot for the life of me figure out whats run. ive tried about 10 different wifi points on campus and tried wirelessly tethering tommy phone and...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook